01-22-2013 02:53 AM - edited 03-04-2019 06:48 PM
I have a basic topology
R1 ---- DLCI 102 , 103
R2---- DLCI 201
R3 ---- DLCI 301
Configuration on R1
==================
interface Loopback0
ip address 10.1.1.1 255.255.255.0
!
interface Loopback1
ip address 10.1.2.1 255.255.255.0
!
interface Loopback2
ip address 10.1.3.1 255.255.255.0
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 64000
frame-relay lmi-type cisco
!
interface Serial0/0.1 multipoint
ip address 172.16.124.1 255.255.255.248
frame-relay map ip 172.16.124.2 102 broadcast
frame-relay map ip 172.16.124.3 103 broadcast
!
router eigrp 25
network 10.1.0.0 0.0.255.255
network 172.16.0.0
no auto-summary
R1#sh frame-relay map
Serial0/0.1 (up): ip 172.16.124.2 dlci 102(0x66,0x1860), static,
broadcast,
CISCO, status defined, active
Serial0/0.1 (up): ip 172.16.124.3 dlci 103(0x67,0x1870), static,
broadcast,
CISCO, status defined, active
Configuration of R2
==========================
interface Loopback1
ip address 10.2.1.1 255.255.255.0
!
interface Loopback2
ip address 10.2.2.1 255.255.255.0
!
interface Loopback3
ip address 10.2.3.1 255.255.255.0
interface Serial0/0
ip address 172.16.124.2 255.255.255.248
encapsulation frame-relay
clock rate 2000000
frame-relay map ip 172.16.124.1 201
!
router eigrp 25
network 10.2.0.0 0.0.255.255
network 172.16.0.0
no auto-summary
R2#sh frame-relay map
Serial0/0 (up): ip 172.16.124.1 dlci 201(0xC9,0x3090), static,
CISCO, status defined, active
R2#
Configuration on R3
=========================
interface Loopback1
ip address 10.3.1.1 255.255.255.0
!
interface Loopback2
ip address 10.3.2.1 255.255.255.0
!
interface Loopback3
ip address 10.3.3.1 255.255.255.0
!
interface Serial0/0
ip address 172.16.124.3 255.255.255.248
encapsulation frame-relay
clock rate 2000000
frame-relay map ip 172.16.124.1 301
!
router eigrp 25
network 10.3.0.0 0.0.255.255
network 172.16.0.0
auto-summary
!
R3#sh frame-relay map
Serial0/0 (up): ip 172.16.124.1 dlci 301(0x12D,0x48D0), static,
CISCO, status defined, active
FR ROUTER
==================
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay lmi-type cisco
frame-relay intf-type dce
frame-relay route 102 interface Serial0/1 201
frame-relay route 103 interface Serial0/2 301
interface Serial0/1
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay intf-type dce
frame-relay route 201 interface Serial0/0 102
!
interface Serial0/2
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay intf-type dce
frame-relay route 301 interface Serial0/0 103
R5#sh frame-relay route
Input Intf Input Dlci Output Intf Output Dlci Status
Serial0/0 102 Serial0/1 201 active
Serial0/0 103 Serial0/2 301 active
Serial0/1 201 Serial0/0 102 active
Serial0/2 301 Serial0/0 103 active
MY QUESTION IS :
===================
I AM ABLE TO PING IP ADDRESS 172.16.0.1, 172.16.0.2,172.16.0.3 . But when i configure eigrp...it is configured properly...
My frame relay mapping is also done properly and it is active as well...
I am not able to see eigrp routes.
172.16.0.0/29 is subnetted, 1 subnets
C 172.16.124.0 is directly connected, Serial0/0.1
10.0.0.0/24 is subnetted, 3 subnets
C 10.1.3.0 is directly connected, Loopback2
C 10.1.2.0 is directly connected, Loopback1
C 10.1.1.0 is directly connected, Loopback0
It only shows connected routes. It does not show any routes coming from r2 and r3. I am aware about split horizon as well in this network type. but there is not need to configure that as if now. cz i am not getting routes from any of the spokes to hub router which is R1.
These are some logs whicI got from R3(SPOKE)
R3#
*Mar 1 04:45:15.382: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 25: Neighbor 172.16.124.1 (Serial0/0) is up: new adjacency
R3#
R3#
*Mar 1 04:48:19.898: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 25: Neighbor 172.16.124.1 (Serial0/0) is down: retry limit exceeded
R3#
*Mar 1 04:48:57.554: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 25: Neighbor 172.16.124.1 (Serial0/0) is up: new adjacency
IP-EIGRP neighbors for process 25
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 172.16.124.1 Se0/0 163 00:01:11 1 5000 1 0
Hold time is 163 ... I think it should be less then 10. After holtime expire my neighborship goes down.
No access list is configured to block hellos.
So what could be the reason that i am able to see it in neighbor table but routing table is not giving me any eigrp learnt routes.
I think FR router is creating problem. How to fix it...
THANKS IN ADVANCE :-)
Solved! Go to Solution.
01-22-2013 03:57 AM
Hello Namish,
on spoke routers R2, R3 add the broadcast keyword to the frame-relay mapping command.
This is required to correctly exchange EIGRP hello packets that have a multicast destination.
On hub router you need to disable EIGRP split horizon also as you noted
Hope to help
Giuseppe
01-23-2013 01:06 AM
Hello Namish,
Broadcast keyword missing on spoke router configurations
01-22-2013 03:57 AM
Hello Namish,
on spoke routers R2, R3 add the broadcast keyword to the frame-relay mapping command.
This is required to correctly exchange EIGRP hello packets that have a multicast destination.
On hub router you need to disable EIGRP split horizon also as you noted
Hope to help
Giuseppe
01-23-2013 01:06 AM
Hello Namish,
Broadcast keyword missing on spoke router configurations
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide