cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
176
Views
0
Helpful
1
Replies
rajibchicago
Beginner

GRE inside GRE tu terminated at a single router

Is it possible to create GRE tunnel inside GRE tunnel where both tunnel terminated at a single spoke router?

1st GRE Tunnel is basically a mechanism to get to the 2nd tunnel termination router (static route pointing at 1st tu termination router as next hop for 2nd tunnel termination router).

2nd tunnel will participate in eigrp process and spoke router will recieve all route from the 2nd tunnel termination router.

We have a requirement where all traffic from a spoke must go thru a certain gateway, but in order to get that gateway, it must go thru anonther hub router.

Thanks

1 REPLY 1
Peter Paluch
Hall of Fame Cisco Employee

Hi,

I have been able to successfully configure it (although I have to say this is not a good design). Observe:

Router R1:

interface Loopback0
 ip address 10.255.255.1 255.255.255.255
!
interface Tunnel1
 ip address 192.168.12.1 255.255.255.0
 tunnel source Loopback0
 tunnel destination 10.255.255.2
!
interface Tunnel11
 ip address 200.20.2.1 255.255.255.0
 tunnel source Tunnel1
 tunnel destination 192.168.12.2
!         
interface FastEthernet0/0
 ip address 10.1.12.1 255.255.255.0
!
ip route 10.255.255.2 255.255.255.255 10.1.12.2

 

Router R2:

interface Loopback0
 ip address 10.255.255.2 255.255.255.255
!
interface Tunnel1
 ip address 192.168.12.2 255.255.255.0
 tunnel source Loopback0
 tunnel destination 10.255.255.1
!
interface Tunnel11
 ip address 200.20.2.2 255.255.255.0
 tunnel source Tunnel1
 tunnel destination 192.168.12.1
!         
interface FastEthernet0/1
 ip address 10.1.12.2 255.255.255.0
!
ip route 10.255.255.1 255.255.25.5255 10.1.12.1

These two routers are, for this lab purposes, directly connected via FastEthernet links. The first tunnel is Tun1, the second tunnel passing through the first one is Tun11. Notice Tun11 uses the Tun1's IP as its source, and the opposite Tun1's IP address as its destination, thereby existing exclusively in Tun1's namespace.

Best regards,
Peter