cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
452
Views
2
Helpful
2
Replies

Help with GRE tunnel, P2P with loopbacks

codystaf1
Level 1
Level 1

I am new to networking, any help would be greatly appreciated!! I have been searching for hours and can't fix this for the life of me. Thanks for reading/helping. It is point-to-point routers that must have GRE tunneling between them. This is a similar version of the issue at my work that I am trying to fix/learn on GNS3 to replicate in the production environment. It must use loopback for the source and static route (outside of my control).

R3

interface Loopback0
ip address 10.0.0.1 255.255.255.255
!
interface Tunnel1
ip address 172.16.1.1 255.255.255.0
tunnel source Loopback0
tunnel destination 1.1.1.2
!
interface Ethernet0/0
description Trunk to R4
ip address 1.1.1.1 255.255.255.252
!
interface Ethernet0/1
description Fake network to fake computer
ip address 192.168.1.1 255.255.255.0
!
ip route 10.0.0.2 255.255.255.255 172.16.1.2
ip route 192.168.2.0 255.255.255.0 172.16.1.2

R4

interface Loopback0
ip address 10.0.0.2 255.255.255.255
!
interface Tunnel1
ip address 172.16.1.2 255.255.255.0
tunnel source Loopback0
tunnel destination 1.1.1.1
!
interface Ethernet0/0
description Trunk to R3
ip address 1.1.1.2 255.255.255.252
!
interface Ethernet0/1
description Fake network to fake computer
ip address 192.168.2.2 255.255.255.0
!
ip route 10.0.0.1 255.255.255.255 172.16.1.1
ip route 192.168.1.0 255.255.255.0 172.16.1.1

-In this configuration, I can ping the physical interfaces of 1.1.1.1 and 1.1.1.2 but that is it. 

R3
1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 1.1.1.0/30 is directly connected, Ethernet0/0
L 1.1.1.1/32 is directly connected, Ethernet0/0
10.0.0.0/32 is subnetted, 2 subnets
C 10.0.0.1 is directly connected, Loopback0
S 10.0.0.2 [1/0] via 172.16.1.2
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.1.0/24 is directly connected, Tunnel1
L 172.16.1.1/32 is directly connected, Tunnel1
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, Ethernet0/1
L 192.168.1.1/32 is directly connected, Ethernet0/1
S 192.168.2.0/24 [1/0] via 172.16.1.2

R4
1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 1.1.1.0/30 is directly connected, Ethernet0/0
L 1.1.1.2/32 is directly connected, Ethernet0/0
10.0.0.0/32 is subnetted, 2 subnets
S 10.0.0.1 [1/0] via 172.16.1.1
C 10.0.0.2 is directly connected, Loopback0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.1.0/24 is directly connected, Tunnel1
L 172.16.1.2/32 is directly connected, Tunnel1
S 192.168.1.0/24 [1/0] via 172.16.1.1
192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.2.0/24 is directly connected, Ethernet0/1
L 192.168.2.2/32 is directly connected, Ethernet0/1

R3
IOU3(config-if)#do sh int tu1
Tunnel1 is up, line protocol is up
Hardware is Tunnel
Internet address is 172.16.1.1/24
MTU 17916 bytes, BW 100 Kbit/sec, DLY 50000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation TUNNEL, loopback not set
Keepalive not set
Tunnel linestate evaluation up
Tunnel source 10.0.0.1 (Loopback0), destination 1.1.1.2
Tunnel Subblocks:
src-track:
Tunnel1 source tracking subblock associated with Loopback0
Set of tunnels with source Loopback0, 1 member (includes iterators), on interface <OK>
Tunnel protocol/transport GRE/IP
Key disabled, sequencing disabled
Checksumming of packets disabled

R4 
IOU4(config-if)#do sh int tu1
Tunnel1 is up, line protocol is up
Hardware is Tunnel
Internet address is 172.16.1.2/24
MTU 17916 bytes, BW 100 Kbit/sec, DLY 50000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation TUNNEL, loopback not set
Keepalive not set
Tunnel linestate evaluation up
Tunnel source 10.0.0.2 (Loopback0), destination 1.1.1.1
Tunnel Subblocks:
src-track:
Tunnel1 source tracking subblock associated with Loopback0
Set of tunnels with source Loopback0, 1 member (includes iterators), on interface <OK>
Tunnel protocol/transport GRE/IP
Key disabled, sequencing disabled
Checksumming of packets disabled

-In the below configuration it works but I still need to use the loopback like above. Can ping both sides of tunnel and the 192 network
(Same as above setup P2P with only one link to each other, except no loopback used and only one ip route)

R1
interface Tunnel1
ip address 172.16.1.1 255.255.255.0
tunnel source 1.1.1.1
tunnel destination 1.1.1.2
end
!
IOU1(config-if)#do sh run | i ip route
ip route 192.168.2.0 255.255.255.0 172.16.1.2

R2
interface Tunnel1
ip address 172.16.1.2 255.255.255.0
tunnel source 1.1.1.2
tunnel destination 1.1.1.1
!
IOU2(config-if)#do sh run | i ip route
ip route 192.168.1.0 255.255.255.0 172.16.1.1


 

1 Accepted Solution

Accepted Solutions

Harold Ritter
Cisco Employee
Cisco Employee

Hi @codystaf1 .

The tunnel source should match the tunnel destination on the other router and vice versa.

And if you are going to use the loopback interface as the destination address for the tunnel, you should also make sure the peer router loopback interface is reachable via the physical interface between the two routers, rather than the tunnel interface.

R3:

int tu1

tunnel destination 10.0.0.2

no ip route 10.0.0.2 255.255.255.255 172.16.1.2

ip route 10.0.0.2 255.255.255.255 1.1.1.2

R4:

int tu1

tunnel destination 10.0.0.1

no ip route 10.0.0.1 255.255.255.255 172.16.1.1

ip route 10.0.0.1 255.255.255.255 1.1.1.1

That should fix it.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

2 Replies 2

In you configuration change the static routes to reflect a next hop of the physical interface of the connecting router,

Example:

 

R3

interface Loopback0
ip address 10.0.0.1 255.255.255.255
!
interface Tunnel1
ip address 172.16.1.1 255.255.255.0
tunnel source Loopback0
tunnel destination 1.1.1.2
!
interface Ethernet0/0
description Trunk to R4
ip address 1.1.1.1 255.255.255.252
!
interface Ethernet0/1
description Fake network to fake computer
ip address 192.168.1.1 255.255.255.0
!
ip route 10.0.0.2 255.255.255.255 1.1.1.2
ip route 192.168.2.0 255.255.255.0 172.16.1.2



R4

interface Loopback0
ip address 10.0.0.2 255.255.255.255
!
interface Tunnel1
ip address 172.16.1.2 255.255.255.0
tunnel source Loopback0
tunnel destination 1.1.1.1
!
interface Ethernet0/0
description Trunk to R3
ip address 1.1.1.2 255.255.255.252
!
interface Ethernet0/1
description Fake network to fake computer
ip address 192.168.2.2 255.255.255.0
!
ip route 10.0.0.1 255.255.255.255 1.1.1.1
ip route 192.168.1.0 255.255.255.0 172.16.1.1


-David

Harold Ritter
Cisco Employee
Cisco Employee

Hi @codystaf1 .

The tunnel source should match the tunnel destination on the other router and vice versa.

And if you are going to use the loopback interface as the destination address for the tunnel, you should also make sure the peer router loopback interface is reachable via the physical interface between the two routers, rather than the tunnel interface.

R3:

int tu1

tunnel destination 10.0.0.2

no ip route 10.0.0.2 255.255.255.255 172.16.1.2

ip route 10.0.0.2 255.255.255.255 1.1.1.2

R4:

int tu1

tunnel destination 10.0.0.1

no ip route 10.0.0.1 255.255.255.255 172.16.1.1

ip route 10.0.0.1 255.255.255.255 1.1.1.1

That should fix it.

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México
Review Cisco Networking for a $25 gift card