10-30-2010 06:03 AM - edited 03-04-2019 10:18 AM
Dear Group members:-
11-08-2010 06:50 PM
You have missed the Dialer interface... the Cell0/1/0 interface needs to be looked like a modem... so you need a dialer interface. I also noticed in your Chat-script up i have ATDT*99, were I use 98, not sure if that maters or not.
Now you carrier might register your SIM to the SN, or (EIME, MEIE, IEME whatever it is) so the SIM might not come up on the network when switching it to a differant hardware for data traffic. I have this issue with AT&T often.
Anyway here is a config similar to yours that I use often:
multilink bundle-name authenticated
!
chat-script gsm "" "ATDT*98*2#" TIMEOUT 60 "CONNECT"
!
!
interface Cellular0/1/0
no ip address
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer pool-member 1
dialer-group 1
no peer default ip address
async mode interactive
ppp chap hostname ISP@CINGULARGPRS.COM
ppp chap password 7 15312222231F07051A62
ppp ipcp dns request
fair-queue 64 16 0
!
!
interface Dialer1
ip address negotiated
ip access-group 120 in
ip nbar protocol-discovery
ip nat outside
ip nat enable
ip virtual-reassembly
dialer pool 1
dialer idle-timeout 0
dialer string gsm
dialer persistent
dialer-group 1
no cdp enable
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
control-plane
!
!
!
line con 0
login local
line aux 0
line 0/1/0
exec-timeout 0 0
script dialer gsm
login
modem InOut
no exec
transport input all
rxspeed 3600000
txspeed 384000
line 67
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
As you can see you default to the dialer interface not the cell interface. the Dialer acts as the middle man determining when the cell should make the connection and when not. As you see I have mine set to be up all the time with the "Dialer persistent" cammand. if using this as a back up data connection you will want to use on demand dialing with a acl.... keeping the connection up all the time even not passing traffic, just in a idle state, will take you over you contracted 5Gig bandwidth. It is not realy unlimited data, so read the fine print. I think Sprint has a true unlimited plan for this use, but the odds of having service is about as commen as everyone having a lake front home...
Good luck..
Dave
P.S. I just noticed you are not using US cell service so just ignore my carrier specific comments... use your APN not what I have listed...
11-11-2010 04:16 AM
Hi,
the cellular interface works already as a dialer interface.
You can configure a dialer interface over it for specific requirements, but for a normal setup this is not required.
Can you please enable:
debug chat
debug dialer
debug ppp nego
Then start a ping traffic that will raise the cellular interface, and collect the logs.
I've seen sometimes that even if the ISP does not require authentication, we need to configure dummy username/password to succeed.
I'd suggest you try this:
1. capture the debugs with the current config
2. change the profile to add authentication chap and username/password guest
3. change the cellular configure to add "ppp chap hostname guest" and "ppp chap password guest"
4. collect the debugs again.
Cheers
Marco
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide