11-05-2021 09:10 AM
hostname R8-PE
ip vrf cust-A1
rd 101:201
route-target export 101:201
route-target import 101:201
!
ip vrf cust-B1
rd 102:202
route-target export 102:202
route-target import 102:202
!
interface Loopback0
ip address 8.8.8.8 255.255.255.255
!
interface FastEthernet0/0
ip address 1.10.7.2 255.255.255.0
ip ospf network point-to-point
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip vrf forwarding cust-B1
ip address 192.168.20.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
no switchport
ip vrf forwarding cust-A1
ip address 172.16.10.2 255.255.255.0
!
interface FastEthernet1/2
no switchport
ip address 1.10.6.2 255.255.255.0
ip ospf network point-to-point
mpls ip
!
interface Vlan1
no ip address
!
router eigrp 500
auto-summary
!
address-family ipv4 vrf cust-A1
redistribute bgp 100 metric 1 1 1 1 1
network 172.16.10.0 0.0.0.255
no auto-summary
autonomous-system 100
exit-address-family
!
router ospf 1
log-adjacency-changes
network 1.10.6.0 0.0.0.255 area 0
network 1.10.7.0 0.0.0.255 area 0
network 8.8.8.8 0.0.0.0 area 0
!
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback0
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
neighbor 1.1.1.1 next-hop-self
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf cust-A1
redistribute eigrp 100
no synchronization
exit-address-family
hostname R1-PE
ip vrf cust-A
rd 101:201
route-target export 101:201
route-target import 101:201
!
ip vrf cust-B
rd 102:202
route-target export 102:202
route-target import 102:202
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding cust-A
ip address 172.16.15.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 1.10.1.1 255.255.255.0
ip ospf network point-to-point
duplex auto
speed auto
mpls ip
!
interface FastEthernet1/0
!
interface FastEthernet1/1
no switchport
ip vrf forwarding cust-B
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet1/2
no switchport
ip address 1.10.6.1 255.255.255.0
ip ospf network point-to-point
mpls ip
!
router eigrp 500
auto-summary
!
address-family ipv4 vrf cust-A
redistribute bgp 100 metric 1 1 1 1 1
network 172.16.0.0
no auto-summary
autonomous-system 100
exit-address-family
!
router ospf 10 vrf cust-B
log-adjacency-changes
network 192.168.10.0 0.0.0.255 area 0
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 1.10.1.0 0.0.0.255 area 0
network 1.10.6.0 0.0.0.255 area 0
!
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 8.8.8.8 remote-as 100
neighbor 8.8.8.8 update-source Loopback0
!
address-family ipv4
neighbor 8.8.8.8 activate
neighbor 8.8.8.8 send-community extended
neighbor 8.8.8.8 next-hop-self
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf cust-A
redistribute eigrp 100
no synchronization
exit-address-family
11-05-2021 09:29 AM - edited 11-05-2021 09:56 AM
Hi @R Manjunatha ,
From what I can understand, this is a L3VPN topology. The iBGP session between R1-PE and R8-PE should have "address-family vpnv4" configured rather than "address-family ipv4" . This is required for the IPv4 L3VPN updates to be propagated between the PEs.
Regards,
11-05-2021 11:15 PM
Hi...Harold,
Thanks Harold ...you are right its seems to be "address-family vpnv4"
regards,
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide