cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
520
Views
0
Helpful
1
Replies
Highlighted
Beginner

IGMP on 891 running 15.4(3)M1

Are there any special tricks to get IGMP running on an 891?

I've done some packet captures and the workstations are sending IGMP reports for their interested streams.

However the router never adds it to the IGMP group list.

IGMP is enabled on the interface as is snooping.

Interestingly .. PIM works fine  I can see local multicast senders in my mroute table .

And mutlicasdt to the workstations work if I hard-code a icmp join-group or static-group on my LAN interface on the router.

 

interface GigabitEthernet8
 ip address 10.x.x.2 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip pim sparse-mode
 duplex auto
 speed auto

891F#sh ip igmp groups

IGMP Connected Group Membership
Group Address    Interface                Uptime    Expires   Last Reporter   Group Accounted
224.0.1.40       GigabitEthernet8         22:16:55  00:02:45  10.69.254.2    

 

891F#sh ip igmp interface g8
Load for five secs: 10%/3%; one minute: 10%; five minutes: 10%
Time source is NTP, 19:25:37.138 EST Wed Jan 28 2015

GigabitEthernet8 is up, line protocol is up
  Internet address is 10.s.x.2/24
  IGMP is enabled on interface
  Current IGMP host version is 2
  Current IGMP router version is 2
  IGMP query interval is 60 seconds
  IGMP configured query interval is 60 seconds
  IGMP querier timeout is 120 seconds
  IGMP configured querier timeout is 120 seconds
  IGMP max query response time is 10 seconds
  Last member query count is 2
  Last member query response interval is 1000 ms
  Inbound IGMP access group is not set
  IGMP activity: 1 joins, 0 leaves
  Multicast routing is enabled on interface
  Multicast TTL threshold is 0
  Multicast designated router (DR) is 10.69.254.2 (this system)
  IGMP querying router is 10.x.x.2 (this system)
  Multicast groups joined by this system (number of users):
      224.0.1.40(1)

 

891F#sh ip mroute 239.193.128.1

IP Multicast Routing Table

Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.193.128.1), 00:02:03/stopped, RP 10.255.255.252, flags: SPF
  Incoming interface: Tunnel10, RPF nbr 10.69.1.1
  Outgoing interface list: Null

(10.69.254.10, 239.193.128.1), 00:02:03/00:02:56, flags: PFT
  Incoming interface: GigabitEthernet8, RPF nbr 0.0.0.0
  Outgoing interface list: Null

 

Attached WIreshak screenshot showing that the IGMP report is being sent on the newtwork

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

Hi Wes,

Check for "ip option drop" in your global config. This will stop the IGMP snooping process from passing the join to the IGMP sub-process. This is why we are not building an OIL in your ip mroute. Remove the config and test your multicast application. This should build the correct OIL and allow multicast to flow now.

-Denny

View solution in original post

1 REPLY 1
Highlighted
Cisco Employee

Hi Wes,

Check for "ip option drop" in your global config. This will stop the IGMP snooping process from passing the join to the IGMP sub-process. This is why we are not building an OIL in your ip mroute. Remove the config and test your multicast application. This should build the correct OIL and allow multicast to flow now.

-Denny

View solution in original post