cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1191
Views
0
Helpful
9
Replies
Alex M
Beginner

Input errors on my с6500

Hello!

I have configured this scheme:

| c6500 |g4/47|------[trunk - 300 Mb/s MAX]------|g0/0/3| ASR1002f |

After that, I saw that "Input errors" counter increased on the c6500 - g4/47. The g0/0/3 on the ASR looks without problem.
What's more, packet loss doesn't occur on that interface and customers don't complain to me.

g4/47 (Located on WS-X6748-GE-TX module.)

GigabitEthernet4/47 is up, line protocol is up (connected)
 
Hardware is C6k 1000Mb 802.3, address is 0012.80c7.04de (bia 0012.80c7.04de)
 
Description: Link to asr1002f-1
  MTU
1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability
255/255, txload 14/255, rxload 41/255
 
Encapsulation ARPA, loopback not set
 
Keepalive set (10 sec)
 
Full-duplex, 1000Mb/s, media type is 10/100/1000BaseT
  input flow
-control is off, output flow-control is off
 
Clock mode is auto
  ARP type
: ARPA, ARP Timeout 04:00:00
 
Last input never, output never, output hang never
 
Last clearing of "show interface" counters 09:18:10
 
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
 
Queueing strategy: fifo
 
Output queue: 0/40 (size/max)
 
5 minute input rate 160938000 bits/sec, 20173 packets/sec
 
5 minute output rate 58258000 bits/sec, 17267 packets/sec
     
154295390 packets input, 135788600661 bytes, 0 no buffer
     
Received 4121 broadcasts (3863 multicasts)
     
0 runts, 0 giants, 0 throttles
     
367 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     
0 watchdog, 0 multicast, 0 pause input
     
0 input packets with dribble condition detected
     
138657812 packets output, 67045673270 bytes, 0 underruns
     
0 output errors, 0 collisions, 0 interface resets
     
0 babbles, 0 late collision, 0 deferred
     
0 lost carrier, 0 no carrier, 0 PAUSE output
     
0 output buffer failures, 0 output buffers swapped out

g0/0/3

GigabitEthernet0/0/3 is up, line protocol is up 
 
Hardware is 4XGE-BUILT-IN, address is 4055.399d.9203 (bia 4055.399d.9203)
 
Description: Link to c6506E
  MTU
1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
     reliability
255/255, txload 40/255, rxload 14/255
 
Encapsulation 802.1Q Virtual LAN, Vlan ID  1., loopback not set
 
Keepalive not supported
 
Full Duplex, 1000Mbps, link type is auto, media type is T
  output flow
-control is on, input flow-control is on
  ARP type
: ARPA, ARP Timeout 04:00:00
 
Last input 00:00:10, output 00:00:11, output hang never
 
Last clearing of "show interface" counters never
 
Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
 
Queueing strategy: fifo
 
Output queue: 0/40 (size/max)
 
30 second input rate 57823000 bits/sec, 16808 packets/sec
 
30 second output rate 159113000 bits/sec, 19761 packets/sec
     
2576235394 packets input, 1105227377945 bytes, 0 no buffer
     
Received 269 broadcasts (0 IP multicasts)
     
0 runts, 0 giants, 0 throttles
     
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     
0 watchdog, 52402 multicast, 0 pause input
     
2888300571 packets output, 2688926885221 bytes, 0 underruns
     
0 output errors, 0 collisions, 6 interface resets
     
0 unknown protocol drops
     
0 babbles, 0 late collision, 0 deferred
     
0 lost carrier, 0 no carrier, 0 pause output
     
0 output buffer failures, 0 output buffers swapped out

I looked at sh int g4/47 counters errors and didn't see anything wrong:

Port                     Align-Err             FCS-Err            Xmit-Err             Rcv-Err           UnderSize         OutDiscards
Gi4/47                           0                   0                   0                 377                   0                   0

Port                    Single-Col           Multi-Col            Late-Col          Excess-Col           Carri-Sen               Runts              Giants
Gi4/47                           0                   0                   0                   0                   0                   0                   0

Port                   SQETest-Err         Deferred-Tx        IntMacTx-Err        IntMacRx-Err          Symbol-Err
Gi4/47                           0                   0                   0                   0                   0

g4.47

interface GigabitEthernet4/47
 description
Link to asr1002f-1
 switchport
 switchport trunk encapsulation dot1q
 switchport trunk
native vlan 666
 switchport trunk allowed vlan
115,200
 switchport mode trunk
 switchport nonegotiate
 logging
event link-status
end

g0/0/3

interface GigabitEthernet0/0/3
 description
Link to c6506E
 
no ip address
 load
-interval 30
 negotiation
auto
end

I tried to replace the cable and the SFP on ASR but it didn't help. It may be some problem with hardware, I don't know.
I think it looks like a bug in IOS 12.2(33)SXI6. Did anyone else encounter this problem?

2 ACCEPTED SOLUTIONS

Accepted Solutions
Leo Laohoo
VIP Community Legend

If the reboot fixes this issue then report this to Cisco as this could be a bug.

View solution in original post

Leo Laohoo
VIP Community Legend

Please don't forget to mark this thread as "Answered".

View solution in original post

9 REPLIES 9
Leo Laohoo
VIP Community Legend

On the 6500, post the complete output to the command "sh count interface Gi4/47".

Thanks for your reply!

c6506E#sh counters interface g4/47
64 bit counters:
0. rxHCTotalPkts = 3572827588
1. txHCTotalPkts = 3166486301
2. rxHCUnicastPkts = 3572721724
3. txHCUnicastPkts = 3166381281
4. rxHCMulticastPkts = 50986
5. txHCMulticastPkts = 57433
6. rxHCBroadcastPkts = 54860
7. txHCBroadcastPkts = 47605
8. rxHCOctets = 3368723832656
9. txHCOctets = 1355132564976
10. rxTxHCPkts64Octets = 217593864
11. rxTxHCPkts65to127Octets = 2310681881
12. rxTxHCPkts128to255Octets = 570564055
13. rxTxHCPkts256to511Octets = 435489113
14. rxTxHCpkts512to1023Octets = 357469891
15. rxTxHCpkts1024to1518Octets = 2480944478
16. txHCTrunkFrames = 3166436388
17. rxHCTrunkFrames = 3572780520
18. rxHCDropEvents = 0
32 bit counters:
0. rxCRCAlignErrors = 0
1. rxUndersizedPkts = 0
2. rxOversizedPkts = 0
3. rxFragmentPkts = 0
4. rxJabbers = 0
5. txCollisions = 0
6. ifInErrors = 17727
7. ifOutErrors = 0
8. ifInDiscards = 0
9. ifInUnknownProtos = 0
10. ifOutDiscards = 0
11. txDelayExceededDiscards = 0
12. txCRC = 0
13. linkChange = 95128
14. wrongEncapFrames = 0
All Port Counters
1. InPackets = 3572827588
2. InOctets = 3368723832656
3. InUcastPkts = 3572721724
4. InMcastPkts = 50986
5. InBcastPkts = 54860
6. OutPackets = 3166486301
7. OutOctets = 1355132564976
8. OutUcastPkts = 3166381281
9. OutMcastPkts = 57433
10. OutBcastPkts = 47605
11. AlignErr = 0
12. FCSErr = 0
13. XmitErr = 0
14. RcvErr = 17727
15. UnderSize = 0
16. SingleCol = 0
17. MultiCol = 0
18. LateCol = 0
19. ExcessiveCol = 0
20. CarrierSense = 0
21. Runts = 0
22. Giants = 0
23. InDiscards = 0
24. OutDiscards = 0
25. InErrors = 17727
26. OutErrors = 0
27. InUnknownProtos = 0
28. txCRC = 0
29. TrunkFramesTx = 3166436388
30. TrunkFramesRx = 3572780520
31. WrongEncap = 0
32. Broadcast_suppression_discards = 0
33. Multicast_suppression_discards = 0
34. Unicast_suppression_discards = 0
35. rxTxHCPkts64Octets = 217593864
36. rxTxHCPkts65to127Octets = 2310681881
37. rxTxHCPkts128to255Octets = 570564055
38. rxTxHCPkts256to511Octets = 435489113
39. rxTxHCpkts512to1023Octets = 357469891
40. rxTxHCpkts1024to1518Octets = 2480944478
41. DropEvents = 0
42. CRCAlignErrors = 0
43. UndersizedPkts = 0
44. OversizedPkts = 0
45. FragmentPkts = 0
46. Jabbers = 0
47. Collisions = 0
48. DelayExceededDiscards = 0
49. bpduOutlost = 0
50. qos0Outlost = 0
51. qos1Outlost = 0
52. qos2Outlost = 0
53. qos3Outlost = 0
54. qos4Outlost = 0
55. qos5Outlost = 0
56. qos6Outlost = 0
57. qos7Outlost = 0
58. qos8Outlost = 0
59. qos9Outlost = 0
60. qos10Outlost = 0
61. qos11Outlost = 0
62. qos12Outlost = 0
63. qos13Outlost = 0
64. qos14Outlost = 0
65. qos15Outlost = 0
66. qos16Outlost = 0
67. qos17Outlost = 0
68. qos18Outlost = 0
69. qos19Outlost = 0
70. qos20Outlost = 0
71. qos21Outlost = 0
72. qos22Outlost = 0
73. qos23Outlost = 0
74. qos24Outlost = 0
75. qos25Outlost = 0
76. qos26Outlost = 0
77. qos27Outlost = 0
78. qos28Outlost = 0
79. qos29Outlost = 0
80. qos30Outlost = 0
81. qos31Outlost = 0
82. bpduCbicOutlost = 0
83. qos0CbicOutlost = 0
84. qos1CbicOutlost = 0
85. qos2CbicOutlost = 0
86. qos3CbicOutlost = 0
87. bpduInlost = 0
88. qos0Inlost = 0
89. qos1Inlost = 0
90. qos2Inlost = 0
91. qos3Inlost = 0
92. qos4Inlost = 0
93. qos5Inlost = 0
94. qos6Inlost = 0
95. qos7Inlost = 0
96. qos8Inlost = 0
97. qos9Inlost = 0
98. qos10Inlost = 0
99. qos11Inlost = 0
100. qos12Inlost = 0
101. qos13Inlost = 0
102. qos14Inlost = 0
103. qos15Inlost = 0
104. qos16Inlost = 0
105. qos17Inlost = 0
106. qos18Inlost = 0
107. qos19Inlost = 0
108. qos20Inlost = 0
109. qos21Inlost = 0
110. qos22Inlost = 0
111. qos23Inlost = 0
112. qos24Inlost = 0
113. qos25Inlost = 0
114. qos26Inlost = 0
115. qos27Inlost = 0
116. qos28Inlost = 0
117. qos29Inlost = 0
118. qos30Inlost = 0
119. qos31Inlost = 0
120. pqueInlost = 0
121. Overruns = 0
122. maxIndex = 0
Leo Laohoo
VIP Community Legend

 0. rxCRCAlignErrors = 0
1. rxUndersizedPkts = 0
2. rxOversizedPkts = 0
3. rxFragmentPkts = 0
4. rxJabbers = 0
5. txCollisions = 0
6. ifInErrors = 17727
7. ifOutErrors = 0
8. ifInDiscards = 0
9. ifInUnknownProtos = 0
10. ifOutDiscards = 0
11. txDelayExceededDiscards = 0
12. txCRC = 0
13. linkChange = 95128
14. wrongEncapFrames = 0
All Port Counters
11. AlignErr = 0
12. FCSErr = 0
13. XmitErr = 0
14. RcvErr = 17727
15. UnderSize = 0
16. SingleCol = 0
17. MultiCol = 0
18. LateCol = 0
19. ExcessiveCol = 0
20. CarrierSense = 0
21. Runts = 0
22. Giants = 0
23. InDiscards = 0
24. OutDiscards = 0
25. InErrors = 17727
26. OutErrors = 0
27. InUnknownProtos = 0
28. txCRC = 0
31. WrongEncap = 0

It's not CRC error.  It's not Collision.  It's not "unknown protocol drop".   It's not QoS-related either.

So this means it's not Layer 1 (Physical Layer) issue.  I don't believe it's a Layer 2 issue either but something is definitely being dropped from the switch side and the culprit is the router.  

I think you are right! I remembered ERSPAN was configured on the ARS g0/0/3 port. But there isn't any ERSPAN commands in the ASR config now. However, sh platform hardware qfp active feature erspan state on the ASR gets me response:

ERSPAN State:
Status : Active
......

I'm going to reboot the ASR, may be it helps.

Leo Laohoo
VIP Community Legend

If the reboot fixes this issue then report this to Cisco as this could be a bug.

View solution in original post

OK. Thank you very much for your replies!

So. I've reboot my ASR. But it didn't resolve the problem. After that, I changed IOS on the ASR and there aren't errors now. Thank you very much for your replies!

Leo Laohoo
VIP Community Legend

Please don't forget to mark this thread as "Answered".

View solution in original post

Leo Laohoo
VIP Community Legend

Thanks for taking the time to rate our posts, Alex.  :)