cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2741
Views
10
Helpful
6
Replies

ip route with exit interface problems

keesepema
Level 1
Level 1

I learned from Cisco CCNA that a directly connected static route specified with an exit-interface has an administrative distance of 0. That seems very promising, because next-hop routes have an AD of 1.

I tried to work with these kind of routes in PacketTracer, but in all occasions packets are dropped at the exit interface.

Inspection of PDU's at the exit-if showed me that the route was found,but on the datalink layer packets were dropped.

I use 1911 routers on both ends and tried to implement a

quad zero route (ip route 0.0.0.0 0.0.0.0 g0/0/0)

and more detailed routes as

ip route 212.10.251.1 255.255.255.252 g0/0/0)

So I wonder in which occasions I should apply such a route?

 

3 Accepted Solutions

Accepted Solutions

Harold Ritter
Spotlight
Spotlight

Hi @keesepema ,

This should work, but you need to make sure

ip proxy-arp

is enable on the interface of the router connected to gi0/0/0.

You can do a

show ip int <interface name>

for the interface connected to gi0/0/0 on the facing router to check whether the

proxy arp 

functionality is enabled.

So I wonder in which occasions I should apply such a route?

This is usually not recommended to configure such a route, as it could could cause the arp cache to grow really big, especially if you configure a default route to the Internet for instance.

Regards,

Regards,
Harold Ritter, CCIE #4168 (EI, SP)

View solution in original post

keesepema
Level 1
Level 1

Thanks, ip

proxy-arp 

is the solution!

Still wondering on which occasion such a route would be best practice......

 

View solution in original post

Hello @keesepema ,

the use of the exit interface in defining a static route was a good alternative for WAN serial links that are point to point and do not create issues with ARP.

But now days most of internet handoffs are provided as ethernet so as noted by @Harold Ritter  the default static route should specify the IP address of the ISP router to avoid excessive ARP entries and to rely on IP proxy ARP enabled on the ISP router interface.

Hope to help

Giuseppe

 

View solution in original post

6 Replies 6

I dont know what issue here, can you share all config ?

Sure!

Here is the config of R1

R1#sh ip route static

S* 0.0.0.0/0 is directly connected, GigabitEthernet0/0/1




R1#sh run

Building configuration...




Current configuration : 719 bytes

!

version 16.6.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

hostname R1




ip cef

no ipv6 cef

spanning-tree mode pvst

interface GigabitEthernet0/0/0

ip address 192.168.10.1 255.255.255.0

duplex auto

speed auto

interface GigabitEthernet0/0/1

ip address 10.100.100.1 255.255.255.252

duplex auto

speed auto

interface GigabitEthernet0/0/2

no ip address

duplex auto

speed auto

shutdown

interface Vlan1

no ip address

shutdown

ip classless

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/1

ip flow-export version 9

line con 0

line aux 0

line vty 0 4

login

end


And here is my R2 config:

R2#sh run

Building configuration...

 

Current configuration : 718 bytes

version 16.6.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

hostname R2

ip cef

no ipv6 cef

spanning-tree mode pvst

interface GigabitEthernet0/0/0

ip address 10.100.100.2 255.255.255.252

duplex auto

speed auto

interface GigabitEthernet0/0/1

ip address 172.22.22.1 255.255.255.0

duplex auto

speed auto

interface GigabitEthernet0/0/2

no ip address

duplex auto

speed auto

shutdown

interface Vlan1

no ip address

shutdown

ip classless

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0

ip flow-export version 9

line con 0

line aux 0

line vty 0 4

login

end

R2#

R2#

R2#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

R2(config)#

R2(config)#

R2(config)#end

R2#

%SYS-5-CONFIG_I: Configured from console by console




R2#sh ip route sta

R2#sh ip route static

S* 0.0.0.0/0 is directly connected, GigabitEthernet0/0/0




R2#sh run

Building configuration...

 

Current configuration : 718 bytes

!

version 16.6.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

hostname R2

ip cef

no ipv6 cef

spanning-tree mode pvst

interface GigabitEthernet0/0/0

ip address 10.100.100.2 255.255.255.252

duplex auto

speed auto

interface GigabitEthernet0/0/1

ip address 172.22.22.1 255.255.255.0

duplex auto

speed auto

interface GigabitEthernet0/0/2

no ip address

duplex auto

speed auto

shutdown

interface Vlan1

no ip address

shutdown

ip classless

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0/0

ip flow-export version 9

line con 0

line aux 0

line vty 0 4

login

end


I also included a png file with the topology regarding this issue.

Harold Ritter
Spotlight
Spotlight

Hi @keesepema ,

This should work, but you need to make sure

ip proxy-arp

is enable on the interface of the router connected to gi0/0/0.

You can do a

show ip int <interface name>

for the interface connected to gi0/0/0 on the facing router to check whether the

proxy arp 

functionality is enabled.

So I wonder in which occasions I should apply such a route?

This is usually not recommended to configure such a route, as it could could cause the arp cache to grow really big, especially if you configure a default route to the Internet for instance.

Regards,

Regards,
Harold Ritter, CCIE #4168 (EI, SP)

keesepema
Level 1
Level 1

Thanks, ip

proxy-arp 

is the solution!

Still wondering on which occasion such a route would be best practice......

 

That for the feedback @keesepema .

> Still wondering on which occasion such a route would be best practice......

As I mentioned, even though the functionality is there, it is generally recommended to specify the next hop ip address when you configure a static route. I have seen too many cases in the past where people would configure a default static route to the Internet with no

next hop ip address 

and you should have seen the size of the arp cache on some of these devices. This could lead to some really bad outages in real life scenarios.

Regards,

Regards,
Harold Ritter, CCIE #4168 (EI, SP)

Hello @keesepema ,

the use of the exit interface in defining a static route was a good alternative for WAN serial links that are point to point and do not create issues with ARP.

But now days most of internet handoffs are provided as ethernet so as noted by @Harold Ritter  the default static route should specify the IP address of the ISP router to avoid excessive ARP entries and to rely on IP proxy ARP enabled on the ISP router interface.

Hope to help

Giuseppe