cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

580
Views
0
Helpful
16
Replies
Highlighted
Beginner

IR809 - Config Serialport

So I am working with alot of PLC and they are a bit on the old side and uses Serial communication

 

On the IR 809 i want to use the Serial ports async 1 (RS232-DTE)  

I manage to connect to that port by setting a IP on it and useing ssh.

But the SCADA systems do not ofcs use SSH. 

 

how do i change tcp/udp ports? 

 

 

 

 

Everyone's tags (3)
16 REPLIES 16
VIP Mentor

Re: IR809 - Config Serialport

Hello,

 

I am not clear on what you are asking. Do you want to change the port used for SSH ?

 

IR809#conf t

IR809(config)#ip ssh port XXX rotary 1

 

where 'XXX is the new port'...

Beginner

Re: IR809 - Config Serialport

Hi  Georg Pauwen

 

No so i have a Async port that will be used for PLC host to connect to. 

 

where the IR809 well act as a convertor. IP/Serial

 

right now i can connect from the SCADA server to the Async port on SSH. but i need to change port as alot of the SCADA systems use Port tcp/5001

 

 

 

 

 

Everyone's tags (1)
VIP Mentor

Re: IR809 - Config Serialport

Hello,

 

I am not sure I understand what you are asking. The async port by itself does not block anything. What do you want to connect with on the IR809 using port 5001 ?

Beginner

Re: IR809 - Config Serialport

Hello

 

So port 5001 is in this case what the Scada system uses. next time its  tcp/5002 or udp/9523.

(we have a few diffrent Scada systems.)

So i need the modem to allow connections on any port. 

 

Right now i only get tcp/22 to work. but i dont understand where i can change it. 

 

Sorry Georg, English is not my first language. 

 

the two pictures was of 1 program that tests Serialports and it worked on tcp/22 but no on tcp/5001. 

 

VIP Mentor

Re: IR809 - Config Serialport

Hello,

 

your async port is probably configured like this:

 

interface Async0
ip address 10.128.7.33 255.0.0.0
encapsulation scada

 

At the bottom of the configuration you see lines like:

 

line 1/5
transport preferred none
transport output all

transport input all

 

I am not sure which line corresponds to your async port, check for one that says 'transport input ssh', since ssh is the only protocol working now. Change that line to 'transport input all'...

Beginner

Re: IR809 - Config Serialport

interface Async0
ip address 10.128.7.33 255.255.255.254
encapsulation slip
end

 


stopbits 1
line 1/5
access-class PROC-AV1 in
transport preferred none
transport input all
transport output all
stopbits 1

 

if i use encapsulation scada it killes the interface.

So i use slip instead "slip =  Serial Line IP"

 

 Edit:

 https://www.cisco.com/c/en/us/td/docs/routers/access/800/829/software/configuration/guide/b_IR800config.pdf

 

This guide says that async 0  belongs to 1/5 and 1/6 belongs 2 async 1

 

"Async 0 and Async 1 respectively reserve line 1/5 and 1/6 to relay serial data to the corresponding Guest OS /dev/ttyS1 and /dev/ttyS2"

VIP Mentor

Re: IR809 - Config Serialport

Hello,

 

what is in the access list ? What if you remove that from the line ?

 

line 1/5
--> no access-class PROC-AV1 in
transport preferred none
transport input all
transport output all
stopbits 1

Beginner

Re: IR809 - Config Serialport

ip access-list extended PROC-AV1
permit icmp any any
permit ip 10.128.7.0 0.0.0.255 host 10.128.7.33
deny ip any 10.128.7.0 0.0.0.255
permit ip any any

 

i removed it same results. 

VIP Mentor

Re: IR809 - Config Serialport

Hello,

 

which emulator are you using ? I cannot tell from your pictures, but also try Putty and TeraTerm. 

 

Under the async port, what others encapsulation options do you have ? I think ther also is ' encapsulation relay-line' ?

Beginner

Re: IR809 - Config Serialport

IR800(config-if)#encapsulation ?
bstun Block Serial tunneling (BSTUN)
ppp Point-to-Point protocol
raw-tcp Raw socket TCP
raw-udp Raw socket UDP
relay-line relay between lines
scada SCADA
slip Serial Line IP
trans Transparent data over MPLS mode
wpan WPAN

 

 

I used Putty, secure CRT. same reults, works on port 22 not on any other port! 

 

No effect on relay-line

VIP Mentor

Re: IR809 - Config Serialport

Hello,

 

try 'encapsulation raw-tcp'; the screenshot with the successful SSH connection shows that a RAW TCP connection is detected...

Beginner

Re: IR809 - Config Serialport

Yes i tested that also, every encapsulation works 22 but no other port.


VIP Mentor

Re: IR809 - Config Serialport

Beginner

Re: IR809 - Config Serialport

Hey



Yeah tried this now but it will not take the command "raw-stocket tcp-server 5001"



Current configuration : 87 bytes

!

interface Async0

ip address 10.128.7.33 255.255.255.254

encapsulation raw-tcp

end





IR800(config-line)#raw-socket tcp server 5001

IR800(config-line)#do sh run | sec line 1

line 1 2

stopbits 1

line 1/3

transport preferred none

transport output none

stopbits 1

line 1/4

transport preferred none

transport input all

transport output all

stopbits 1

line 1/5

exec-timeout 0 0

transport preferred none

transport input all

transport output none

stopbits 1










CreatePlease to create content
Content for Community-Ad
FusionCharts will render here