cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
241
Views
0
Helpful
0
Replies

IR829 How to configure routing

MartinAM
Level 1
Level 1

I have a IR829 rugged router and trying to setup an IP Camera that will be accessible through a cellular connection. I have the cellular interface 'cellular 1/0' connected with a static IP/AT&T SimCard and can ping to the outside. I have a DNS server host name No-IP setup with the cellular IP. I have the camera on LAN/PoE port gigabitEthernet 3 and the camera itself (NOT THE PORT) has a static IP 192.168.1.90:8080. I tried to configure it to when you type in the dns name, you get access to the camera but I get a gateway error. Biggest issue is that I can't assign static IP to the gigabitEthernet 3 port because its an L2 port and "no switchport" command doesn't not work, I get an "Command rejected: Not a convertable port.". I've already tried "ip routing" to prevent this but no luck and because of this, none of my nat commands work. Any suggestions on how to approach this and get this configuration working? 

Config File: 

Current configuration : 5584 bytes
!
! Last configuration change at 18:33:51 UTC Mon Oct 10 2022
!
version 15.9
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname IR800
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
service-module wlan-ap 0 bootimage autonomous
!
ignition off-timer 900
!
ignition undervoltage threshold 11 000
!
no ignition enable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!


!
!
ip dhcp pool dpool1
import all
network 192.168.1.0 255.255.255.0
dns-server 8.8.4.4
default-router 192.168.1.11
domain-name mydomain.ddns.net
!
!
!
no ip domain lookup
ip domain name calverttrain.ddns.net
ip host mydomain.ddns.net 166.195.80.12
ip name-server 8.8.4.4
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
!
crypto pki trustpoint TP-self-signed-422713650
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-422713650
revocation-check none
rsakeypair TP-self-signed-422713650
!
!
crypto pki certificate chain TP-self-signed-422713650
certificate self-signed 01
30820229 30820192 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 34323237 31333635 30301E17 0D323231 30303731 36333034
315A170D 33303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3432 32373133
36353030 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
A0B16112 AD8276DB 43CF2565 6EC65EA2 5E0129AF C8DCD3BC F08E92F5 3A142728
BA8C8C5B F34520D3 90C54DF3 08A148EE 133D8A41 E6B65668 201A9D87 2B78F9ED
F15ECD0D CDA5148E 8A86CCC8 8F7DC2BB 8EDFBE1D 707B45C4 1C85FB23 ED28F612
B50FD97C AAD06AAD E2B8FFAE 8E301E11 A732ED52 3713833C 76438308 AD1E4A1D
02030100 01A35330 51300F06 03551D13 0101FF04 05300301 01FF301F 0603551D
23041830 16801489 6F92AB78 CEF5AA97 0B0ACA4E 4F29494F 11F14C30 1D060355
1D0E0416 0414896F 92AB78CE F5AA970B 0ACA4E4F 29494F11 F14C300D 06092A86
quit
license udi pid IR829M-2LTE-EA-BK9 sn FTX2616D0CP
!
!
!
redundancy

!
!
!
!
!
controller Cellular 0
!
controller Cellular 1
lte sim data-profile 1 attach-profile 1
no lte gps enable
description AT&T
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0
no ip address
shutdown
!
interface GigabitEthernet1
no ip address
!
interface GigabitEthernet2
no ip address
!
interface GigabitEthernet3
switchport access vlan 2
switchport mode access
ip dhcp client lease 365 0 0
no ip address
!
interface GigabitEthernet4
no ip address
!
interface Wlan-GigabitEthernet0
no ip address
!
interface GigabitEthernet5
no ip address
shutdown
duplex auto
speed auto
!
interface Cellular0/0
ip address negotiated
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer string lte
dialer-group 1
!
interface Cellular1/0
ip address negotiated
ip virtual-reassembly in
encapsulation slip
ip tcp adjust-mss 1390
dialer in-band
dialer idle-timeout 0
dialer string lte
dialer-group 1
ipv6 address autoconfig
ipv6 enable
!
interface Cellular0/1
no ip address
encapsulation slip
!
interface Cellular1/1
no ip address
encapsulation slip
!
interface wlan-ap0
no ip address
!
interface Vlan1
ip address dhcp
ip nat inside
ip nat allow-static-host
ip virtual-reassembly in
!
interface Vlan2
ip address 192.168.1.95 255.255.255.0
ip nat inside
ip nat enable
ip virtual-reassembly in
!
interface Async0
no ip address
encapsulation scada
!
interface Async1
no ip address
encapsulation scada
!
!
ip forward-protocol nd
!
no ip http server
ip http secure-server
!
ip nat source static tcp 192.168.1.90 8080 interface Cellular1/0 8080
ip nat source static tcp 192.168.1.90 8080 166.195.80.12 8080 extendable
ip nat source static 192.168.1.95 166.195.80.12 extendable
ip nat inside source static 192.168.1.90 192.168.1.11
ip nat outside source static 166.195.80.12 192.168.1.11
ip route 0.0.0.0 0.0.0.0 dhcp
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipv6 permit
ipv6 route ::/0 Cellular1/0
ipv6 ioam timestamp
!
!
access-list 1 permit any
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 100 permit icmp any any echo
!
control-plane
!
!
!
line con 0
stopbits 1
line 1 2
stopbits 1
line 3
script dialer lte
no exec
transport preferred none
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 4
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 8
no exec
transport preferred none
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 9
script dialer lte
no exec
transport preferred none
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 150000000
txspeed 50000000
line 15
no exec
transport preferred none
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 150000000
txspeed 50000000
line 1/3 1/6
transport preferred none
transport output none
stopbits 1
line vty 0 4
login
transport input none
!
no scheduler max-task-time
no iox hdm-enable
iox client enable interface GigabitEthernet5
no iox recovery-enable
!
!
!
!
!
!
!
end

0 Replies 0
Review Cisco Networking for a $25 gift card