cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2121
Views
50
Helpful
23
Replies

IR829 no internet through AP/GigabitEthernet

TriLabs
Level 1
Level 1

Hello,

I'm currently trying to configure an IR829GW for use as a mobile hotspot on a company vehicle, but am having an issue where I can not reach the internet through either the WiFi AP, or any of the ethernet ports.

*Cellular is configured with an AT&T sim, and appears to be functional, as I can ping out to 8.8.8.8 with 100% success rate, and the rest of the cellular setting appear correct.
*WiFi AP is currently configured with active SSID's for 2.4 and 5GHz bands, and I can connect to these SSID's, albeit with no internet access through the cellular link.
*Ethernet ports are configured and appear to be functional, as I can connect my company's business internet modem with a patch cable to any of the ethernet ports, and then I have access to the internet over the 2.4 and 5GHz WiFi AP through the GigabitEthernet ports. I can also connect other ethernet devices to any of the 4 ethernet ports and have normal connectivity/switching/routing. 

Note: the cellular 0 interface appears to go down (sleep?) when I'm not trying to ping an IP, then once I enter "ping 8.8.8.8" the cellular 0 interface comes back up momentarily to complete the ping, then seemingly goes back down. Here is the cellular startup/shutdown scenario as seen on the console: 

IR829#

IR829#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

*Jan 27 18:00:58.011: %CELLWAN-2-BEARER_UP: Instance id=0, Default bearer (beare r_id=5) in Cellular0 is now UP.
*Jan 27 18:01:00.113: %LINK-3-UPDOWN: Interface Cellular0, changed state to up
*Jan 27 18:01:01.113: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular0, changed state to up.!!!
Success rate is 60 percent (3/5), round-trip min/avg/max = 140/185/256 ms
IR829#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 152/163/174 ms
IR829#
*Jan 27 18:01:42.227: %CELLWAN-2-BEARER_DELETED: Instance id=0, Default bearer (bearer_id=5) in Cellular0 is no w deleted.
*Jan 27 18:01:44.227: %LINK-5-CHANGED: Interface Cellular0, changed state to reset
*Jan 27 18:01:45.227: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular0, changed state to down

*Jan 27 18:01:49.227: %LINK-3-UPDOWN: Interface Cellular0, changed state to down

Here is my current configuration:

IR829#sh config
Using 3328 out of 262144 bytes
!
! Last configuration change at 17:50:56 UTC Fri Jan 27 2023
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname IR829
!
boot-start-marker
boot system flash:/ir800-universalk9-mz.SPA.156-3.M1b
boot-end-marker
!
!
enable secret xxxxxxxxxxxxxxxxxxxxxxxxxx
enable password xxxxxxxxxxxxxxxxxxxxxxxxxxx
!
no aaa new-model
service-module wlan-ap 0 bootimage autonomous
!
ignition off-timer 900
!
ignition undervoltage threshold 9
!
no ignition enable
!
!
!
!
!
!
!
!
!
!
!


!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
!
!
license udi pid IR829GW-LTE-NA-AK9 sn FTX2108Z072
!
!
!
redundancy
!
!
!
!
!
controller Cellular 0
lte sim data-profile 1 attach-profile 1 slot 0
no lte gps enable
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
description AT&T
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0
ip address 10.1.10.6 255.255.255.0
no mop enabled
!
interface GigabitEthernet1
no ip address
no mop enabled
!
interface GigabitEthernet2
no ip address
no mop enabled
!
interface GigabitEthernet3
no ip address
no mop enabled
!
interface GigabitEthernet4
no ip address
no mop enabled
!
interface Wlan-GigabitEthernet0
no ip address
no mop enabled
!
interface GigabitEthernet5
no ip address
duplex auto
speed auto
no mop enabled
!
interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer string lte
dialer-group 1
!
interface Cellular1
no ip address
encapsulation slip
!
interface wlan-ap0
no ip address
!
interface Vlan1
ip address 192.168.0.2 255.255.255.0
ip nat inside
ip virtual-reassembly in
no mop enabled
!
interface Async0
no ip address
encapsulation scada
!
interface Async1
no ip address
encapsulation scada
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Cellular0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0
ip ssh server algorithm encryption aes128-ctr aes192-ctr aes256-ctr
ip ssh client algorithm encryption aes128-ctr aes192-ctr aes256-ctr
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipv6 permit
ipv6 ioam timestamp
!
!
access-list 1 permit 192.168.0.0
access-list 1 permit 192.168.0.2
!
control-plane
!
!
!
!
line con 0
stopbits 1
line 1 2
stopbits 1
line 3
script dialer lte
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 100000000
txspeed 50000000
line 4
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 8
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 100000000
txspeed 50000000
line 1/3 1/6
transport preferred none
transport output none
stopbits 1
line vty 0 4
password xxxxxxxxxxxxxxxxxxxxxxxx
login
transport input none
!
no scheduler max-task-time
iox hypervisor password xxxxxxxxxxxxxxxxxxxxxxxx
!
!
!
!
!
!
end

IR829#

 

1 Accepted Solution

Accepted Solutions

as per the config looks ok (again basic config level of the cellular depends on provider) but you have not got IP address you may need to debug the connection.

for LTE look below example guide and confg :

https://wannabelab.blogspot.com/2016/04/cisco-899-4g-lte-router-configuration.html

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

View solution in original post

23 Replies 23

balaji.bandi
Hall of Fame
Hall of Fame

Not sure you get DHCP IP from provider:

Tweak the config as below :

config t
!
ip routing
!
no ip route 0.0.0.0 0.0.0.0 Cellular0
ip route 0.0.0.0 0.0.0.0 Cellular0 dhcp
!
!
no access-list 1 permit 192.168.0.0
no access-list 1 permit 192.168.0.2
access-list 1 permit 192.168.0.0 0.0.0.255 any
access-list 1 permit 192.168.0.2
!
end




Also can you post below output :

show ip interface brief

show ip route

show interface Cellular0

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Thank you very much for responding sir, and I really appreciate your time.
I am very new to CLI configuration, so there are many things I am still learning.

I tried entered the new configuration changes you posted and this was the result:

IR829#config t
Enter configuration commands, one per line. End with CNTL/Z.
IR829(config)#!
IR829(config)#ip routing
IR829(config)#!
IR829(config)#no ip route 0.0.0.0 0.0.0.0 Cellular0
IR829(config)#ip route 0.0.0.0 0.0.0.0 Cellular0 dhcp
IR829(config)#!
IR829(config)#!
IR829(config)#no access-list 1 permit 192.168.0.0
IR829(config)#no access-list 1 permit 192.168.0.2
IR829(config)#access-list 1 permit 192.168.0.0 0.0.0.255 any
                                                                                          ^
% Invalid input detected at '^' marker.

IR829(config)#access-list 1 permit 192.168.0.2
IR829(config)#!
IR829(config)#end
IR829#
*Jan 27 21:12:29.399: %SYS-5-CONFIG_I: Configured from console by console
IR829#wr mem
Building configuration...
[OK]
IR829#

Here is 'show ip interface brief':


IR829#show ip int brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0 10.1.10.6 YES manual down down
GigabitEthernet1 unassigned YES unset up up
GigabitEthernet2 unassigned YES unset down down
GigabitEthernet3 unassigned YES unset down down
GigabitEthernet4 unassigned YES unset down down
Wlan-GigabitEthernet0 unassigned YES unset up up
Async0 unassigned YES unset up down
Async1 unassigned YES unset up down
GigabitEthernet5 unassigned YES NVRAM up up
Cellular0 unassigned YES IPCP up up
Cellular1 unassigned YES NVRAM down down
NVI0 127.1.3.2 YES unset up up
Vlan1 192.168.0.2 YES NVRAM up up
wlan-ap0 unassigned YES NVRAM up up
IR829#


Here is 'show ip route':

IR829#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is not set

192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.0.0/24 is directly connected, Vlan1
L 192.168.0.2/32 is directly connected, Vlan1
IR829#

Here is 'show interface cellular 0':

IR829#show int cell 0
Cellular0 is up (spoofing), line protocol is up (spoofing)
Hardware is 4G WWAN Modem - North America (ATT & Canada) Multimode LTE/DC-HSPA+/HSPA+/HSPA/
Internet address will be assigned dynamically by the network
MTU 1500 bytes, BW 50000 Kbit/sec, DLY 100000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation SLIP, loopback not set
Keepalive not supported
Last input 03:14:16, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/10 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
54 packets input, 5184 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
127 packets output, 12372 bytes, 0 underruns
0 output errors, 0 collisions, 8 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
DCD=down DSR=up DTR=up RTS=up CTS=up

IR829#

my typo error :

config t

no access-list 1 permit 192.168.0.2

no access-list 1 permit 192.168.0.0 0.0.0.255  any

!

access-list 1 permit 192.168.0.0 0.0.0.255 

!

Other side I did not see you got IP address from provider

it does not matter ACL there or not, you from router you should able to ping 8.8.8.8

the ACL only matter for the users connecting Lan side.

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Ok, I corrected the configuration with that typo correction.

If I am not receiving an IP address from the cell network provider, does that mean I also have a problem with the cell 0 configuration? Or is that a problem with the cell network?

Here is my updated configuration after your recommendations:

IR829#sh config
Using 3333 out of 262144 bytes
!
! Last configuration change at 21:44:02 UTC Fri Jan 27 2023
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname IR829
!
boot-start-marker
boot system flash:/ir800-universalk9-mz.SPA.156-3.M1b
boot-end-marker
!
!
enable secret x
enable password x
!
no aaa new-model
service-module wlan-ap 0 bootimage autonomous
!
ignition off-timer 900
!
ignition undervoltage threshold 9
!
no ignition enable
!
!
!
!
!
!
!
!
!
!
!


!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
!
!
license udi pid IR829GW-LTE-NA-AK9 sn FTX2108Z072
!
!
!
redundancy
!
!
!
!
!
controller Cellular 0
lte sim data-profile 1 attach-profile 1 slot 0
no lte gps enable
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
description AT&T
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0
ip address dhcp
ip nat outside
ip virtual-reassembly in
no mop enabled
!
interface GigabitEthernet1
no ip address
no mop enabled
!
interface GigabitEthernet2
no ip address
no mop enabled
!
interface GigabitEthernet3
no ip address
no mop enabled
!
interface GigabitEthernet4
no ip address
no mop enabled
!
interface Wlan-GigabitEthernet0
no ip address
no mop enabled
!
interface GigabitEthernet5
no ip address
duplex auto
speed auto
no mop enabled
!
interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer string lte
dialer-group 1
!
interface Cellular1
no ip address
encapsulation slip
!
interface wlan-ap0
no ip address
!
interface Vlan1
ip address 192.168.0.2 255.255.255.0
ip nat inside
ip virtual-reassembly in
no mop enabled
!
interface Async0
no ip address
encapsulation scada
!
interface Async1
no ip address
encapsulation scada
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Cellular0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0 dhcp
ip ssh server algorithm encryption aes128-ctr aes192-ctr aes256-ctr
ip ssh client algorithm encryption aes128-ctr aes192-ctr aes256-ctr
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipv6 permit
ipv6 ioam timestamp
!
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
control-plane
!
!
!
!
line con 0
stopbits 1
line 1 2
stopbits 1
line 3
script dialer lte
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 100000000
txspeed 50000000
line 4
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 8
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 100000000
txspeed 50000000
line 1/3 1/6
transport preferred none
transport output none
stopbits 1
line vty 0 4
password x
login
transport input none
!
no scheduler max-task-time
iox hypervisor password x
!
!
!
!
!
!
end

IR829#

as per the config looks ok (again basic config level of the cellular depends on provider) but you have not got IP address you may need to debug the connection.

for LTE look below example guide and confg :

https://wannabelab.blogspot.com/2016/04/cisco-899-4g-lte-router-configuration.html

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Ok, good to know that the conifg for everything else except cellular 0 is ok now. Progress gives me hope!

I will read that example guide, and re-configure the cellular 0 with current APN settings for my cell provider (AT&T) right now, and then respond to you with the results.

Hello again sir,

I followed the complete example guide and configured the APN with verified settings from the cell carrier.

Still having the same issue unfortunately, even when there is an active IP on the Cellular interface from the cell carrier.
All the APN settings are correct, and the APN profile #1 is showing "ACTIVE"
I can even 'ping 8.8.8.8' with 100% success, but I still have no internet access through the WiFi AP, or the GE ports.

I'm almost wondering if this problem is due to out of date IOs software on the router? It is currently running 15.6.3 M1b.

Also please keep in mind that I am able to freely change any IP/DNS/NAT/etc. settings necessary, as I have no specific provisions for my network, and just need basic internet access on this router.

Thank you again for all of your advice and recommendations on this issue, I really appreciate the help sir.

check if the IOS available the latest to test. 

as I mentioned before, until you get IP address from ISP/Provide you will be not able to reach 8.8.8.8

show IP interface brief, you see IP address DHCP from ISP/provider to move forward rest config.

enable debug cellular connection and see what is wrong? why are you not able to connect and get IP address from the provider to start with.

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Ok, understood. 

The interesting thing is that now I do have an active IP address from the ISP/Provider, and I can successfully ping 8.8.8.8 no problem, but still no internet through AP or GE ports

The problem with upgrading the software is that I do not have a service contract for this router due to age, and the Cisco website will not allow me to download the most current IOs software without a service contract.
Is there any other way to obtain the current software image? 

apologies i read wrong here if you getting IP address and you able to ping 8.8.8.8

what is the issue ? from Lan's side device not able to get internet, the config we suggested is good and you can apply to the device and test it.

i am not much worried for now to download the latest firmware.(until any security risk on your IOS)

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

No problem sir.

The issue is that I still cannot access the internet when connected to the WiFi AP, or any of the GE ports, even though all cellular setting are correct.
I have tried connecting multiple different devices by using the GE (1-4) ports, and the WiFi AP, and all have the same result; no internet access.

Ok understood about the firmware, thank you for confirming that.

we go back ask same output you posted before :

show run

show ip interface brief

show ip route

show interface Cellular0

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Show run:

IR829#sh run
Building configuration...

Current configuration : 3428 bytes
!
! Last configuration change at 01:25:39 UTC Thu Feb 2 2023
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname IR829
!
boot-start-marker
boot system flash:/ir800-universalk9-mz.SPA.156-3.M1b
boot-end-marker
!
!
enable secret xxxx
enable password xxxx
!
no aaa new-model
service-module wlan-ap 0 bootimage autonomous
!
ignition off-timer 900
!
ignition undervoltage threshold 9
!
no ignition enable
!
!
!
!
!
!
!
!
!
!
!


!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
!
!
license udi pid IR829GW-LTE-NA-AK9 sn FTX2108Z072
!
!
!
redundancy
!
!
!
!
!
controller Cellular 0
lte sim data-profile 1 attach-profile 1 slot 0
no lte gps enable
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
description AT&T
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0
ip address dhcp
ip nat outside
ip virtual-reassembly in
no mop enabled
!
interface GigabitEthernet1
no ip address
no mop enabled
!
interface GigabitEthernet2
no ip address
no mop enabled
!
interface GigabitEthernet3
no ip address
no mop enabled
!
interface GigabitEthernet4
no ip address
no mop enabled
!
interface Wlan-GigabitEthernet0
no ip address
no mop enabled
!
interface GigabitEthernet5
no ip address
duplex auto
speed auto
no mop enabled
!
interface Cellular0
ip dhcp client update dns
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer string lte
dialer-group 1
ntp broadcast client
ntp broadcast
ntp multicast
ntp multicast client
!
interface Cellular1
no ip address
encapsulation slip
!
interface wlan-ap0
no ip address
!
interface Vlan1
ip address 192.168.0.2 255.255.255.0
ip nat inside
ip virtual-reassembly in
no mop enabled
!
interface Async0
no ip address
encapsulation scada
!
interface Async1
no ip address
encapsulation scada
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Cellular0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0
ip ssh server algorithm encryption aes128-ctr aes192-ctr aes256-ctr
ip ssh client algorithm encryption aes128-ctr aes192-ctr aes256-ctr
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipv6 permit
ipv6 ioam timestamp
!
!
access-list 1 permit 192.168.0.0 0.0.0.255
!
control-plane
!
!
!
!
line con 0
stopbits 1
line 1 2
stopbits 1
line 3
script dialer lte
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 100000000
txspeed 50000000
line 4
no activation-character
no exec
transport preferred none
transport input all
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
line 8
no exec
transport preferred lat pad telnet rlogin lapb-ta mop udptn v120 ssh
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
rxspeed 100000000
txspeed 50000000
line 1/3 1/6
transport preferred none
transport output none
stopbits 1
line vty 0 4
password xxxx
login
transport input none
!
no scheduler max-task-time
iox hypervisor password xxxx
!
!
!
!
!
!
end

IR829#

Show ip interface brief:


IR829#sh ip int brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0 unassigned YES NVRAM down down
GigabitEthernet1 unassigned YES unset down down
GigabitEthernet2 unassigned YES unset down down
GigabitEthernet3 unassigned YES unset down down
GigabitEthernet4 unassigned YES unset down down
Wlan-GigabitEthernet0 unassigned YES unset up up
Async0 unassigned YES unset up down
Async1 unassigned YES unset up down
GigabitEthernet5 unassigned YES NVRAM up up
Cellular0 21.38.217.248 YES IPCP up up
Cellular1 unassigned YES NVRAM down down
NVI0 127.1.3.2 YES unset up up
Vlan1 192.168.0.2 YES NVRAM up up
wlan-ap0 unassigned YES NVRAM up up
IR829#

Show ip route: 

IR829#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S* 0.0.0.0/0 is directly connected, Cellular0
21.0.0.0/32 is subnetted, 1 subnets
C 21.38.217.248 is directly connected, Cellular0
192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.0.0/24 is directly connected, Vlan1
L 192.168.0.2/32 is directly connected, Vlan1
IR829#

Show interface Cellular0:

IR829#sh int cell 0
Cellular0 is up, line protocol is up
Hardware is 4G WWAN Modem - North America (ATT & Canada) Multimode LTE/DC-HSPA+/HSPA+/HSPA/
Internet address is 21.38.217.248/32
MTU 1500 bytes, BW 50000 Kbit/sec, DLY 100000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation SLIP, loopback not set
Keepalive not supported
Last input 00:05:57, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/10 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
38 packets input, 3648 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
38 packets output, 3800 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions
DCD=up DSR=up DTR=up RTS=up CTS=up

IR829#

 

i do not see any config issue, what happens when you connect the device like PC

having IP 192.168.0.10 mask 255.255.255.0 and gateway 192.168.0.2

DNS 8.8.8.8

are you not able to get internet ?

also check show xlate and show nat translation

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card