02-28-2020 01:44 PM
Hey community! We have a Cisco 4331 or 10 in our environment. Below is our current QoS policy. When I do a "show access-lists" I don't get a count for matches for access list 101, which is used in our QoS policy. Does that mean the access list isn't catching traffic for the "rdpfromlan" class map, therefor won't really do anything in our service policy tied to our MPLS interface Gi0/0/2? We are taking Citrix traffic and putting it on our MPLS network with a precedence of 2 via access list 101 so our ISP can properly QoS it if we ever reached bandwidth limits.
The 172.29.0.0/16 subnet is our remote network data subnets, and 172.17.99.0/24 is our citrix server environment subnet.
at-grsc-mpls-rt01#show access-lists
Standard IP access list 20
10 permit 172.16.1.166 (24833476 matches)
Standard IP access list CoreSwitch
10 permit 172.17.101.129 log
20 permit 172.17.101.2 log
Standard IP access list Management
10 permit 172.16.0.0, wildcard bits 0.15.255.255 (918 matches)
Extended IP access list 101
10 permit tcp 172.29.0.0 0.0.255.255 172.16.0.0 0.0.255.255 eq 3389
20 permit tcp 172.30.0.0 0.0.255.255 172.16.0.0 0.0.255.255 eq 3389
30 permit tcp 172.29.0.0 0.0.255.255 172.17.99.0 0.0.0.255 eq 3389
40 permit tcp 172.30.0.0 0.0.255.255 172.17.99.0 0.0.0.255 eq 3389
50 permit tcp 172.29.0.0 0.0.255.255 172.17.99.0 0.0.0.255 eq 1494
60 permit tcp 172.29.0.0 0.0.255.255 172.17.99.0 0.0.0.255 eq 2598
70 permit udp 172.29.0.0 0.0.255.255 172.17.99.0 0.0.0.255 eq 2598
Extended IP access list 102
10 permit tcp 172.17.99.0 0.0.0.255 172.29.0.0 0.0.255.255
20 permit udp 172.17.99.0 0.0.0.255 172.29.0.0 0.0.255.255
Extended IP access list guestwifi
10 permit udp any any eq bootps (24264 matches)
20 permit udp any any eq bootpc
30 deny ip 172.31.16.0 0.0.0.255 10.0.0.0 0.255.255.255
40 deny ip 172.31.16.0 0.0.0.255 172.16.0.0 0.15.255.255 (438495 matches)
50 deny ip 172.31.16.0 0.0.0.255 192.168.0.0 0.0.255.255 (11998 matches)
60 permit ip any any (62092796 matches)
70 permit icmp any any
class-map match-any voicefromlan
match ip dscp ef
class-map match-any rdpfromlan
match access-group 101
class-map match-any voicefromwan
match ip precedence 5
class-map match-any cntrfromwan
match ip precedence 4
class-map match-any cntrfromlan
match ip dscp cs3
match ip dscp af31
class-map match-any rdpfromwan
match access-group 102
!
policy-map lanedge
class voicefromwan
bandwidth percent 25
set dscp ef
class cntrfromwan
bandwidth percent 10
set dscp cs3
class rdpfromwan
bandwidth percent 35
class class-default
fair-queue
policy-map wanedge
class voicefromlan
bandwidth percent 25
set precedence 5
class cntrfromlan
bandwidth percent 10
set precedence 4
class rdpfromlan
bandwidth percent 35
set precedence 2
class class-default
fair-queue
shape average percent 10
interface GigabitEthernet0/0/0
description To LAN
bandwidth 100000
ip flow monitor NetFlowMonitor1 input
ip flow monitor NetFlowMonitor1 output
ip address 172.17.101.1 255.255.255.252
negotiation auto
service-policy output lanedge
!
interface GigabitEthernet0/0/1
description CID- CenturyLink ETH1000-XXXX
ip flow monitor NetFlowMonitor1 input
ip flow monitor NetFlowMonitor1 output
ip address 1.2.3.4 255.255.255.252
negotiation auto
service-policy output wanedge
02-28-2020 03:09 PM
Hi,
to confirm whether traffic is getting classified and policed , can you get the output from the Router of below:
show policy-map interface gi0/0
it will show you the packets classified and shaped/policed.
02-29-2020 01:03 AM
Hello,
when your access lists don't show any matches, that could indicate that the access list somehow does not match the traffic flow. Try and temporarily change the access list to:
access list 101 permit tcp any any eq 3389
access list 101 permit tcp any any eq 1494
access list 101 permit tcp any any eq 2598
access list 101 permit udp any any eq 2598
or change the class map to match citrix:
class-map match-any rdpfromlan
match protocol citrix
and check if you get any hits then...
02-29-2020 04:37 AM
02-29-2020 04:47 AM
The count should be there indeed...
02-29-2020 01:05 PM
Hello
easiest way is as suggested @Muhammad Awais Khan look at the policy map
02-29-2020 10:32 AM
03-02-2020 06:10 AM - edited 03-02-2020 07:59 AM
EDIT: I cleared the counters on the interface, and if I do a "show policy-map interface gi0/0/2", on the MPLS interface, I can see the packet count going up for rdpfromlan, but if I do a "show access-lists" the count next to access list 101 does not go up? From the ACL the 172.29.0.0/16 subnet is the data subnet of our remote site, and 172.17.99.0/24 are our citrix servers at our data center.
at-chtx-mpls-rt01#show policy-map interface gi0/0/2
Class-map: rdpfromlan (match-any)
11886 packets, 823950 bytes
5 minute offered rate 19000 bps, drop rate 0000 bps
Match: access-group 101
Queueing
queue limit 64 packets
(queue depth/total drops/no-buffer drops) 0/0/0
(pkts output/bytes output) 11886/823950
bandwidth 35% (3584 kbps)
QoS Set
precedence 2
Marker statistics: Disabled
at-chtx-mpls-rt01#show access-lists
Standard IP access list Management
10 permit 172.16.0.0, wildcard bits 0.15.255.255 (92 matches)
Extended IP access list 101
10 permit tcp 172.29.0.0 0.0.255.255 172.16.0.0 0.0.255.255 eq 3389
20 permit tcp 172.30.0.0 0.0.255.255 172.16.0.0 0.0.255.255 eq 3389
30 permit tcp 172.29.0.0 0.0.255.255 172.17.99.0 0.0.0.255 eq 3389
40 permit tcp 172.30.0.0 0.0.255.255 172.17.99.0 0.0.0.255 eq 3389
50 permit tcp 172.29.0.0 0.0.255.255 172.17.99.0 0.0.0.255 eq 1494
60 permit tcp 172.29.0.0 0.0.255.255 172.17.99.0 0.0.0.255 eq 2598
70 permit udp 172.29.0.0 0.0.255.255 172.17.99.0 0.0.0.255 eq 2598
80 permit tcp 172.16.0.0 0.0.255.255 172.29.0.0 0.0.255.255 eq 3389
90 permit tcp 172.16.0.0 0.0.255.255 172.30.0.0 0.0.255.255 eq 3389
100 permit tcp 172.17.99.0 0.0.0.255 172.29.0.0 0.0.255.255 eq 3389
110 permit tcp 172.17.99.0 0.0.0.255 172.30.0.0 0.0.255.255 eq 3389
120 permit tcp 172.17.99.0 0.0.0.255 172.29.0.0 0.0.255.255 eq 1494
130 permit tcp 172.17.99.0 0.0.0.255 172.29.0.0 0.0.255.255 eq 2598
140 permit udp 172.17.99.0 0.0.0.255 172.29.0.0 0.0.255.255 eq 2598
Extended IP access list guestwifi
10 permit udp any any eq bootps (28677 matches)
20 permit udp any any eq bootpc
30 deny ip 172.31.11.0 0.0.0.255 10.0.0.0 0.255.255.255 (266 matches)
40 deny ip 172.31.11.0 0.0.0.255 172.16.0.0 0.15.255.255 (14016 matches)
50 deny ip 172.31.11.0 0.0.0.255 192.168.0.0 0.0.255.255 (5620 matches)
60 permit ip any any (20769840 matches)
70 permit icmp any any
03-02-2020 09:50 AM
03-02-2020 10:11 AM
Sorry the 172.29.0.0/16 is the LAN side of this remote site MPLS router, and 172.17.99.0/24 is over the MPLS WAN to our datacenter. This is from the perspective of the remote site router as it classifies traffic going onto the mpls coming from a 172.29.0.0/16 data subnet going to a 172.17.99.0/24 citrix server.
On our example router the Gi0/0/2 is the MPLS connection, Gi0/2/0 goes to our FTD 1010 firewall where our DMVPN traffic goes, and Gi0/0/1.X is our subinterfaces for vlan tagging.
Long story short example is we have a computer at IP 172.29.11.20 trying to reach a citrix server over the MPLS connection through Gi0/0/2 at 172.17.99.100 on port 2598 or 1494. We want to take that traffic and give it a precedence of 2 when it goes onto the MPLS network out interface Gi0/0/2 destined for 172.17.99.100 from 172.29.11.20.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide