04-10-2006 10:14 AM - edited 03-03-2019 12:21 PM
Is there a way to block static routes from propagating via BGP?
When testing SRST mode; we sent all traffic dest for the Call Managers to null0
ip route 0.0.0.0 0.0.0.0 CCM null0
Weel this put the phones into SRST mode, but also propagated over the BGP network and started killing all of my other remote sites.
I need to find a way to block 'bad' static routes from being propagated to other sites. We use EIGRP/BGP over a MPLS Frame Relay network.
sample config from ONE of the sites:
[code]
router eigrp 20
network 10.0.0.0
no auto-summary
!
router bgp 1
no synchronization
bgp log-neighbor-changes
redistribute eigrp 20
neighbor 199.220.198.181 remote-as 65000
no auto-summary
!
ip default-gateway 199.220.198.181
ip classless
ip route 0.0.0.0 0.0.0.0 199.220.198.181
!
[/code]
I'm thinking maybe persistant routes or blocking redistribution of statics [or just null0 routes]????
Cisco80211
Chris Serafin
IT Security / Cisco VoIP Engineer
04-10-2006 11:08 AM
Chris,
Looking at your configuration, I don't know how the default route got injected into BGP. First, you don't have a "redistribute static" statement and second, you need to configure "default-information oringinate" under the BGP process to allow redistribution of the default route into bgp.
Hope this helps,
04-10-2006 12:41 PM
version 12.4
no service pad
clock timezone EST -5
clock summer-time EDT recurring
network-clock-participate wic 0
ip subnet-zero
no ip source-route
!
!
ip cef
!
!
ip domain name routers.ocena.oce.net
ip name-server 10.1.1.45
ip name-server 10.1.1.46
username o privilege 15 password xxxx
username xxx privilege 15 password xxxx
!
!
controller T1 0/0/0
framing esf
linecode b8zs
channel-group 0 timeslots 1-24
!
controller T1 0/0/1
framing esf
linecode b8zs
ds0-group 1 timeslots 1-12 type e&m-wink-start
!
class-map match-any 2_Voice_Video
description Class-map to define VoIP traffic
match ip precedence 5
match ip dscp ef
match protocol rtp audio
match protocol rtp video
match ip precedence 7
match ip precedence 4
match ip precedence 6
class-map match-any 4_Business_Critical
description Class-map reserved for future use
class-map match-any 1_Gold_CAR
description GoldCAR class: Only 8k and not being used
class-map match-any 3_Mission_Critical
description Class-map to define VoIP control traffic
match protocol h323
match protocol rtcp
match protocol mgcp
match ip precedence 3
match access-group name UNITY_CCM_DHCP_SERVERS
!
!
policy-map OCE_QOS_ver1.0
class 1_Gold_CAR
class 2_Voice_Video
set ip dscp af41
priority percent 30
class 3_Mission_Critical
set ip dscp af31
bandwidth remaining percent 20
class 4_Business_Critical
class class-default
bandwidth remaining percent 80
random-detect dscp-based
!
!
interface Loopback0
ip address 172.16.100.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no ip mroute-cache
duplex full
speed 100
!
interface FastEthernet0/0.1
encapsulation dot1Q 1 native
ip address 10.1.87.1 255.255.255.0
ip helper-address 10.1.2.10
no snmp trap link-status
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 10.1.187.1 255.255.255.0
ip helper-address 10.1.2.10
no snmp trap link-status
!
interface FastEthernet0/1
ip address 10.4.87.1 255.255.255.0
ip access-group demo-floor in
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
no ip mroute-cache
duplex auto
speed auto
!
interface Serial0/0/0:0
description MCI MPLS Circuit glastonbury-ct_bc1-1504325
bandwidth 1536
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip nbar protocol-discovery
encapsulation frame-relay
ip route-cache flow
frame-relay lmi-type cisco
max-reserved-bandwidth 90
service-policy output OCE_QOS_ver1.0
!
interface Serial0/0/0:0.1 point-to-point
description MCI MPLS Circuit glastonbury-ct_bcb1-1504325
ip address 199.x.x.x.255.255.252
frame-relay interface-dlci 100 IETF
!
router eigrp 20
network 10.0.0.0
no auto-summary
!
router bgp 1
no synchronization
bgp log-neighbor-changes
redistribute eigrp 20
neighbor 199.220.198.181 remote-as 65000
no auto-summary
!
ip default-gateway 199.220.198.181
ip classless
ip route 0.0.0.0 0.0.x.x.220.198.181
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide