05-24-2017 11:40 PM - edited 03-05-2019 08:36 AM
Hello Community Members,
How best can i connect my Router to two ISP links with BGP configured.
I in addition would like to do setup High availability on both links such that if ISP --A links becomes unstable due to constant flapping then the Second ISP---B takes over .
Thanks
05-25-2017 12:07 AM
Hello,
flapping can be countered with BGP dampening.
As with regard to high availability, the options are numerous, and depend on your physical setup. If you provide more details (e.g. a schematic drawing of your setup), we can give you more details. In the meantime, have a look at the link below:
http://showipbgp.com/bgp-configurations/cisco.html
05-25-2017 08:36 AM
05-25-2017 02:24 PM
Hello,
here is what the configuration would look like. In your setup, you can only do load sharing. I assumed your AS to be 10, and the LAN address space to be 192.168.1.0/24, you probably have to change those accordingly:
interface GigabitEthernet1/0
description Link to ISP A
ip address 41.10.20.2 255.255.255.252
no ip route-cache
interface GigabitEthernet1/1
description Link to ISP B
ip address 212.101.65.6 255.255.255.252
no ip route-cache
router bgp 10
bgp dampening
neighbor 41.10.20.1 remote-as 20
neighbor 41.10.20.1 route-map ISP_LOW in
neighbor 212.101.65.5 remote-as 50
neighbor 212.101.65.5 route-map ISP_HIGH in
auto-summary
route-map ISP_LOW permit 10
match ip address 1
set weight 100
route-map ISP_LOW permit 20
match ip address 2
route-map ISP_HIGH permit 10
match ip address 1
route-map ISP_HIGH permit 20
match ip address 2
set weight 100
access-list 1 permit 0.0.0.0 127.255.255.255
access-list 2 deny 0.0.0.0 127.255.255.255
access-list 2 permit any
05-26-2017 03:44 AM
I would like to admit that unequal load-balancing is also possible...
05-25-2017 12:26 PM
Hi
You can use BGP attributes like local preference and AS Path in order to have symmetric traffic, also in order to avoid flapping you can configure fast fallover and BGP dampening.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide