cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1079
Views
5
Helpful
12
Replies
Highlighted
Beginner

ISP load balacing and redundacy

Hi Gurus,

I have a connection to ISP_A(int G0/1) and another connection to ISP_B (int G0/2) they all terminated at my  router. With interface G0/0 as my internal interface.


I have routed traffic from my servers farm (10.10.5.0/24) through ISP_A and my users traffic(192.168.240.0/24) pass through  ISP_B and natting configured.


But i need a configuration that will track the two interfaces and if ISP_A is down, it should re-route the traffic from the servers farm to ISP_B, and when ISP_A is back the servers farm traffic should be reverted back to ISP_A. Same goes for ISP_B when it is down, the users should be re-routed to ISP_A, and when ISP_B is back, the user traffic should be reverted back to ISP_B.


below is a snippest of my config for further inputs from you gurus!


interface GigabitEthernet0/0
description CONNECTION TO INTERNAL_NETWORK
ip address 192.168.240.1 255.255.255.252
ip nat inside
ip virtual-reassembly
ip policy route-map POLICY_Internet_Traffic


interface GigabitEthernet0/1
description CONNECTION TO ISP_A_INTERNET_BACKBONE
ip address 192.168.15.14 255.255.255.240
ip nat outside
ip virtual-reassembly

!
interface GigabitEthernet0/2
description CONNECTION TO ISP_B_INTERNET_BACKBONE
ip address 172.16.50.2 255.255.255.0
ip nat outside
ip virtual-reassembly

!

ip nat inside source route-map ISP_A interface GigabitEthernet0/1 overload
ip nat inside source route-map ISP_B interface GigabitEthernet0/2 overload

!

ip route 0.0.0.0 0.0.0.0 192.168.15.13 name ROUTE-TO-ISP-A

ip route 0.0.0.0 0.0.0.0 172.16.50.1 name ROUTE-TO-ISP-B

!
ip access-list extended Traffic_To_ISP_B
deny   ip 10.10.5.0 0.0.0.255 any
permit ip any any
ip access-list extended Traffic_To_ISP_A
permit ip 10.10.5.0 0.0.0.255 any
ip access-list extended POLICY_Internet
permit ip 10.10.5.0 0.0.0.255 any
!
!
route-map POLICY_Internet_Traffic permit 10
match ip address POLICY_Internet
set ip next-hop 192.168.15.13
!
route-map ISP_B permit 10
match ip address Traffic_To_ISP_B
!
route-map ISP_A permit 10
match ip address Traffic_To_ISP_A
!

Awaiting your response soon!

12 REPLIES 12
Highlighted

Re: ISP load balacing and redundacy

Hi,

Config the two WAN interfaces like below for redundancy.

interface GigabitEthernet0/1
description CONNECTION TO ISP_A_INTERNET_BACKBONE
track 1 interface GigabitEthernet0/2 line-protocol
delay down 5 up 30
ip address 192.168.15.14 255.255.255.240
ip nat outside
ip virtual-reassembly

!
interface GigabitEthernet0/2
description CONNECTION TO ISP_B_INTERNET_BACKBONE
track 1 interface GigabitEthernet0/1 line-protocol
delay down 5 up 30
ip address 172.16.50.2 255.255.255.0
ip nat outside
ip virtual-reassembly


Hope this will helps.

Please rate the helpfull posts.

Regards,
Naidu.

Highlighted
Beginner

Re: ISP load balacing and redundacy

Hi Naidu,

thanks for the quick response,i tried it but its not working, if you look at my config carefully, i created a policy that match my server farm ip address(denied all user traffic ) and set it next-hop to point to ISP_A and all user traffic is sent  to ISP_B.

The code you included does not take into account the ip policy and reroute the traffic with it.

Other response is welcome!

thanks!!

Beginner

Re: ISP load balacing and redundacy

Hi Tunde,

Have a look at the link below which shows an example of how to implement a failover using IP SLA and tracking object. I remember testing this a while back and it worked.

http://www.inacom-sby.net/Shawn/post/2007/11/Cisco-IP-SLA-for-failover.aspx

Regards,

AJ

Highlighted
Beginner

Re: ISP load balacing and redundacy


Current configuration : 1756 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Tunde_Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

!

!

ip cef

!

!

ip sla monitor 1

type echo protocol ipIcmpEcho 200.1.1.2

timeout 1000

frequency 3

ip sla monitor schedule 1 life forever start-time now


track 1 rtr 1 reachability


interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.0

ip policy route-map POLICY

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial1/0

ip address 200.1.1.1 255.255.255.0

serial restart-delay 0

!

interface Serial1/1

ip address 201.1.1.1 255.255.255.0

serial restart-delay 0

!

interface Serial1/2

no ip address

shutdown

serial restart-delay 0

!

interface Serial1/3

no ip address

shutdown

serial restart-delay 0


ip local policy route-map ROUTER_TRAFFIC

ip http server

no ip http secure-server

ip forward-protocol nd


ip access-list extended Datacentertraffic

permit ip host 192.168.1.20 any

ip access-list extended usertraffic

permit tcp host 192.168.1.21 any any

permit tcp host 192.168.1.21 any any

ip access-list extended ROUTER

permit ip any any

!

route-map POLICY permit 10

match ip address datacentertraffic

set ip next-hop 201.1.1.2

!

route-map POLICY permit 20

match ip address usertraffic

set ip next-hop 200.1.1.2

!

route-map POLICY permit 30

set ip next-hop 201.1.1.2

!

route-map ROUTER_TRAFFIC permit 10

match ip address ROUTER

set ip next-hop verify-availability 200.1.1.2 10 track 1

set ip next-hop 201.1.1.2


control-plane

line con 0

line aux 0

line vty 0 4

login

!

!

end

I hope this helps,

AA

Highlighted
Beginner

Re: ISP load balacing and redundacy

Hi Abdul,

Your configs is cool,simulated it and its works great just the way i wanted!!!!

Thanks alot mate and to everyone that contributed to this topic.

Highlighted
Beginner

Re: ISP load balacing and redundacy

Hi Tunde,

I'm glad you found it useful, please rate helpful posts.

Aziz

Highlighted
Beginner

Re: ISP load balacing and redundacy

Hi, Aziz. Your post actual for me, can i ask you?. Have you any configuration for additonal this ISP load balacing and redundacy + configure SLA monitoring fully. I mean that, for example, if  ISP1 downs all local hosts work through ISP2 and back if ISP1 ups work with both ISP1 and ISP2. Note the remote branch has two ISP (1 and 2) also.

Thanks in advance!

Highlighted
Beginner

Re: ISP load balacing and redundacy

Dear Aziz,

I tried to implement this config on a 2911 router with the Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.0(1)M3, but the IP SLA command in not working.?

After i entered the IP SLA command and do a ? the only options i see is responder !

Can someone who have done this on this IOS help please!

Thanks In Anticipation

Highlighted
Rising star

Re: ISP load balacing and redundacy

Highlighted
Beginner

Re: ISP load balacing and redundacy

HI Sean,

I did not buy the data license,but i should be able to implement the load balancing with the default IOS (ver15.0) that came with it from the factory.

Any Assistant will be appreciated!

Thanks

Highlighted
Beginner

Re: ISP load balacing and redundacy

check the IOS version.

Highlighted
Beginner

Re: ISP load balacing and redundacy

Hi Abdul

 

Can u explain the route-map ROUTER_TRAFFIC permit 10 line, ? Why is it mentioned in that way? and what is it's purpose here in Failover?