Showing results for 
Search instead for 
Did you mean: 

ISR 4221 Guestshell Network Access


So I read that as of IOS XE 16.8.1, you can enable the guestshell with only 4G of RAM which is what our ISR 4221s have.  How do we configure this? I get the following when trying:


Test_host#guestshell enable
Interface will be selected if configured in app-hosting
Please wait for completion
% Error: No interface configuration for guestshell


The goal is to get iperf on the guestshell and talking to another iperf server.  Is this possible using Gi0/0/0 on the router with some kind of NAT?

17 Replies 17




      What this documentation does not say is the missing piece of the puzzle>

First you need to use NAT if you want guestshell to have access to outside since guestshell uses the virtualportgroup to communicate. Virtualportgroup needs and ip. Once that is done you do the following which is not described on any document.
conf ter
app-hosting appid guestshell <-- hidden command and will be removed eventually
vnic gateway1 virtualportgroup 0 guest-interface 0



This will map your VPG to your physical interface so that guestshell has a working mapped interface. Hope that helps.
Then just run guestshell enable and it should be fine.


Have fun :)


The key on a router like CSR is syntax. I had the same problem as all of you and read all of the same threads but nothing was clear about what the problem was.. missing route attributes, duplicate interfaces...


I found my configs firsts using 

Router#show running-config | section app-hosting

!this showed my botched settings for the appid guestshell 

>I used a 'no' command in front of each line I didn't want to clean up the config parameters

Router#no app-vnic gateway0  ! removes the gateway0 configs


you need to has an 'app-default-gateway (IP address) guest-interface 0'

also use 1 not 0 for the gateway as well as vnic NOT app-vnic

 router(config-if)#vnic gateway 1virtualportgroup 0 guest-interface 0

router(config- gateway)#guest-ipaddress (IP) netmask (subnet)



see the pic attached


Thanks this worked, although your text and your image are different! I followed what was in your screenshot instead of the text as it is indeed app-vnic not vnic. Not sure why there's a need for multiple gateways but it's working now after I was getting the XML error - by the way Cisco you've left a typo


9300#guestshell enable
Interface will be selected if configured in app-hosting
Please wait for completion
% Error: Error while creating app comtainer XML error: Domain interface: Missing required gateway attribute in route definition


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers