cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

328
Views
0
Helpful
14
Replies
Highlighted
Beginner

LACp Configuration on SG 550 Switch

Hi team, 

         I Have configured LACp configuration on SG 550 switch - after that i am getting following output, 

 

Po2 Active: gi1-2

 

I Have configured for two  Gigabit ethernet port but in active state it shows only one port Why ?

This is my switch Configuration

 

switch4fe4de#show running-config
config-file-header
switch4fe4de
v2.5.0.83 / RTESLA2.5_930_364_091
CLI v1.0
file SSD indicator encrypted
@
ssd-control-start
ssd config
ssd file passphrase control unrestricted
no ssd file integrity control
ssd-control-end cb0a3fdb1f3a1af4e4430033719968c0
!
!
unit-type-control-start
unit-type unit 1 network gi uplink none
unit-type-control-end
!
vlan database
vlan 2,15-16
exit
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
no boot host auto-config
no boot host auto-update
bonjour interface range vlan 1
hostname switch4fe4de
username admin password encrypted 7af2d10b73ab7cd8f603937f7697cb5fe432c7ff privilege 15
clock timezone J 0 minutes 0
!
interface vlan 2
ip address 192.168.137.3 255.255.255.128
!
interface vlan 16
ip address 192.168.139.65 255.255.255.248
!
interface GigabitEthernet1
no negotiation
spanning-tree link-type point-to-point
channel-group 2 mode on
switchport mode trunk
macro description switch
!next command is internal.
macro auto smartport dynamic_type switch
!
interface GigabitEthernet2
no negotiation
spanning-tree link-type point-to-point
channel-group 2 mode on
switchport mode trunk
macro description switch
!next command is internal.
macro auto smartport dynamic_type switch
!
interface GigabitEthernet3
no switchport
!
interface Port-Channel2
flowcontrol on
spanning-tree link-type point-to-point
switchport mode trunk
macro description switch
!next command is internal.
macro auto smartport dynamic_type switch
!
exit
ip default-gateway 192.168.139.66

In both switch side i have configured Lacp Auto only.

 

Please help me to complete the configuration with two enable ports.

 

Thanks,

Regards,

Yasmeen Shaul Hameed.

1 ACCEPTED SOLUTION

Accepted Solutions
VIP Advocate

Re: LACp Configuration on SG 550 Switch

HI,

A few days ago, I faced the same issue and one port is getting suspended. I checked everything and found a bug with Cisco IOS. What is the firmware version? 

Point: It is not recommended but you can try with restart both switches at same time.

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!

View solution in original post

14 REPLIES 14
VIP Advisor

Re: LACp Configuration on SG 550 Switch

Hi there,

What is the LACP state of the ports on the device(s) at the other end of the port-channel?

 

cheers,

Seb.

Beginner

Re: LACp Configuration on SG 550 Switch

Hi,
Another end of Switch port configuration as follows,

interface GigabitEthernet1/0/1
no negotiation
spanning-tree link-type point-to-point
channel-group 1 mode on
switchport mode trunk
macro description switch
!next command is internal.
macro auto smartport dynamic_type switch
!

interface GigabitEthernet2/0/1
no negotiation
spanning-tree link-type point-to-point
channel-group 1 mode on
switchport mode trunk
macro description switch
!next command is internal.
macro auto smartport dynamic_type switch


switchf8fa54#show interfaces port-channel

Load balancing: src-dst-mac.

Gathering information...
Channel Ports
------- -----
Po1 Active: gi1/0/1,gi2/0/1
VIP Advisor

Re: LACp Configuration on SG 550 Switch

Hi there,

You have configured both ends with mode on, so this means LACP is not being used.

 

Try changing the channel-group commands on both ends to mode active.

 

Then share the output of sh etherchannel summary

 

cheers,

Seb.

Beginner

Re: LACp Configuration on SG 550 Switch

Hi,
I am using Cisco SG550 switch, In this i am unable to configure Active State,
The switch has only Auto and On state only,

https://www.cisco.com/c/en/us/support/docs/smb/switches/cisco-550x-series-stackable-managed-switches/smb5848-configuring-lag-settings-on-a-switch-through-cli.html?dtid=osscdc000283

As this link only i have configured on my switch.
VIP Advisor

Re: LACp Configuration on SG 550 Switch

OK, then put the SG550 end to mode auto and the other (IOS?) end to mode active.

 

Check the output to show etherchannel summary on the IOS switch.

 

cheers,

Seb.

Beginner

Re: LACp Configuration on SG 550 Switch

Hi,
I have both side only SG550 switches only,
Then How can i configure as active
i have only two options on other side also
SG550 <-------> SG550 <------> SG550
VIP Advisor

Re: LACp Configuration on SG 550 Switch

My mistake.

In which case I suggest you test each LAG pair in isolation. Remove the channel-group config and shut down one of the interfaces of the pair. 

 

Gi1   <---> Gi1/0/1

Gi2 (shutdown)  <-->  Gi2/0/1

 

Once tested, shut Gi1 and no shut Gi2.

 

This will confirm that the link is capable of being UP/UP and forwarding. It will be interesting to see if both links work when not bundled.

 

cheers,

Seb.

Beginner

Re: LACp Configuration on SG 550 Switch

Actually when i am shutting down one port ans un shut the another port my data traffic can pass perfectly,

My query is
i have configured LACp protocol on both switches end
In that one switch config shows as a
Po1 Active: gi1/0/1,gi2/0/1

Another switch shows as a
Po2 Active: gi 2
but in this case i have enabled both gi 1, gi 2 port i have enabled with LACp
but it shows only Gi 2 port is Active
same time second switch not showing as active why ?
first switch can show as Po 1 Active : Gi1/0/1, Gi 2/0/1
second switch can show as Po 2 Active : gi1





VIP Advisor

Re: LACp Configuration on SG 550 Switch

The SG documentation states that mode on doesn't use LACP negotiation. It is just bundling the links together. If there is an issue with a member link the LAG will not know it.

Auto mode is described differently to IOS. On IOS, auto is for PAgP, but the SGxxx uses it for LACP negotiation. on IOS having an auto<-->auto pair would not work. Perhaps the SGxxx will behave differently.

 

Perhaps try mode auto on both ends. You may end up with just one working member link, this indicates you have an issue with the other not becoming an active member of the bundle.

Rising star

Re: LACp Configuration on SG 550 Switch

SG550 <-------> SG550 <------> SG550

do you mean 3 switches are involved?

or do you mean 2 switches ?

SG550 <-------> SG550

            <------> 

 

in the first situation you end up with two LAG groups each with a single interface!

Beginner

Re: LACp Configuration on SG 550 Switch

Yes, I mean to Three switches are involved with two links,
SG550 <----> SG550 <-----> SG350
Po : Active :gi1,2 ...>Po 2 : Active Gi 2
Beginner

Re: LACp Configuration on SG 550 Switch

HI,
Yes, I mean to Three switches are involved with two links,
SG550 <=====> SG550 <====> SG350
Po : Active :gi1,2 ...>Po 2 : Active Gi 2
Rising star

Re: LACp Configuration on SG 550 Switch

"macro auto smartport dynamic_type switch"

I suggest a test with auto-smartports disabled or set manually instead of dynamic

 

"Auto Smartport waits for a device to be attached to the interface before applying a configuration. When a device is detected from an interface, the Smartport macro (if assigned) that corresponds to the Smartport type of the attaching device is automatically applied."

 

if the detection is not correct the wrong settings may be applied.

whether detection be correct or not, the macro may overrule your manual settings

VIP Advocate

Re: LACp Configuration on SG 550 Switch

HI,

A few days ago, I faced the same issue and one port is getting suspended. I checked everything and found a bug with Cisco IOS. What is the firmware version? 

Point: It is not recommended but you can try with restart both switches at same time.

 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!

View solution in original post

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here