cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
998
Views
0
Helpful
1
Replies

Load balancing NAT over 2 satellite connections

chris4809833
Level 1
Level 1

I have 2 seperate satellite connections running @ 2mbps. I am looking to load balance my internal network over each of the two connections. So far, I have been unable to get both connections to be used simultaneously. Network layout is as follows:

Sat Modem 1 > Int fa0/0 > internal network 192.168.19.x

Sat Modem 2 > Int fa1/0 > internal network 192.168.19.x

If I have either modem plugged in by itself, the nat works, but when I add the second one into the mix it is not load balancing over them. Am I missing something? The modems are each providing dhcp and I am not able to change this so the fastethernet interfaces have been given static ip's to match the dhcp pools of the modems. Any help is appreciated.

interface FastEthernet0/0

description Outside interface to Sat modem

bandwidth 1100

ip address 10.142.36.61 255.255.255.240

ip nat outside

ip nbar protocol-discovery

ip route-cache flow

speed 100

full-duplex

interface FastEthernet0/1

description Inside interface to tent LAN

ip address 192.168.19.1 255.255.255.0

ip nat inside

ip nbar protocol-discovery

ip route-cache flow

speed 100

full-duplex

interface FastEthernet1/0

description Outside interface to Sat modem

bandwidth 1100

ip address 10.142.36.75 255.255.255.240

ip nat outside

ip nbar protocol-discovery

ip route-cache flow

speed 100

full-duplex

interface FastEthernet1/1

no ip address

shutdown

ip nat inside source route-map tentnat interface FastEthernet0/0 overload

ip nat inside source route-map tentnat2 interface FastEthernet1/0 overload

ip route 0.0.0.0 0.0.0.0 10.142.36.49

ip route 0.0.0.0 0.0.0.0 10.142.36.65

access-list 7 permit 192.168.19.0 0.0.0.255

access-list 20 permit 192.168.19.0 0.0.0.255

access-list 110 permit ip host 192.168.19.14 any

route-map tentnat2 permit 10

match ip address 7

match interface FastEthernet0/1

route-map tentnat permit 10

match ip address 7

match interface FastEthernet0/0

1 Reply 1

Mark DeLong
Level 4
Level 4

Already posted this on Chris's FB (he's a buddy of mine) but I figured I would put it here for everyone else. I believe the problem is that hte top route-map has the wrong matching interface listed. The interface to be matched is the outbound interface (same as in the corresponding nat statement). So:

route-map tentnat2 permit 10

match ip address 7

match interface FastEthernet0/1

Should be:

route-map tentnat2 permit 10

match ip address 7

match interface FastEthernet1/0

Also, NAT load balancing I believe is going to be uneven because CEF load balances based on an algorythm rather than a in a round robin fashion. So open many connections before checking with a show ip nat trans. Also, you may want to look at changing the CEF algorithm options and see if that gives you better load balancing in production if it's not coming out as even as you would like.

Review Cisco Networking for a $25 gift card