11-25-2009 04:52 AM - edited 03-04-2019 06:47 AM
Hallo,
I need mark traffic from specific FE switch port on C1802 when in goes thrue Dialer there is done some Qos process.
How can I do this on FE 8 if all ports are in BVI1?
I tryed IP based marking that is not good in case of DHCP clinets off course.
!
interface FastEthernet1
!
!
interface FastEthernet2
!
!
interface FastEthernet3
!
!
interface FastEthernet4
!
!
interface FastEthernet5
!
!
interface FastEthernet6
!
!
interface FastEthernet7
!
!
interface FastEthernet8
!
!
interface Vlan1
no ip address
bridge-group 1
!
interface BVI1
description $ES_LAN$$FW_INSIDE$
ip address 192.168.X.X 255.255.255.0
no ip redirects
no ip unreachables
ip nbar protocol-discovery
ip flow ingress
ip flow egress
ip nat inside
ip virtual-reassembly
zone-member security in-zone
ip tcp adjust-mss 1452
!
!
bridge 1 protocol ieee
bridge 1 route ip
!
Thanks,
Urbanek
Solved! Go to Solution.
11-27-2009 10:05 AM
giuslar wrote:
Hello,
I think the problem is that Fas6 is a port of an etherswitch module in an ISR router.
Probably QoS features are not supported on Etherswitch ports.
According to the documentation:
QoS is supported on etherswitch modules with some caveats. One of those caveats is the class class-default isn't supported.
With that said, we can modify my previous recommendation as followed:
class-map DSCP-EF
match any
policy-map DSCP-EF
class DSCP-EF
set dscp ef
interface fastethernet 6
service-policy input DSCP-EF
Regards
Edison
11-27-2009 09:59 AM
Giuseppe has illustrated the requirements for QoS marking, thanks Giuseppe.
You can verify if that interface does run CEF with the 'show ip cef fastethernet 6' command.
You mentioned about applying the ingress policy on the BVI - you could do that but it won't target the information on per-switchport basis.
I'm not sure if you can match on interface with this hardware but it's worth a try.
class-map DSCP-EF
match input-interface fastethernet 6
policy-map DSCP-EF
class DSCP-EF
set dscp ef
interface BVI
service-policy input DSCP-EF
Regards
Edison
11-28-2009 02:34 AM
I have try it end no success with class test
Router#show policy-map interface bvI 1
BVI1
Service-policy input: policy_mark
Class-map: class_reznik (match-any)
168709 packets, 20827818 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group name access_reznik
168709 packets, 20827818 bytes
5 minute rate 0 bps
QoS Set
dscp ef
Packets marked 168709
Class-map: class_honza (match-any)
112818 packets, 9869099 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: access-group name access_honza
112818 packets, 9869099 bytes
5 minute rate 0 bps
QoS Set
dscp af12
Packets marked 112818
Class-map: test (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: input-interface FastEthernet6
QoS Set
dscp af21
Packets marked 0
Class-map: class-default (match-any)
146312 packets, 21565553 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
and on FE6 the traffic was
Router#show interfaces fastEthernet 6
FastEthernet6 is up, line protocol is up
Hardware is FastEthernet, address is 0021.5556.35d5 (bia 0021.5556.35d5)
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters 1d16h
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 1000 bits/sec, 1 packets/sec
5 minute output rate 2000 bits/sec, 3 packets/sec
19154 packets input, 1872292 bytes, 0 no buffer
Received 388 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
47318 packets output, 19757094 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
and post before not succes too
Router#show policy-map interface fastEthernet 6
FastEthernet6
Service-policy input: test_in
Class-map: test (match-all)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
QoS Set
dscp af21
Packets marked 0
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
As you see I use ip based marking that work for me now, but it is not solution to marking all interface traffic.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide