cancel
Showing results forĀ 
Search instead forĀ 
Did you mean:Ā 
cancel
901
Views
8
Helpful
8
Replies

MGRE / NHRP Issue with EIGRP - EIGRP Relationship Not Working

xmakina
Level 1
Level 1

Hi Everyone,

I badly need help.  

 am working on mGRE (static). I am able to get the tunnel up. However, I could not get LAN side networks on both sides to go through the tunnel as EIGRP does not seem to work. It is not forming any neighbor relationship. I have been dealing with this for few days already. Here is the code below:

PLEASE HELP

TOPOLOGY:

!//////////////////////////////////////////////
!/////////////////////// R1 ///////////////
!//////////////////////////////////////////////

R1#
R1#show run
Building configuration...

version 15.6

!
hostname R1
!
redundancy
!
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.0
!
interface Tunnel1
 ip address 192.168.1.1 255.255.255.0
 no ip redirects
 ip nhrp map 192.168.1.2 199.1.1.2
 ip nhrp map 192.168.1.3 75.1.1.3
 ip nhrp map 192.168.1.4 200.1.1.4
 ip nhrp network-id 1
 tunnel source GigabitEthernet0/0
 tunnel mode gre multipoint
!
interface GigabitEthernet0/0
 ip address 150.5.5.1 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
!
interface GigabitEthernet0/1
 ip address 172.16.1.1 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
!
ip route 0.0.0.0 0.0.0.0 150.5.5.5
!
!
end

R1#ā€ƒ

 

!/////////////////////////////////////////////////////
!/////////////////////// R2 (SPOKE)/////////////////// 
!/////////////////////////////////////////////////////
  
 R2# 
 R2#show run 
 Building configuration... 
 ! 
 hostname R2 
 ! 
 interface Loopback0 
 ip address 10.2.2.2 255.255.255.0 
 ! 
 interface Tunnel1 
 ip address 192.168.1.2 255.255.255.0 
 no ip redirects 
 ip nhrp map 192.168.1.1 150.5.5.1 
 ip nhrp map 192.168.1.3 75.1.1.3 
 ip nhrp map 192.168.1.4 200.1.1.4 
 ip nhrp network-id 1 
 tunnel source GigabitEthernet0/0 
 tunnel mode gre multipoint 
 
 ! 
 interface GigabitEthernet0/0 
 ip address 199.1.1.2 255.255.255.0 
 duplex auto 
 speed auto 
 media-type rj45 
 ! 
 
 interface GigabitEthernet0/1 
 ip address 172.16.2.2 255.255.255.0 
 duplex auto 
 speed auto 
 media-type rj45 
 
 ! 
 ! 
 router eigrp 100 
 network 10.0.0.0 
 network 192.168.1.0 
 ! 
 ip route 0.0.0.0 0.0.0.0 199.1.1.5 
 end 

Thank you.

x- makinaā€ƒ

 

2 Accepted Solutions

Accepted Solutions

Peter Paluch
Cisco Employee
Cisco Employee

Hello,

In addition to the other friends' responses here, at the first sight, you are missing the multicast NHRP mappings in your configurations. As you know, EIGRP is a combined multicast/unicast beast, and it needs both types of connectivity to work. Your mappings allow the unicast connectivity, but when EIGRP puts a multicast packet on the Tunnel interface, the router does not know whom to send a copy of that multicast packet.

If you are doing this configuration statically (which, however, defeats the purpose of the Dynamic Multipoint VPN), then the hub needs to have a multicast mapping for every spoke while a spoke needs the multicast mapping only and exclusively for the hub. So something like this:

!!! On the R1 as the hub, add:

interface Tunnel1
ip nhrp map multicast 199.1.1.2
ip nhrp map multicast 75.1.1.3
ip nhrp map multicast 200.1.1.4

!!! On the R2 as the spoke, add:

interface Tunnel1
ip nhrp map multicast 150.5.5.1

This should help EIGRP to come up.

Best regards,
Peter

 

View solution in original post

Your consider is correct' he not use phase1 nor phase2

dmvpn ( nhrp is dmvpn)

I run lab and test connect spoke  to spoke  and share with you result.

He can use

ip nhrp nhs

under spoke tunnel which already build static tunnel in hub and spoke and use

 ip nhrp map

multicast dynamic. But let me test.

I will update you when finish lab.

View solution in original post

8 Replies 8

Hello
Can you elaborate on what you are trying to achieve, you seem to be wanting to use DMVPN , is this correct or is it just to use a simple GRE tunnel to route eigrp traffic?

this is the case then you are missing a few command statements 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the communityā€™s global network.

Kind Regards
Paul

Hello Paul,

Thank you for your reply.

I want to be able to for an GRE tunnels to multiple sites by assigning STATIC mapping of tunnel interfaces with public IPs(NBMA).

I use

NHRP map

command. At this point, I am not yet in DMVPN. First I want to be able to be able to use EIGRP and have my 2x LAN networks from R1 

(the 10.1.1.0/24)

site and R2

(the 10.2.1.0/24)

site to communicate with each other (ping).

From what I understand, these 2x networks need to be able to use the mGRE tunnel for them to communicate. 

Once these two are able to communicate, then I will continue to configure R3 and R4 sites later on.

Isnt that possible ?  

 

Thank you so much.

 

Your consider is correct' he not use phase1 nor phase2

dmvpn ( nhrp is dmvpn)

I run lab and test connect spoke  to spoke  and share with you result.

He can use

ip nhrp nhs

under spoke tunnel which already build static tunnel in hub and spoke and use

 ip nhrp map

multicast dynamic. But let me test.

I will update you when finish lab.

I will run lab test

static nhrp map

Hi MHM,

Thank you so much.

Thank you

Peter Paluch
Cisco Employee
Cisco Employee

Hello,

In addition to the other friends' responses here, at the first sight, you are missing the multicast NHRP mappings in your configurations. As you know, EIGRP is a combined multicast/unicast beast, and it needs both types of connectivity to work. Your mappings allow the unicast connectivity, but when EIGRP puts a multicast packet on the Tunnel interface, the router does not know whom to send a copy of that multicast packet.

If you are doing this configuration statically (which, however, defeats the purpose of the Dynamic Multipoint VPN), then the hub needs to have a multicast mapping for every spoke while a spoke needs the multicast mapping only and exclusively for the hub. So something like this:

!!! On the R1 as the hub, add:

interface Tunnel1
ip nhrp map multicast 199.1.1.2
ip nhrp map multicast 75.1.1.3
ip nhrp map multicast 200.1.1.4

!!! On the R2 as the spoke, add:

interface Tunnel1
ip nhrp map multicast 150.5.5.1

This should help EIGRP to come up.

Best regards,
Peter

 

Hi Sir Peter,

THANK YOU SOO MUCH !!! You're solution fixed my issue which has been giving me headache for days.

I am actually learning CCNA, specifically on VPN now so I am following a lesson. The class lesson I am studying has shown me how to create the MGRE tunnel and the tunnel interface -to-NBMA maps but it didnt show how to route internal LAN traffic and I have been trying to find an answer. 

I got stuck in this lesson trying to find an answer and I refuse to move forward to the next lesson (about DMVPN) until I succeed doing this static version first, both on EVEng and on real gears.

I am guessing I will have to use the same in case I want OSPF in lieu of EIGRP. (I am a beginner in networking)

Thank you so much Sir Peter !!! Now I can sleep well

I am pretty sure others like me will find your answer here to be very helpful now and in the future.

Thank you so much Sir Peter !!! 

Regards,

x-makina

 

 

Hello x-makina,

You are heartily welcome < 3

Best regards,
Peter

 

Review Cisco Networking for a $25 gift card