01-22-2020 12:36 AM
I have attached topology screenshot for your clarification.
Here Switch 2 is normal Customer and it's connected to Provider edge. Customer router not showing many routes (Loop back interface routes) when compare to R6 PE router. Below the configs provided
---------------------------------------------------------------------------------------
R6#sh runn
!
hostname R6
vrf definition MPLS
rd 1:1
route-target export 1:1
route-target import 1:1
!
address-family ipv4
exit-address-family
!
!
no aaa new-model
!
ip cef
no ipv6 cef
!
!
mpls label range 600 699
multilink bundle-name authenticated
!
!
interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface Loopback1
vrf forwarding MPLS
ip address 66.66.66.66 255.255.255.255
!
interface FastEthernet0/0
ip address 10.4.6.6 255.255.255.0
ip ospf network point-to-point
speed auto
duplex auto
!
interface FastEthernet0/1
vrf forwarding MPLS
ip address 10.2.6.6 255.255.255.0
ip ospf network point-to-point
speed auto
duplex auto
!
!
router ospf 100 vrf MPLS
redistribute connected subnets
redistribute bgp 1 subnets
network 6.6.6.6 0.0.0.0 area 0
network 10.2.6.0 0.0.0.255 area 0
network 66.66.66.66 0.0.0.0 area 0
!
router ospf 1
redistribute connected subnets
redistribute bgp 1 subnets
network 6.6.6.6 0.0.0.0 area 0
network 10.4.6.0 0.0.0.255 area 0
mpls ldp autoconfig
!
router bgp 1
bgp router-id 6.6.6.6
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 1
neighbor 2.2.2.2 update-source Loopback0
!
address-family ipv4
neighbor 2.2.2.2 activate
exit-address-family
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community extended
exit-address-family
!
address-family ipv4 vrf MPLS
redistribute ospf 100 match internal external 1 external 2 nssa-external 1 nssa-external 2
exit-address-family
!
ip forward-protocol nd
!
!
mpls ldp router-id Loopback0
!
end
R6#
R6#sh ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
Gateway of last resort is not set
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/4] via 10.4.6.4, 01:04:54, FastEthernet0/0
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/4] via 10.4.6.4, 01:04:54, FastEthernet0/0
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/2] via 10.4.6.4, 01:05:04, FastEthernet0/0
5.0.0.0/32 is subnetted, 1 subnets
O 5.5.5.5 [110/4] via 10.4.6.4, 01:04:54, FastEthernet0/0
7.0.0.0/32 is subnetted, 1 subnets
O E2 7.7.7.7 [110/20] via 10.4.6.4, 01:04:54, FastEthernet0/0
8.0.0.0/32 is subnetted, 1 subnets
O 8.8.8.8 [110/3] via 10.4.6.4, 01:04:54, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O E2 10.2.4.0/24 [110/20] via 10.4.6.4, 01:04:54, FastEthernet0/0
O 10.2.8.0/24 [110/3] via 10.4.6.4, 01:04:54, FastEthernet0/0
O 10.3.5.0/24 [110/4] via 10.4.6.4, 01:04:33, FastEthernet0/0
O 10.3.8.0/24 [110/3] via 10.4.6.4, 01:04:54, FastEthernet0/0
O 10.4.8.0/24 [110/2] via 10.4.6.4, 01:05:04, FastEthernet0/0
O 10.5.7.0/24 [110/4] via 10.4.6.4, 01:04:54, FastEthernet0/0
O 10.5.8.0/24 [110/3] via 10.4.6.4, 01:04:54, FastEthernet0/0
R6#
R6#
R6#
R6#sh ip route vrf MPLS
Routing Table: MPLS
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
B 1.1.1.1 [200/2] via 2.2.2.2, 01:04:01
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
B 10.1.1.0/24 [200/2] via 2.2.2.2, 01:04:01
B 10.1.2.0/24 [200/0] via 2.2.2.2, 01:04:01
B 10.1.3.0/24 [200/2] via 2.2.2.2, 01:04:01
C 10.2.6.0/24 is directly connected, FastEthernet0/1
L 10.2.6.6/32 is directly connected, FastEthernet0/1
B 10.2.7.0/24 [200/3] via 2.2.2.2, 00:09:37
11.0.0.0/32 is subnetted, 1 subnets
B 11.11.11.11 [200/3] via 2.2.2.2, 01:04:01
22.0.0.0/32 is subnetted, 1 subnets
O 22.22.22.22 [110/2] via 10.2.6.2, 00:24:00, FastEthernet0/1
66.0.0.0/32 is subnetted, 1 subnets
C 66.66.66.66 is directly connected, Loopback1
R6#
R6#sh bgp vpnv4 uni all
BGP table version is 22, local router ID is 6.6.6.6
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 1:1 (default for vrf MPLS)
*>i 1.1.1.1/32 2.2.2.2 2 100 0 ?
*>i 10.1.1.0/24 2.2.2.2 2 100 0 ?
*>i 10.1.2.0/24 2.2.2.2 0 100 0 ?
*>i 10.1.3.0/24 2.2.2.2 2 100 0 ?
*> 10.2.6.0/24 0.0.0.0 0 32768 ?
*>i 10.2.7.0/24 2.2.2.2 3 100 0 ?
*>i 11.11.11.11/32 2.2.2.2 3 100 0 ?
*> 22.22.22.22/32 10.2.6.2 2 32768 ?
*> 66.66.66.66/32 0.0.0.0 0 32768 ?
R6#sh bgp vpnv4 uni all sum
BGP router identifier 6.6.6.6, local AS number 1
BGP table version is 22, main routing table version 22
9 network entries using 1404 bytes of memory
9 path entries using 720 bytes of memory
5/5 BGP path/bestpath attribute entries using 720 bytes of memory
2 BGP extended community entries using 80 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 2924 total bytes of memory
BGP activity 9/0 prefixes, 15/6 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2.2.2.2 4 1 83 78 22 0 0 01:05:12 6
R6#
---------------------------------------------------------------------------------------------------------
SW-2#sh run | sec router ospf
router ospf 1
router-id 22.22.22.22
redistribute connected subnets
network 10.2.6.0 0.0.0.255 area 0
network 10.2.7.0 0.0.0.255 area 0
network 22.22.22.22 0.0.0.0 area 0
SW-2#
SW-2#
SW-2#sh run
Building configuration...
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
!
interface Loopback0
ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0
ip address 10.2.6.2 255.255.255.0
ip ospf network point-to-point
speed auto
duplex auto
!
interface FastEthernet0/1
ip address 10.2.7.2 255.255.255.0
ip ospf network point-to-point
shutdown
speed auto
duplex auto
!
!
router ospf 1
router-id 22.22.22.22
redistribute connected subnets
network 10.2.6.0 0.0.0.255 area 0
network 10.2.7.0 0.0.0.255 area 0
network 22.22.22.22 0.0.0.0 area 0
!
ip forward-protocol nd
login
!
!
end
SW-2#
SW-2#sh ip route os
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/3] via 10.2.6.6, 00:26:07, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
O IA 10.1.1.0/24 [110/3] via 10.2.6.6, 00:26:07, FastEthernet0/0
O IA 10.1.2.0/24 [110/2] via 10.2.6.6, 00:26:07, FastEthernet0/0
O IA 10.1.3.0/24 [110/3] via 10.2.6.6, 00:26:07, FastEthernet0/0
O IA 10.2.7.0/24 [110/4] via 10.2.6.6, 00:11:44, FastEthernet0/0
11.0.0.0/32 is subnetted, 1 subnets
O IA 11.11.11.11 [110/4] via 10.2.6.6, 00:26:07, FastEthernet0/0
66.0.0.0/32 is subnetted, 1 subnets
O 66.66.66.66 [110/2] via 10.2.6.6, 00:26:07, FastEthernet0/0
SW-2#
SW-2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O IA 1.1.1.1 [110/3] via 10.2.6.6, 00:26:10, FastEthernet0/0
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
O IA 10.1.1.0/24 [110/3] via 10.2.6.6, 00:26:10, FastEthernet0/0
O IA 10.1.2.0/24 [110/2] via 10.2.6.6, 00:26:10, FastEthernet0/0
O IA 10.1.3.0/24 [110/3] via 10.2.6.6, 00:26:10, FastEthernet0/0
C 10.2.6.0/24 is directly connected, FastEthernet0/0
L 10.2.6.2/32 is directly connected, FastEthernet0/0
O IA 10.2.7.0/24 [110/4] via 10.2.6.6, 00:11:47, FastEthernet0/0
11.0.0.0/32 is subnetted, 1 subnets
O IA 11.11.11.11 [110/4] via 10.2.6.6, 00:26:10, FastEthernet0/0
22.0.0.0/32 is subnetted, 1 subnets
C 22.22.22.22 is directly connected, Loopback0
66.0.0.0/32 is subnetted, 1 subnets
O 66.66.66.66 [110/2] via 10.2.6.6, 00:26:10, FastEthernet0/0
SW-2#
Solved! Go to Solution.
01-22-2020 10:54 PM
Hi,
What you are seeing is expected and correct behavior. I have segregated the topology for your easy reference. Refer to the attached file for details
The routes highlighted by you in bold belong to the service provider infrastructure. They are correctly visible in the PE R6 router in the local IGP routes ( show ip routes) while the routes that belong to the customer would belong to the VRF table ( show ip route vrf MPLS)
A customer is not supposed to learn or know the routes of the Service provider domain. Hence what we are seeing is correct.
Only the routes that belong to the customer domain ( SW2 and beyond) and that are learnt via iBGP by the R6 PE router would be advertised to the SW1. Similarly all the routes that are belong to the customer domain ( SW1 and beyond) and that are learnt via iBGP by the R1 PE would be advertised to the SW2.
A quick way to confirm this is to check the routes in the BGP table for VRF and the routing table of the CE. They should match. Refer to the file name routes for the comparison
Hope this helps
Regards.
01-22-2020 01:53 AM
Hello,
at first glance, it looks like the problem is that you are not advertising the link between R6 and SW2 in the non-MPLS OSPF instance on R6.
On R6, try and add the line marked in bold:
R6
router ospf 1
redistribute connected subnets
redistribute bgp 1 subnets
network 6.6.6.6 0.0.0.0 area 0
network 10.2.6.0 0.0.0.255 area 0
network 10.4.6.0 0.0.0.255 area 0
mpls ldp autoconfig
01-22-2020 02:20 AM
it's already configured in ispf 100
router ospf 100 vrf MPLS
redistribute connected subnets
redistribute bgp 1 subnets
network 6.6.6.6 0.0.0.0 area 0
network 10.2.6.0 0.0.0.255 area 0
network 66.66.66.66 0.0.0.0 area 0
01-22-2020 07:08 AM
Hello,
I have recreated your setup in GNS3, and no matter what sort of VRF to global route leaking I tried to configure, nothing seems to work. The problem is, I think, that one of the connecting interfaces is in the VRF, while the corresponding connecting interface on SW2 is not. It would probably work if both connecting interfaces are in the global OSPF process, and one of the other interfaces (e.g. the interface connecting R6 to the other router) would be in the VRF. That would allow route leaking to work.
Maybe I am off here, and if you have found a solution in the meantime, I would of course be glad to hear about it...
01-22-2020 10:54 PM
Hi,
What you are seeing is expected and correct behavior. I have segregated the topology for your easy reference. Refer to the attached file for details
The routes highlighted by you in bold belong to the service provider infrastructure. They are correctly visible in the PE R6 router in the local IGP routes ( show ip routes) while the routes that belong to the customer would belong to the VRF table ( show ip route vrf MPLS)
A customer is not supposed to learn or know the routes of the Service provider domain. Hence what we are seeing is correct.
Only the routes that belong to the customer domain ( SW2 and beyond) and that are learnt via iBGP by the R6 PE router would be advertised to the SW1. Similarly all the routes that are belong to the customer domain ( SW1 and beyond) and that are learnt via iBGP by the R1 PE would be advertised to the SW2.
A quick way to confirm this is to check the routes in the BGP table for VRF and the routing table of the CE. They should match. Refer to the file name routes for the comparison
Hope this helps
Regards.
01-22-2020 10:55 PM
01-28-2020 05:43 AM
Thanks for the great clarification.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide