12-01-2020 12:47 AM
Hi Everyone,
I have a problem with Sparse-mode multicast configuration in Nexus 9000.
I have 2 VLANs (Vlan 2 and 3) and we want to send multicast traffic between VLANs. I have implemented multicast routing (Feature Pim). Stream Server is in VLAN 2 and Receiver is in VLAN3.
I configured Static-RP once but it didn't work and after that I tried Auto-RP but it didn't work either. Could you please check our configuration and let us know if it's the correct configuration?
Just for info, the multicast inside the VLAN can work without any problem.
Here is my configuration for Static RP and Auto-RP, Can anyone tell me What is the problems?
Static RP Confiugration:
feature pim
ip pim rp-address 10.2.2.2 group-list 239.0.0.0/8
ip pim ssm range none
interface vlan 2
ip pim sparse-mode
ip igmp version 3
!
interface vlan 3
ip pim sparse-mode
ip igmp version 3
Auto-RP Configuration:
feature pim
ip pim auto-rp rp-candidate Vlan2 group-list 239.0.0.0/8
ip pim auto-rp mapping-agent Vlan2
ip pim ssm range none
ip pim auto-rp forward listen
interface vlan 2
ip pim sparse-mode
ip igmp version 3
!
interface vlan 3
ip pim sparse-mode
ip igmp version 3
Many Thanks,
Ali
12-01-2020 01:42 AM
Couple of question, is the interface vlan 3 and vlan2 has IP configuration not seen any IP configured, can you post show interface vlan2 and 3 to undertand
config looks ok for me to start with.,
Please also post below information
show run interface vlan 2
show run interface vlan 3
show ip pim interface
show ip pim group-range
12-01-2020 02:25 AM
THe Stream Server is in VLAN 2 with IP 192.168.2.100 and gatway 192.168.2.1 and Stream receiver is in VLAN 3 with ip 192.168.3.100 and gateway 192.168.3.1
interface vlan 2
no shutdown
ip address 192.168.2.1/24
ip pim sparse-mode
ip igmp version 3
!
interface vlan 3
no shutdown
ip address 192.168.3.1/24
ip pim sparse-mode
ip igmp version 3
!
interface loopback 0
ip address 10.2.2.2 255.255.255.255
ip pim sparse-mode
NXOS# show ip pim interface
PIM Interface Status for VRF "default"
Vlan2, Interface status: protocol-up/link-up/admin-up
IP address: 192.168.2.1, IP subnet: 192.168.2.0/24
PIM DR: 192.168.2.1, DR's priority: 1
PIM neighbor count: 0
PIM hello interval: 30 secs, next hello sent in: 00:00:15
PIM neighbor holdtime: 105 secs
PIM configured DR priority: 15
PIM configured DR delay: 3 secs
PIM border interface: no
PIM GenID sent in Hellos: 0x160a8c3f
PIM Hello MD5-AH Authentication: disabled
PIM Neighbor policy: none configured
PIM Join-Prune inbound policy: none configured
PIM Join-Prune outbound policy: none configured
PIM Join-Prune interval: 1 minutes
PIM Join-Prune next sending: 1 minutes
PIM BFD enabled: no
PIM passive interface: no
PIM VPC SVI: no
PIM Auto Enabled: no
PIM Interface Statistics, last reset: never
General (sent/received):
Hellos: 261/0 (early: 0), JPs: 8/0, Asserts: 0/0
Grafts: 0/0, Graft-Acks: 0/0
DF-Offers: 0/0, DF-Winners: 0/0, DF-Backoffs: 0/0, DF-Passes: 0/0
Errors:
Checksum errors: 0, Invalid packet types/DF subtypes: 0/0
Authentication failed: 0
Packet length errors: 0, Bad version packets: 0, Packets from self: 0
Packets from non-neighbors: 0
Packets received on passiveinterface: 0
JPs received on RPF-interface: 0
(*,G) Joins received with no/wrong RP: 0/0
(*,G)/(S,G) JPs received for SSM/Bidir groups: 0/0
JPs filtered by inbound policy: 0
JPs filtered by outbound policy: 0
Vlan3, Interface status: protocol-up/link-up/admin-up
IP address: 192.168.3.1, IP subnet: 192.168.3.0/24
PIM DR: 192.168.3.1, DR's priority: 1
PIM neighbor count: 0
PIM hello interval: 30 secs, next hello sent in: 00:00:04
PIM neighbor holdtime: 105 secs
PIM configured DR priority: 1
PIM configured DR delay: 3 secs
PIM border interface: no
PIM GenID sent in Hellos: 0x03e08d26
PIM Hello MD5-AH Authentication: disabled
PIM Neighbor policy: none configured
PIM Join-Prune inbound policy: none configured
PIM Join-Prune outbound policy: none configured
PIM Join-Prune interval: 1 minutes
PIM Join-Prune next sending: 1 minutes
PIM BFD enabled: no
PIM passive interface: no
PIM VPC SVI: no
PIM Auto Enabled: no
PIM Interface Statistics, last reset: never
General (sent/received):
Hellos: 261/0 (early: 0), JPs: 0/0, Asserts: 0/0
Grafts: 0/0, Graft-Acks: 0/0
DF-Offers: 0/0, DF-Winners: 0/0, DF-Backoffs: 0/0, DF-Passes: 0/0
Errors:
Checksum errors: 0, Invalid packet types/DF subtypes: 0/0
Authentication failed: 0
Packet length errors: 0, Bad version packets: 0, Packets from self: 0
Packets from non-neighbors: 0
Packets received on passiveinterface: 0
JPs received on RPF-interface: 0
NXOS# show ip pim group-list
PIM Group-Range Configuration for VRF "default"
Group-range Action Mode RP-address Shared-tree-only range
239.0.0.0/8 - ASM 10.2.2.2 -
12-01-2020 03:11 AM
Hello @Ali.Allafzadeh1 ,
you need igmp version 2 on SVI interfaces
igmp version 3 is for SSM and you have configured
>>>ip pim ssm range none
For the RP you can use a loopback interface
Hope to help
Giuseppe
12-01-2020 03:14 AM
I have tested also with igmp version 2 but unfortunately it does not work
12-01-2020 03:15 AM
also I have tested with vlan IP for RP and also loopback IP for RP but it does not work!
12-01-2020 05:03 AM
Can you post the config and output after changing to IGMP v2
12-01-2020 05:33 AM
*********Config***************
cli alias name wr copy runn start
feature interface-vlan
vlan 2
exi
vlan 3
exi
interface vlan 2
ip address 192.168.2.1/24
no shut
exi
interface vlan 3
ip address 192.168.3.1/24
no shut
exit
interface loopback 0
ip address 10.2.2.2 255.255.255.255
no shutdown
interface ethernet 1/1-2
switchport access vlan 2
exit
interface ethernet 1/3
switchport access vlan 3
feature pim
interface vlan 2
ip pim sparse-mode
ip igmp version 2
exit
interface vlan 3
ip pim sparse-mode
ip igmp version 2
exi
interface loopback 0
ip pim sparse-mode
exit
ip pim rp-address 10.2.2.2 group-list 239.0.0.0/8
ip pim ssm range none
************Verification*******************
NXOS# show ip pim interface
PIM Interface Status for VRF "default"
Vlan2, Interface status: protocol-up/link-up/admin-up
IP address: 192.168.2.1, IP subnet: 192.168.2.0/24
PIM DR: 192.168.2.1, DR's priority: 1
PIM neighbor count: 0
PIM hello interval: 30 secs, next hello sent in: 00:00:25
PIM neighbor holdtime: 105 secs
PIM configured DR priority: 1
PIM configured DR delay: 3 secs
PIM border interface: no
PIM GenID sent in Hellos: 0x0a2453f0
PIM Hello MD5-AH Authentication: disabled
PIM Neighbor policy: none configured
PIM Join-Prune inbound policy: none configured
PIM Join-Prune outbound policy: none configured
PIM Join-Prune interval: 1 minutes
PIM Join-Prune next sending: 1 minutes
PIM BFD enabled: no
PIM passive interface: no
PIM VPC SVI: no
PIM Auto Enabled: no
PIM Interface Statistics, last reset: never
General (sent/received):
Hellos: 4/0 (early: 0), JPs: 0/0, Asserts: 0/0
Grafts: 0/0, Graft-Acks: 0/0
DF-Offers: 0/0, DF-Winners: 0/0, DF-Backoffs: 0/0, DF-Passes: 0/0
Errors:
Checksum errors: 0, Invalid packet types/DF subtypes: 0/0
Authentication failed: 0
Packet length errors: 0, Bad version packets: 0, Packets from self: 0
Packets from non-neighbors: 0
Packets received on passiveinterface: 0
JPs received on RPF-interface: 0
(*,G) Joins received with no/wrong RP: 0/0
(*,G)/(S,G) JPs received for SSM/Bidir groups: 0/0
JPs filtered by inbound policy: 0
JPs filtered by outbound policy: 0
Vlan3, Interface status: protocol-up/link-up/admin-up
IP address: 192.168.3.1, IP subnet: 192.168.3.0/24
PIM DR: 192.168.3.1, DR's priority: 1
PIM neighbor count: 0
PIM hello interval: 30 secs, next hello sent in: 00:00:25
PIM neighbor holdtime: 105 secs
PIM configured DR priority: 1
PIM configured DR delay: 3 secs
PIM border interface: no
PIM GenID sent in Hellos: 0x1ebcb74a
PIM Hello MD5-AH Authentication: disabled
PIM Neighbor policy: none configured
PIM Join-Prune inbound policy: none configured
PIM Join-Prune outbound policy: none configured
PIM Join-Prune interval: 1 minutes
PIM Join-Prune next sending: 1 minutes
PIM BFD enabled: no
PIM passive interface: no
PIM VPC SVI: no
PIM Auto Enabled: no
PIM Interface Statistics, last reset: never
General (sent/received):
Hellos: 4/0 (early: 0), JPs: 0/0, Asserts: 0/0
Grafts: 0/0, Graft-Acks: 0/0
DF-Offers: 0/0, DF-Winners: 0/0, DF-Backoffs: 0/0, DF-Passes: 0/0
Errors:
Checksum errors: 0, Invalid packet types/DF subtypes: 0/0
Authentication failed: 0
Packet length errors: 0, Bad version packets: 0, Packets from self: 0
Packets from non-neighbors: 0
Packets received on passiveinterface: 0
JPs received on RPF-interface: 0
(*,G) Joins received with no/wrong RP: 0/0
(*,G)/(S,G) JPs received for SSM/Bidir groups: 0/0
JPs filtered by inbound policy: 0
JPs filtered by outbound policy: 0
loopback0, Interface status: protocol-up/link-up/admin-up
IP address: 10.2.2.2, IP subnet: 10.2.2.2/32
PIM DR: 10.2.2.2, DR's priority: 1
PIM neighbor count: 0
PIM hello interval: 30 secs, next hello sent in: 00:00:24
PIM neighbor holdtime: 105 secs
PIM configured DR priority: 1
PIM configured DR delay: 3 secs
PIM border interface: no
PIM GenID sent in Hellos: 0x29aabaf3
PIM Hello MD5-AH Authentication: disabled
PIM Neighbor policy: none configured
PIM Join-Prune inbound policy: none configured
PIM Join-Prune outbound policy: none configured
PIM Join-Prune interval: 1 minutes
PIM Join-Prune next sending: 1 minutes
PIM BFD enabled: no
PIM passive interface: no
PIM VPC SVI: no
PIM Auto Enabled: no
PIM Interface Statistics, last reset: never
General (sent/received):
Hellos: 4/0 (early: 0), JPs: 0/0, Asserts: 0/0
Grafts: 0/0, Graft-Acks: 0/0
DF-Offers: 0/0, DF-Winners: 0/0, DF-Backoffs: 0/0, DF-Passes: 0/0
Errors:
Checksum errors: 0, Invalid packet types/DF subtypes: 0/0
Authentication failed: 0
Packet length errors: 0, Bad version packets: 0, Packets from self: 0
Packets from non-neighbors: 0
Packets received on passiveinterface: 0
JPs received on RPF-interface: 0
(*,G) Joins received with no/wrong RP: 0/0
(*,G)/(S,G) JPs received for SSM/Bidir groups: 0/0
JPs filtered by inbound policy: 0
JPs filtered by outbound policy: 0
NXOS# show ip pim group-range
PIM Group-Range Configuration for VRF "default"
Group-range Action Mode RP-address Shared-tree-only range
239.0.0.0/8 - ASM 10.2.2.2 -
01-22-2021 03:44 PM
What's the fix? Did anybody figure this out?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide