cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
252
Views
10
Helpful
5
Replies
Highlighted
Beginner

Multicast routing - did something changed ?

Hi All,

 

i used to configure multirouting with no problem. Here i have to do it one more time and nothing works, i do not know why.

Then i fall back to a very simple config : multicast routing between 2 routed interfaces on the same router -> same problem, nothing OK

 

My test :

a C921 configured on gig4 (192.168.4.254) and gig5 (192.168.5.254)

One pc on 192.168.4.1 and another on 192.168.5.1

No firewall

w10

iperf/vlc/self made program to test multicast

 

debug ip igmp we can see some info like :

 

*Jan 24 15:58:00.931: IGMP(0): Received v2 Report on GigabitEthernet4 from 192.168.4.1 for 228.1.1.1
*Jan 24 15:58:00.931: IGMP(0): Received Group record for group 228.1.1.1, mode 2 from 192.168.4.1 for 0 sources
*Jan 24 15:58:00.931: IGMP(0): WAVL Insert group: 228.1.1.1 interface: GigabitEthernet4Successful
*Jan 24 15:58:00.931: IGMP(0): Switching to EXCLUDE mode for 228.1.1.1 on GigabitEthernet4
*Jan 24 15:58:00.931: IGMP(0): Updating EXCLUDE group timer for 228.1.1.1
*Jan 24 15:58:00.931: IGMP(0): MRT Add/Update GigabitEthernet4 for (*,228.1.1.1) by 0
*Jan 24 15:58:01.113: IGMP(0): Received v2 Report on GigabitEthernet4 from 192.168.4.1 for 228.1.1.1
*Jan 24 15:58:01.113: IGMP(0): Received Group record for group 228.1.1.1, mode 2 from 192.168.4.1 for 0 sources
*Jan 24 15:58:01.113: IGMP(0): Updating EXCLUDE group timer for 228.1.1.1
*Jan 24 15:58:01.113: IGMP(0): MRT Add/Update GigabitEthernet4 for (*,228.1.1.1) by 0
*Jan 24 15:58:11.497: IGMP(0): Received Leave from 192.168.4.1 (GigabitEthernet4) for 228.1.1.1
*Jan 24 15:58:11.497: IGMP(0): Received Group record for group 228.1.1.1, mode 3 from 192.168.4.1 for 0 sources
*Jan 24 15:58:11.497: IGMP(0): Lower expiration timer to 2000 msec for 228.1.1.1 on GigabitEthernet4
*Jan 24 15:58:11.497: IGMP(0): Send v2 Query on GigabitEthernet4 for group 228.1.1.1
*Jan 24 15:58:12.583: IGMP(0): Send v2 Query on GigabitEthernet4 for group 228.1.1.1
*Jan 24 15:58:13.583: IGMP(0): Switching to INCLUDE mode for 228.1.1.1 on GigabitEthernet4
*Jan 24 15:58:13.583: IGMP(0): MRT delete GigabitEthernet4 for (*,228.1.1.1) by 0

Nothing on debug ip mpacket

 

version is flash:c900-universalk9-mz.SPA.158-3.M2.bin

 

 

Bellow is the conf :

 

 

ip multicast-routing
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
redundancy
!
!
!
!
!
!
interface Loopback0
 ip address 10.254.1.1 255.255.0.0
 ip pim sparse-dense-mode
!
interface GigabitEthernet0
 no ip address
!
interface GigabitEthernet1
 no ip address
!
interface GigabitEthernet2
 no ip address
!
interface GigabitEthernet3
 no ip address
!
interface GigabitEthernet4
 ip address 192.168.4.254 255.255.255.0
 ip pim sparse-dense-mode
 duplex auto
 speed auto
!
interface GigabitEthernet5
 ip address 192.168.5.254 255.255.255.0
 ip pim sparse-dense-mode
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip pim rp-address 10.254.1.1
!

Any help, debug or so will be really appreciated, i do not know what change into multicast config !

 

Thanks

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Collaborator

Re: Multicast routing - did something changed ?

Hi,

How are you sending the multicast? Is the server vlc and the client vlc? Have you checked ttl values of the stream? Have you checked it is not a client/server issue? Install wireshark on the server and client. Check that the server is actually sending and what values it is using.Check that the client is actually trying to join the correct group.

On the router what is the output of the following commands:

show ip mroute

show ip mroute active

show ip igmp groups

show ip igmp snooping

show ip igmp snooping groups

 

Thanks

John

**Please rate posts you find helpful**

View solution in original post

5 REPLIES 5
Highlighted
Collaborator

Re: Multicast routing - did something changed ?

Hi,

How are you sending the multicast? Is the server vlc and the client vlc? Have you checked ttl values of the stream? Have you checked it is not a client/server issue? Install wireshark on the server and client. Check that the server is actually sending and what values it is using.Check that the client is actually trying to join the correct group.

On the router what is the output of the following commands:

show ip mroute

show ip mroute active

show ip igmp groups

show ip igmp snooping

show ip igmp snooping groups

 

Thanks

John

**Please rate posts you find helpful**

View solution in original post

Highlighted
Beginner

Re: Multicast routing - did something changed ?

Hi John, and thanks for your interest

 

Here is replies to your post :

 - we use vlc, iperf and a program we have done that is actually working on the config we want to replace (and that i configure myself some yers ago, i did some multicats routing config some times ago with no problem )

 - yes we tried with vlc server and client

 - ttl from our program is set to 8 (i do not know for vlc and iperf, i'll check with wireshark)

 - we tried the same test when both PC were connected directly with a network cable : all is ok.

 - with wireshark we can see multicats beeing generated, but nothing on the other side

 

Below are the content of the commands you asked

We did the test on IP 228.0.0.1, results seems to be weird

 

Iperf commands :

 

iperf -c 228.0.0.1 -u -t 3 -T 10
iperf -s -B 228.0.0.1 -u -t 3

 

 

sh ip mroute

(*, 228.0.0.1), 00:04:16/stopped, RP 10.254.1.1, flags: SPF
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list: Null

sh ip mroute active

Active IP Multicast Sources - sending >= 4 kbps


show ip igmp groups
IIGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter Group Accounted
239.255.255.250 Vlan1 00:26:22 00:02:26 192.168.1.1
239.255.255.250 Vlan2 00:28:41 00:02:34 192.168.2.1
228.0.0.1 Vlan2 00:04:19 00:02:30 192.168.2.1
224.0.1.40 Loopback0 00:29:30 00:02:56 10.254.1.1

 

sh ip igmp snoop
Global IGMP Snooping configuration:
-----------------------------------
IGMP snooping : Enabled
IGMPv3 snooping support : Basic
Report suppression : Enabled
Last Member Query Interval : 1000

Vlan 1:
--------
IGMP snooping : Enabled
IGMPv2 immediate leave : Disabled
Multicast router learning mode : pim-dvmrp
Last Member Query Interval : 1000
CGMP interoperability mode : IGMP_ONLY
Vlan 99:
--------
IGMP snooping : Enabled
IGMPv2 immediate leave : Disabled
Multicast router learning mode : pim-dvmrp
Last Member Query Interval : 1000
CGMP interoperability mode : IGMP_ONLY


sh ip igmp snoop group
Vlan Group Version Port List
---------------------------------------------------------

1 239.255.255.250v2 Fa1
2 228.0.0.1 v2 Fa2
2 239.255.255.250v2 Fa2

 

Really we do not know what happens

Many thanks for your help

 

 

edit : in fact we saw that even with "T 10" options in iperf, ttl seems to remain to 1 (seen on wireshark...)

 

Do you have a good testing program ? We are searching, only find iperf and vlc and nothing else (on windows)

 

 

 

 

Highlighted
Beginner

Re: Multicast routing - did something changed ?

Hi,

 

it seems now better that i have a real good program to test multicast :)

so old, but so simple !

https://community.arubanetworks.com/t5/Wired-Intelligent-Edge-Campus/Multicast-Testing-Tool/td-p/448210

http://www.dqnetworks.ie/toolsinfo/mcasttest/

 

I'll now do my full tests and tell you

Highlighted
Beginner

Re: Multicast routing - did something changed ?

The issue is the TTL from VLC (default is 1) so change the value in the app.

VLC-Preferences—>Stream output—> access output—> hop limit 

Highlighted
Beginner

Re: Multicast routing - did something changed ?

Thanks to both of you for your help.

with the program i found all is ok now (and more simple than vlc or iperf :))
Now i hav problem with hsrp and multicast :(
Found many docs but do not understand all... i will open a new thread for that
Once again, many thanks !

CreatePlease to create content