ā04-15-2013 12:27 PM - edited ā03-04-2019 07:36 PM
hi,
we recently acquire a cisco 2921/K9 router to interface 2 networks
Network 1 : 169.254.XXX.XXX/16 on GigabitEthernet0/0 interface
Network 2 : 192.168.1.XXX/24 on GigabitEthernet0/1 interface
on the network 1 side there is a multicast source (169.254.200.200 destination : 225.0.0.1)
on the network 2 side there is 1 receiver which is not multicast capable(old) but i want it to receive the multicast stream
for the moment we configure the ip multicast-routing and each interface each interface with ip pim sparse-dense-mode then configure the
GigabitEthernet0/1 in order to join the multicast group (using ip igmp static-group 225.0.0.1) and wireshark confirm that the multicast stream on the network 2 side from 169.254.200.200 -> 225.0.0.1
of course the receiver don't the stream, but if i force a "multicast to unicast" process inside the router it shall be ok....
after many hour of internet browsing i found 2 solution :
- NAT, http://netsyshax.wordpress.com/2010/08/23/multicast-to-unicast-and-vice-versa/
- multicast service reflection (Cisco documentation)
the NAT example don't work ,what is the best way to do this task (example if possible
best reagards
Solved! Go to Solution.
ā04-16-2013 05:59 AM
Hi Yoann,
You are almost there.
You need to add the following command on the VIF interface. This is required to attract the multicast stream towards the Vif Interface.
Interface Vif 1
ip igmp static-group
You also need to change the interface on the "ip service reflect" command to specify the input interface.
Interface Vif 1
ip service reflect GigabitEthernet 0/0 destination 225.0.0.0 to 192.168.1.0 mask-len 24 source 10.1.1.2
Hope this helps
ā04-15-2013 03:14 PM
Hi Yoann,
It is quite possible to convert a multicast stream to unicast using the Multicast Service Reflection as described in the following document:
http://www.cisco.com/en/US/docs/ios/ipmulti/configuration/guide/imc_serv_reflect.html#wp1056104
Hope this helps
ā04-16-2013 01:27 AM
hi,
according the Multicast service reflection example (multicast to unicast) i adapt (parmater in bold) to my architecture and the multicast destination address (see attached drawing) and i will try the following configuration next Friday,
best regards
configure terminal
ip multicast-routing
interface GigabitEthernet0/0
ip address 169.254.200.1 255.255.0.0
ip pim sparse-mode
no shutdown
interface GigabitEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip pim sparse-mode
no shutdown
!
! Configure the loopback interface for the Service Provider RP
!
interface loopback 0
ip address 192.168.2.1 255.255.255.255
ip pim sparse-mode
!
ip pim rp-address 192.168.2.1 mylist override
ip access-list standard mylist permit 225.0.0.4 0.0.0.255
!
! Configure the Vif1 virtual interface for multicast service reflection
!
interface Vif1
ip address 10.1.1.1 255.255.255.0
ip pim sparse-mode
ip service reflect Ethernet 0/0 destination 225.0.0.0 to 192.168.1.0 mask-len 24 source 10.1.1.2
end
ā04-16-2013 05:59 AM
Hi Yoann,
You are almost there.
You need to add the following command on the VIF interface. This is required to attract the multicast stream towards the Vif Interface.
Interface Vif 1
ip igmp static-group
You also need to change the interface on the "ip service reflect" command to specify the input interface.
Interface Vif 1
ip service reflect GigabitEthernet 0/0 destination 225.0.0.0 to 192.168.1.0 mask-len 24 source 10.1.1.2
Hope this helps
ā04-16-2013 10:09 AM
Thanks a lot !
i'll try this next friday and share my tests results for information
best regards
ā04-24-2013 01:22 PM
Ok , it's works !!!
i've only add an command "no shutdown" in vif1 interface (down by default)
tanks a lot !
ā06-18-2013 07:44 AM
Hi Fellas
Can I implement this setup on gns3 dynamips, and how can I test that MRS is working.
ā06-19-2013 01:03 AM
Hi Fella
Please can you let me know if we can test this configuration in gns3...and How did you test it in the real environment. I suppose vlc player?
ā04-15-2013 10:31 PM
I'm not sure of your exact limitations with you router being capable of multicast, but if it is the result of a nbma topology, you may want to look into pim nbma mode, it requires sparse mode on the connection between the routers.
Sent from Cisco Technical Support iPad App
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide