Showing results for 
Search instead for 
Did you mean: 

Multicasting Trouble

Quick little issue here. I'm pretty new to multicasting, through various forums and Cisco research I have been able to develop a multicast testing lab consisting of 3x Linux laptops and 2x 2921 routers. I have attached my topology and config files for clarity. I am able to see my multicast messages from Router1 to Receiver1 but I cannot get my messages across to Receiver2. I have also attached some troubleshooting command outputs from both Router1 and Router2 to see if you guys can spot anything that doesn't seem right. I've exhausted myself trying to figure out why this won't work. Any help is appreciated. 

6 Replies 6

Cristian Matei



    Generate traffic from the source and post the output of the following commands from both routers: " show ip igmp membership" , "show ip mroute", "show ip mfib count" and "debug ip mfib pak".



Cristian Matei.

Okay, so I ran the python script for sending UDP multicast, and ran the commands while it was doing it's thing. I have attached the following outputs from both routers. Interesting results from the "debug" command on Router2, I saw no traffic. Do I have to set up a GRE Tunnel in order to get packets across in a multicast environment? I can ping my whole network, including my multicast address on both routers.



    Does the cast receiver send IGMPv3 join messages? Do the attached changes and post again the same outputs as you're generating multicast traffic.



Cristian Matei.

Cristian,   I only see IGMPv3 join messages from the 12 network. I have made the changes and the results are attached. A few results, expected of course. One thing I can say is for some reason on any troubleshooting command I run, I never see the 13.0 network. It is as if for some reason it will not join the multicast group, even with it configured correctly. All TTL's are not a factor after a bit of research. Source TTL is 32 and the routers are automatic on all interfaces with a multicast ttl threshold of 0. While I made the changes, the traffic for kept being received on R1, wouldn't you think that if you got rid of the "join-groups" that the messages would stop?

paul driver
VIP Expert VIP Expert
VIP Expert
from my phone your M/C config looks fine can you confirm you have reachability to all networks as I did notice you have eigrp running and by default this protocol is class full in design so you may need to disable auto summarisation otherwise any non classfull subnets may not be advertised correctly

router eigrp xx
no auto-summary

Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards

Paul,   I made the change you requested before making the changes Cristian told me to make, no difference. Still seeing no messages on receiver 13.2. We also have tried running the same python script but on a different port at the same time and matched it on 13.2 receive script, nothing. 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers