cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1453
Views
30
Helpful
36
Replies

MultiLink for point to point connection

ajurado25
Level 1
Level 1

Hi,

We currently have two t1 lines from the corporate office to our warehouse. The t1's on both sides are connected to two wics on 1721 routers. We are attempting to combine the two t1s to get the full 3mbps bandwidth. I tried using the ip cef command but it is not available (even though I'm running IOS 12.1). I am now trying to setup multilink but it just doesn't work. I'm using the same IP scheme on both sides (the current setup has the t1s within the same bridge-group). I've provided my running config.

Current configuration:

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Corporate_PTP_Router

!

enable password xxxxxx

!

!

!

!

!

memory-size iomem 25

ip subnet-zero

no ip routing

!

!

!

!

interface Serial0

ip address 192.168.1.20 255.255.255.0

no ip route-cache

service-module t1 clock source internal

bridge-group 1

!

interface Serial1

ip address 192.168.1.24 255.255.255.0

no ip route-cache

service-module t1 clock source internal

bridge-group 1

!

interface FastEthernet0

ip address 192.168.1.20 255.255.255.0

no ip route-cache

speed auto

bridge-group 1

!

ip classless

no ip http server

!

bridge 1 protocol ieee

!

line con 0

transport input none

line aux 0

line vty 0 4

password xxxxx

login

!

end

I setup the multilink interface on the corporate side first but I cannot ping the multilink IP. I then proceed to setup the multilink IP on the warehouse side and i can ping that IP address but only from the corporate router.

Any ideas?????

36 Replies 36

jeff.xiao
Level 1
Level 1

I don't see any routing protocols configured on this router and what is your Wan type?

The routers were configured from before by the provider. The router on the other end of the point to point is configured in the same manner. I guess no routing protocol was needed since the IP scheme is the same on both ends.

Running config from warehouse router:

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Warehouse_PTP_Router

!

enable password xxxx

!

!

!

!

!

memory-size iomem 25

ip subnet-zero

no ip routing

!

!

!

!

interface Serial0

ip address 192.168.1.21 255.255.255.0

no ip route-cache

bridge-group 1

!

interface Serial1

bandwidth 1544

ip address 192.168.1.26 255.255.255.0

no ip route-cache

service-module t1 timeslots 1-24

bridge-group 1

!

interface FastEthernet0

ip address 192.168.1.21 255.255.255.0

no ip route-cache

speed auto

bridge-group 1

!

ip classless

no ip http server

!

bridge 1 protocol ieee

!

line con 0

transport input none

line aux 0

line vty 0 4

password xxxx

login

!

end

Should I change the IP scheme on the warehouse side? When creating the multilink do I need to set it up on both routers? I really need to increase the bandwidth from the warehouse to the corporate office.

Thanks.

Equal Cost Routes

To get load balancing to happen, you need equal cost routes pointing to the interfaces involved in the load balancing. For example, on Router A load balancing 2 T1's, the "show ip route" output might include something like this:

S* 0.0.0.0/0 is directly connected, Serial0/1

is directly connected, Serial0/0

And on Router B the balanced cost static routes may be set up as follows:

ip route 192.168.8.0 255.255.255.0 Serial1/3 10

ip route 192.168.8.0 255.255.255.0 Serial1/0 10

ip load-sharing per-packet

int serial 0

ip load-sharing per-packet

int serial 1

ip load-sharing per-packet

You apply this to each interface you want to participate in per-packet load balancing. Remember, you want to do this on the routers at both ends of the T1's.

I do not have ip cef available to me. That was my first choice but when view the available commands I have no ip cef enabled. Would the fact that I have the "no ip routing" enabled not allow me to see the ip cef command? And if by chance I get to use ip cef would I need to change the IP scheme on the warehouse side or can I use the same IP scheme as the corporate side.

Thanks again.

I have not tried to set up load balance on the same subnet without any routing protocol, but by default cef is not enable on cisco routers except 7000 series. Or instead of using per-packet load balancing, you can use load sharing by configuring a routing protocol that supports multi-path and change your ip scheme.

Here's what's happening:

The line - "no ip routing" disables IP routing functionality. IPs are used for management only.

You'll notice that you have "bridge group 1" assigned to all interfaces. Essentially, you have one flat subnet from HQ to Warehouse. You are using the two routers and 2 T1s as bridges rather than routers.

Since you are bridging, and with the 2 T1s you've created a loop, spanning-tree (STP) is placing one of the T1 ports in a blocked state. So effectively, you only have one T1 link available for transit. If that transit link should fail, STP will reconverge and use the other T1 link.

Depending on your network/host requirements, there may likely be many ways to meet your requirements. The advice others have posted are good advice, but we'd need to know why a choice to bridge, rather than route, was made by the vendor.

I wish I knew why the vendor is using bridge-group instead of routing. Vendor does not support point to point connections anymore (company has had the point to point for more than 3 years and 3 years ago vendor supported point to point configuration). We recently choose to upgrade connection from 1.5 to 3 megs but sales rep. failed to mention that the point to point would go unmanaged. I called vendor and asked which would be the best way to combine bandwidth. Vendor mentioned ip cef. Not sure how I should handle this. should I go with multilink? I would like to have the 3megs to use rather than load balance between the 2 connections.

Any ideas? Thanks again.

Understood.

Indeed, it's hard to think of a good reason for this particular config. I suspect that either you have non-routable protocols like SNA, LAT, or NetBEUI or numerous protocols that the vendor didn't want or know how to support.

Or maybe there were very good reasons for this approach...

So let me give some things to chew on / work through.

It may also be that the vendor took this approach so that your internet router/firewall was the only gateway and configured as default gateway. Maybe lame, maybe necessary for your infrastructure, but possible either way. I dunno.

Do you have any mainframe, as400, Netware, old Windows 9x or 3.x on this network?

If not, there's probably no reason not to separate the network into different subnets (one per T1, and one per location), enable ip routing, then ip cef, then cef per-packet load balancing, etc.

Multilink PPP (MLPPP) is great for multi-protocol support ie some combination of AppleTalk, IPX, & IP. If this network is IP only cef per-packet should be all you need.

If you can handle SNA & NetBeui with DLSW+. And if you are a multiprotocol shop, you'll probably need an enterprise or IP/IPX image.

If it seems like I'm keeping this very high level, it's because nobody can tell you conclusively the right way to go without really knowing your network.

That said, you can see there are some things to investigate and work through.

Hopefully this will shed more light.

There was a Novell server they were using possibly as far back as 3 years ago. So that may have been the reson for the bridge-group setup or they wanted and easy way out of the setup and kept the warehouse on the same subnet. Warehouse does go through the corporate firewall to access the internet. All servers are on the corporate side. Warehouse only has workstations. Network is now Windows 2000 servers and Windows XP workstations. We have no legacy systems in place. 3 months ago I completed migrating from NT to W2K. We only run IP.

I was thinking of going towards the seperate IP scheme on the warehouse side but when I attempt to enable IP CEF on either router the command is not available. Both routers are 1721 and I've read that the IP CEF command has been available since IOS 11.3. Since IP CEF is not available is there some trigger command that I don't of? If CEF is out what other way would I be able to combine both t1's for a full 3 meg bandwidth?

Thanks again!

Enable ip routing and you should be able to enable cef.

(config)#ip routing

(config)ip cef

And then you can play with per-packet, etc.

Caution!!!! When you do this, everything warehouse related breaks until the re-addressing at the warehouse is corrected!!!

Thanks.

I will try enabling ip routing on the corporate side first. I will let you know the outcome. Thanks for the help.

Hi,

I enabled ip routing on one router but I still do not have the IP CEF command available. Is there anything else that might be preventing me from having this command available? Since it seems this command is not available should I proceed with the multilink configuration?

And if so does anyone have a config I might be able to use as a guideline.

Thanks again.

Very strange.

Can you post a "show version"?

Here is the version info you requested.

Cisco Internetwork Operating System Software

IOS (tm) C1700 Software (C1700-Y-M), Version 12.1(3), RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2000 by cisco Systems, Inc.

Compiled Wed 05-Jul-00 17:07 by cmong

Image text-base: 0x80008088, data-base: 0x805CDB90

ROM: System Bootstrap, Version 12.0(3)T, RELEASE SOFTWARE (fc1)

Corporate_PTP_Router uptime is 3 days, 20 hours, 40 minutes

System returned to ROM by power-on

System image file is "flash:c1700-y-mz.121-3"

cisco 1720 (MPC860) processor (revision 0x601) with 24576K/8192K bytes of memory

.

Processor board ID JAD05190HRU (1786435041), with hardware revision 0000

M860 processor: part number 0, mask 32

Bridging software.

X.25 software, Version 3.0.0.

1 FastEthernet/IEEE 802.3 interface(s)

2 Serial network interface(s)

WIC T1-DSU

32K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Let me know what you think. Thanks.

Review Cisco Networking for a $25 gift card