cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3247
Views
0
Helpful
3
Replies

Multiple vlan on a single port not trunk

  Hi, need some help.

Valn 10: PC

Vlan 30: voice

Vlan 40: printer

How can I configure a single port for multiple vlans?? I am using a Cisco 3560 G PoE as an access switch. Vlans have differrent subnets.

I have a trunk on my last port:

interface gi0/24

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan 10, 30, 40

On my port:

interface gi0/1
description LAN Access
switchport access vlan 10
switchport voice vlan 30
spanning-tree portfast  

How can my printers have connection on that port???

regards rey 

2 Accepted Solutions

Accepted Solutions

cadet alain
VIP Alumni
VIP Alumni

Hi,

to my best knowledge they can't  as this type of "mini trunk" port only supports 1 tagged vlan which is the data in your case. you need a real trunk port to have multiple tagged frames.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

View solution in original post

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello Reymond,

you cannot achieve a "plug and play" configuration involving three Vlans.

There is no 3-vlans capable mini Vlan and a printer cannot be distinguished from a PC when it starts to connect to the network ( it will try to get an IP address via DHCP or it can have a manually configured IP address exactly like a PC) it does not use special protocol messages.

On ports where you know a printer will be connected you will need

switchport access vlan 40

instead of

switchport access vlan 10

This means that any time a new printer has to be connected to the network a specific network side configuration is needed.

You can use the description command to label the interfaces connecting to printers.

Hope to help

Giuseppe

View solution in original post

3 Replies 3

cadet alain
VIP Alumni
VIP Alumni

Hi,

to my best knowledge they can't  as this type of "mini trunk" port only supports 1 tagged vlan which is the data in your case. you need a real trunk port to have multiple tagged frames.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello Reymond,

you cannot achieve a "plug and play" configuration involving three Vlans.

There is no 3-vlans capable mini Vlan and a printer cannot be distinguished from a PC when it starts to connect to the network ( it will try to get an IP address via DHCP or it can have a manually configured IP address exactly like a PC) it does not use special protocol messages.

On ports where you know a printer will be connected you will need

switchport access vlan 40

instead of

switchport access vlan 10

This means that any time a new printer has to be connected to the network a specific network side configuration is needed.

You can use the description command to label the interfaces connecting to printers.

Hope to help

Giuseppe

Thanks for the quick response.

That help a lot.

Rey

Review Cisco Networking for a $25 gift card