04-19-2022 10:12 AM - edited 04-19-2022 10:14 AM
Hello,
I am struggling with this, I have a scenario were I need to redistribute (selective) static routes into Named EIGRP. Because the nature of needing to be selective I am using a route-map which identifies the routes with a prefix list (also tried acl).
I am able to get this working in classic eigrp but not named.
Here is the router doing the static route redistribution:
######################################################################################
HQ# show run
!Command: show running-config
!Time: Tue Apr 19 12:43:11 2022
version 7.0(3)I7(1)
hostname HQ
vdc HQ id 1
limit-resource vlan minimum 16 maximum 4094
limit-resource vrf minimum 2 maximum 4096
limit-resource port-channel minimum 0 maximum 511
limit-resource u4route-mem minimum 248 maximum 248
limit-resource u6route-mem minimum 96 maximum 96
limit-resource m4route-mem minimum 58 maximum 58
limit-resource m6route-mem minimum 8 maximum 8
feature eigrp
feature interface-vlan
username admin password 5 *******
0 role network-admin
ip domain-lookup
snmp-server user admin network-admin auth md5 0x9f0c7803b35eae9f64c1ed6e3f14cc27
priv 0x9f0c7803b35eae9f64c1ed6e3f14cc27 localizedkey
rmon event 1 description FATAL(1) owner PMON@FATAL
rmon event 2 description CRITICAL(2) owner PMON@CRITICAL
rmon event 3 description ERROR(3) owner PMON@ERROR
rmon event 4 description WARNING(4) owner PMON@WARNING
rmon event 5 description INFORMATION(5) owner PMON@INFO
vlan 1
ip prefix-list REDISTRIBUTE-STATIC-INTO-EIGRP seq 5 permit 10.6.16.0/28
ip prefix-list REDISTRIBUTE-STATIC-INTO-EIGRP seq 10 permit 10.6.16.16/28
route-map REDISTRIBUTE-INTO-EIGRP permit 5
match ip address prefix-list REDISTRIBUTE-STATIC-INTO-EIGRP
vrf context management
interface Vlan1
interface Ethernet1/1
no switchport
ip address 10.0.33.2/24
ip router eigrp TEST
no shutdown
interface Ethernet1/2
interface Ethernet1/3
interface Ethernet1/4
interface mgmt0
vrf member management
interface loopback0
ip address 2.2.2.2/32
ip router eigrp TEST
interface loopback1
ip address 2.2.2.3/32
ip router eigrp TEST
line console
line vty
ip route 0.0.0.0/0 10.250.250.2
ip route 9.1.1.0/30 10.250.250.2
ip route 10.0.16.0/32 10.250.250.2
ip route 10.6.16.16/28 10.250.250.2
router eigrp TEST
distance 90 109
address-family ipv4 unicast
autonomous-system 16
default-metric 1000 100 250 100 1500
redistribute static route-map REDISTRIBUTE-INTO-EIGRP
############################################################################################
here is the peer, I do have eigrp neighborship and learn routes of loopbacks
SITE-A# show run
!Command: show running-config
!Time: Tue Apr 19 12:43:43 2022
version 7.0(3)I7(1)
hostname HQ
vdc HQ id 1
limit-resource vlan minimum 16 maximum 4094
limit-resource vrf minimum 2 maximum 4096
limit-resource port-channel minimum 0 maximum 511
limit-resource u4route-mem minimum 248 maximum 248
limit-resource u6route-mem minimum 96 maximum 96
limit-resource m4route-mem minimum 58 maximum 58
limit-resource m6route-mem minimum 8 maximum 8
feature eigrp
username admin password 5 ***************
1 role network-admin
ip domain-lookup
snmp-server user admin network-admin auth md5 0xa6fc085745d7b61571db865f55aaa92d
priv 0xa6fc085745d7b61571db865f55aaa92d localizedkey
rmon event 1 description FATAL(1) owner PMON@FATAL
rmon event 2 description CRITICAL(2) owner PMON@CRITICAL
rmon event 3 description ERROR(3) owner PMON@ERROR
rmon event 4 description WARNING(4) owner PMON@WARNING
rmon event 5 description INFORMATION(5) owner PMON@INFO
vlan 1
vrf context management
interface Ethernet1/1
no switchport
ip address 10.0.33.3/24
ip router eigrp TEST
no shutdown
interface Ethernet1/2
interface Ethernet1/3
interface Ethernet1/4
interface mgmt0
vrf member management
interface loopback0
ip address 1.1.1.1/32
ip router eigrp TEST
interface loopback1
ip address 1.1.1.3/32
ip router eigrp TEST
line console
line vty
router eigrp TEST
distance 90 109
address-family ipv4 unicast
autonomous-system 16
BCCO# show ip route
IP Route Table for VRF "default"
'*' denotes best ucast next-hop
'**' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]
'%<string>' in via output denotes VRF <string>
1.1.1.1/32, ubest/mbest: 2/0, attached
*via 1.1.1.1, Lo0, [0/0], 14:26:07, local
*via 1.1.1.1, Lo0, [0/0], 14:26:07, direct
1.1.1.3/32, ubest/mbest: 2/0, attached
*via 1.1.1.3, Lo1, [0/0], 14:14:17, local
*via 1.1.1.3, Lo1, [0/0], 14:14:17, direct
2.2.2.2/32, ubest/mbest: 1/0
*via 10.0.33.2, Eth1/1, [90/130816], 00:18:16, eigrp-ADVIA, internal
2.2.2.3/32, ubest/mbest: 1/0
*via 10.0.33.2, Eth1/1, [90/130816], 00:18:16, eigrp-ADVIA, internal
10.0.33.0/24, ubest/mbest: 1/0, attached
*via 10.0.33.3, Eth1/1, [0/0], 14:30:46, direct
10.0.33.3/32, ubest/mbest: 1/0, attached
*via 10.0.33.3, Eth1/1, [0/0], 14:30:46, local
Solved! Go to Solution.
04-19-2022 11:34 AM
I figured this out, this was a GNS3 lab, so my next hop address on the static route was not up as this was a rough test....
I reached out to a old college, and explained how all seems good with the config and I keep coming back to the EIGRP basics, for it to be advertised the route needs to be up. I however told myself for the last 36 hours a default route (0.0.0.0 0.0.0.0 x.x.x.x) is not up but I wasn't thinking about the next hop address that in fact is up.
I am glad I was able to focus my troubleshooting at the EIGRP fundamentals but ashamed I did not make sure the next hop was up.
04-19-2022 10:53 AM
Probably not the problem but the first prefix list does not match with the respective route
ip prefix-list REDISTRIBUTE-STATIC-INTO-EIGRP seq 5 permit 10.6.16.0/28
ip prefix-list REDISTRIBUTE-STATIC-INTO-EIGRP seq 10 permit 10.6.16.16/28
ip route 0.0.0.0/0 10.250.250.2
ip route 9.1.1.0/30 10.250.250.2
ip route 10.0.16.0/32 10.250.250.2
ip route 10.6.16.16/28 10.250.250.2
Any specific reason to use this kind of EIGRP?
04-19-2022 11:04 AM
Are the routes in the EIGRP topology table on the peer ?
If so can you post output.
Jon
04-19-2022 11:27 AM - edited 04-19-2022 11:40 AM
router eigrp TEST
address-family ipv4 autonomous-system 16
af-inteface Fx/x .....etc.
try this way
04-19-2022 11:34 AM
I figured this out, this was a GNS3 lab, so my next hop address on the static route was not up as this was a rough test....
I reached out to a old college, and explained how all seems good with the config and I keep coming back to the EIGRP basics, for it to be advertised the route needs to be up. I however told myself for the last 36 hours a default route (0.0.0.0 0.0.0.0 x.x.x.x) is not up but I wasn't thinking about the next hop address that in fact is up.
I am glad I was able to focus my troubleshooting at the EIGRP fundamentals but ashamed I did not make sure the next hop was up.
04-19-2022 11:42 AM
If you want next time config static route with Null0 this make static route always UP.
And I glad your issue solved.
good luck friend
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide