05-28-2013 06:18 PM - edited 03-04-2019 08:02 PM
Hello Everyone,
If I'm sitting inside my network (192.168.1.0/24) and I type in an internet browser my global address with a port attached (50.50.50.50:5001) it says page cannot be displayed, but if i'm outside of my network and I use that same address the port forwarding works? How do I configure my router to be able to use the global address when i'm inside my network so i do not have to change my server settings in all my devices everytime I want to check my work orders while sitting at my desk?
Config:
interface FastEthernet0/0
ip address 50.50.50.50 255.255.224.0
ip verify unicast source reachable-via rx allow-default 100
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
speed 100
full-duplex
no keepalive
no mop enabled
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
speed 100
full-duplex
no keepalive
no mop enabled
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 50.50.50.x
!
!
ip nat inside source list 1 interface FastEthernet0/0 overload
ip nat inside source static tcp 192.168.1.10 5001 interface FastEthernet0/0 5001
ip nat inside source static tcp 192.168.1.10 5002 interface FastEthernet0/0 5002
!
!
access-list 1 permit 192.168.1.0 0.0.0.255
Solved! Go to Solution.
05-28-2013 11:41 PM
Hi,
It should be working with NAT NVI:
int f0/1
no ip nat in
no ip redirect
ip nat enable
int f0/0
no ip nat out
ip nat enable
no ip redirect
no ip nat inside source list 1 interface FastEthernet0/0 overload
no ip nat inside source static tcp 192.168.1.10 5001 interface FastEthernet0/0 5001
no ip nat inside source static tcp 192.168.1.10 5002 interface FastEthernet0/0 5002
ip nat source list 1 interface FastEthernet0/0 overload
ip nat source static tcp 192.168.1.10 5001 interface FastEthernet0/0 5001
ip nat source static tcp 192.168.1.10 5002 interface FastEthernet0/0 5002
Regards
Alain
Don't forget to rate helpful posts.
05-28-2013 09:00 PM
you would need to confgure NAT hairpinning to be able to do that
alternatively DNS doctoring and changing lmhost file to you could fix this as well
=============================
Please remember to rate useful posts, by clicking on the stars below.
=============================
05-28-2013 11:41 PM
Hi,
It should be working with NAT NVI:
int f0/1
no ip nat in
no ip redirect
ip nat enable
int f0/0
no ip nat out
ip nat enable
no ip redirect
no ip nat inside source list 1 interface FastEthernet0/0 overload
no ip nat inside source static tcp 192.168.1.10 5001 interface FastEthernet0/0 5001
no ip nat inside source static tcp 192.168.1.10 5002 interface FastEthernet0/0 5002
ip nat source list 1 interface FastEthernet0/0 overload
ip nat source static tcp 192.168.1.10 5001 interface FastEthernet0/0 5001
ip nat source static tcp 192.168.1.10 5002 interface FastEthernet0/0 5002
Regards
Alain
Don't forget to rate helpful posts.
05-29-2013 12:25 AM
That works perfectly. Thanks! Now to understand why it works that way.
Much Appreciation!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide