cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

170
Views
0
Helpful
1
Replies

Need help to configure a router as a terminal server with reverse telnet

Hi all,
I would like to know if someone has an example of router config for a terminal server.
In fact I need a configuration for a router with multiple, low speed, asynchronous ports that are connected to other serial devices, for example,
modems or console ports on routers or switches.
With this router I would like to use a reverse telnet to connect with my devices using the serial connection.
I find many examples on the Cisco web site but none with my router hardware configuration.
My router is a 3620 router with a 8 port async (NM-8A/S) network module and I would like to use the 8 serial interfaces, each of them connecting a serial device.

Thank you by advance.


Here is the show run and show ver :
Router#show ver
Cisco Internetwork Operating System Software
IOS (tm) 3600 Software (C3620-I-M), Version 12.3(25), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2008 by cisco Systems, Inc.
Compiled Mon 28-Jan-08 20:16 by alnguyen

ROM: System Bootstrap, Version 11.1(19)AA, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

Router uptime is 1 minute
System returned to ROM by reload
System image file is "flash:c3620-i-mz.123-25.bin"

cisco 3620 (R4700) processor (revision 0x81) with 45056K/4096K bytes of memory.
Processor board ID 11876590
R4700 CPU at 80MHz, Implementation 33, Rev 1.0
Bridging software.
X.25 software, Version 3.0.0.
1 Ethernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
8 Low-speed serial(sync/async) network interface(s)
DRAM configuration is 32 bits wide with parity disabled.
29K bytes of non-volatile configuration memory.
12288K bytes of processor board System flash (Read/Write)
         
Configuration register is 0x2102

Router#show run
Building configuration...

Current configuration : 883 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot system flash flash:c3620-i-mz.123-25.bin
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
ip cef
!
!
!
!        
!
!
interface Ethernet0/0
ip address dhcp
half-duplex
!
interface Serial0/0
no ip address
shutdown
!
interface Serial0/1
no ip address
shutdown
!
interface Serial1/0
no ip address
shutdown
!
interface Serial1/1
no ip address
shutdown
!
interface Serial1/2
no ip address
shutdown
!
interface Serial1/3
no ip address
shutdown
!
interface Serial1/4
no ip address
shutdown
!
interface Serial1/5
no ip address
shutdown
!
interface Serial1/6
no ip address
shutdown
!
interface Serial1/7
no ip address
shutdown
!        
ip http server
ip classless
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

1 REPLY 1
Highlighted
Cisco Employee

Re: Need help to configure a router as a terminal server with re

The below mentioned link explains on how to configure a router as terminal server. I have used this config

earlier to set up my lab.

http://www.cisco.com/en/US/tech/tk801/tk36/technologies_configuration_example09186a008014f8e7.shtml

Config details:

ip host 3600-2 2013 172.21.1.1
ip host 5200-1 2010 172.21.1.1
ip host 2600-1 2008 172.21.1.1

2013,2010,2008 are the terminal port lines in which you get connected to the router...

Also rememer that 2013 corresponds to the 13th serial port in the router.

While you want to "3600-2" device connected in the 13th serial port use "telnet host [port]           [keyword]"

(ie) telnet 172.21.1.1 2013


Remember in order to reverse telnet the port no should be 2000+serial port no

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here