07-15-2020 06:55 AM
I created a Lo102 interface on router R1 ip address 100.110.102.1 255.255.255.0 to simulate a network behind it. I have a 172.21.1.0 / 24 network from a 701. vlan. I announced the 172.21.1.0 network via OSPF on R17 to R1.
# R17 # ospf 100 # router
summary-address 10.0.0.0 255.0.0.0
network 100.126.198.0 0.0.0.255 area 100
network 172.21.1.0 0.0.0.255 area 100
neighbor 100.126.198.238
R17 # sh ip route 172.21.1.0
Routing entry for 172.21.1.0/24
Known via "static", distance 1, metric 0
Routing Descriptor Blocks:
* 10.22.212.2
******************************************
ip route 172.21.1.0 255.255.255.0 10.22.212.2
!
access-list 10 permit 172.21.1.0 0.0.0.255
access-list 20 permit 10.22.212.0 0.0.0.255
interface FastEthernet1 / 0
description To_R1
ip address 100.126.198.237 255.255.255.252
ip nat outside
ip ospf network point-to-point
FastEthernet0 / 0 interface
ip address 10.22.212.1 255.255.255.0
ip nat inside
I also created a static route for R1.
ip route 172.21.1.0 255.255.255.0 10.22.212.2
!
access-list 10 permit 172.21.1.0 0.0.0.255
access-list 20 permit 10.22.212.0 0.0.0.255
On R1 I announced the network 100.110.102.0
ospf 100 router
router-id 10.10.10.101
network 100.110.102.0 0.0.0.255 area 100
network 100.126.198.0 0.0.0.255 area 100
neighbor 100.126.198.237
I have a PC on the 172.21.1.10 network that cant ping the Lo102. What is missing to solve this problem?
I am setting up this lab to develop my knowledge in routing. In the future I will add an ASA behind the R17. My idea with this topology is to simulate a data center behind the R17 and arrive at a branch on the internet.
*********************R1*************************
router ospf 1
!
router ospf 100
router-id 10.10.10.101
network 100.110.102.0 0.0.0.255 area 100
network 100.126.198.0 0.0.0.255 area 100
neighbor 100.126.198.237
!
router bgp 500
bgp log-neighbor-changes
bgp bestpath compare-routerid
network 1.1.1.1 mask 255.255.255.255
network 172.21.1.0 mask 255.255.255.0
neighbor 192.168.12.2 remote-as 500
neighbor 192.168.13.3 remote-as 500
maximum-paths ibgp 2
Solved! Go to Solution.
07-16-2020 04:51 AM
Hello
Can you clarify where the device that hosts this Loopback interface is located?
If it’s on the inside of a natted network, then you won’t be able to reach it externally unless it has a valid inside global address relating to it.
Also note by default opsf loopback interfaces are advertised as host /32 unless you change the ospf interface mode of the loopback however this shouldn’t negate that interface from being advertised within ospf.
Int Loopback0
ip ospf network point-to-point
07-15-2020 11:57 AM
Not sure your topology how it looks like :
but why you have static route - ip route 172.21.1.0 255.255.255.0 10.22.212.2 (this take precedence - so remove it)
If R17 Announcing route to R1 - R1 should see the routes show io route and learn routes (if the OSPF neighbour relation up and running)
on R1
why you are announcing same route in BGP :
router bgp 500
bgp log-neighbor-changes
bgp bestpath compare-routerid
network 1.1.1.1 mask 255.255.255.255
no network 172.21.1.0 mask 255.255.255.0
neighbor 192.168.12.2 remote-as 500
neighbor 192.168.13.3 remote-as 500
maximum-paths ibgp 2
if you like to learn the route to announce via BGP you can redistribute OSPF learn routes., but one step at a time, fix your Loopback interface reachability fist.
07-21-2020 01:15 PM - edited 07-21-2020 08:24 PM
Below is part of my laboratory.
The first objective:
The network 172.21.1.0/24 is able to reach the network 100.110.102.0 it behind the R1. And ping the Lo102 100.110.102.1 on R1.
TESTs
PC--> Lo102.
C:\Documents and Settings\user>tracert 100.110.102.1
1 2 ms 2 ms 2 ms 172.21.1.1
2 18 ms 17ms 16 ms 10.22.212.1 <<--R17-INTERFACE F0/0
3 * * * Request timed out.
When I remove the ip route 172.21.1.0 255.255.255.0 10.22.212.2. The packet with destination IP address 100.110.102.1 not arrive R17-INTERFACE F0/0.
C:\Documents and Settings\user>tracert 100.110.102.1
1 2 ms 2 ms 2 ms 172.21.1.1
2 * * * Request timed out.
The packet with destination interface Lo102 100.110.102.1
R17#ping 100.110.102.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.110.102.1, timeout is 2 seconds:
!!!!!
R1#ping 10.22.212.1 <<--R17 interface f0/0 inside
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.22.212.1, timeout is 2 seconds:
!!!!!
*********************************************
*****************R1**************************
*********************************************
I was announcing the 172.21.1.0 mask 255.255.255.0 network in BGP.
!I removed this configuration as requested.!
R1#
bgp 500 router
bgp log-neighbor-changes
bgp bestpath compare-routerid
network 1.1.1.1 mask 255.255.255.255
no network 172.21.1.0 mask 255.255.255.0
neighbor 192.168.12.2 remote-as 500
neighbor 192.168.13.3 remote-as 500
maximum-paths ibgp 2
R1#show run
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback102
ip address 100.110.102.1 255.255.255.0
!
interface Loopback10001
description Router-id OSPF100
ip address 10.10.10.101 255.255.255.255
!
interface FastEthernet0/0
description F0/1_R2
ip address 192.168.12.1 255.255.255.0
ip ospf 1 area 0
duplex full
!
interface FastEthernet1/0
description F0/0_R3
ip address 192.168.13.1 255.255.255.0
ip ospf 1 area 0
duplex full
!
interface FastEthernet2/0
description MPLS OI
ip address 100.126.198.238 255.255.255.252
ip ospf network point-to-point
duplex full
!
router ospf 1
!
router ospf 100
router-id 10.10.10.101
network 100.110.102.0 0.0.0.255 area 100
network 100.126.198.0 0.0.0.255 area 100
neighbor 100.126.198.237
!
router bgp 500
bgp log-neighbor-changes
bgp bestpath compare-routerid
network 1.1.1.1 mask 255.255.255.255
neighbor 192.168.12.2 remote-as 500
neighbor 192.168.13.3 remote-as 500
maximum-paths ibgp 2
******************************
************R17**************
******************************
The Router R17 receives OSPF information about 100.110.102.1/32.
R17#sh ip route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.22.212.0/24 is directly connected, FastEthernet0/0
L 10.22.212.1/32 is directly connected, FastEthernet0/0
100.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O 100.110.102.1/32
[110/2] via 100.126.198.238, 01:12:17, FastEthernet1/0
C 100.126.198.236/30 is directly connected, FastEthernet1/0
L 100.126.198.237/32 is directly connected, FastEthernet1/0
126.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 126.1.1.0/24 is directly connected, Loopback3
L 126.1.1.1/32 is directly connected, Loopback3
130.100.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 130.100.200.0/24 is directly connected, Loopback2
L 130.100.200.1/32 is directly connected, Loopback2
I have configured a NAT on the R17 for the network 172.21.1.0/24.
R17#sh ip nat translations
Pro Inside global Inside local Outside local Outside global
--- 172.21.1.6 172.21.1.10 --- ---
interface Loopback2
ip address 130.100.200.1 255.255.255.0
!
interface Loopback3
ip address 126.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.22.212.1 255.255.255.0
ip nat inside
duplex full
!
interface FastEthernet1/0
ip address 100.126.198.237 255.255.255.252
ip nat outside
ip ospf network point-to-point
duplex full
!
interface FastEthernet2/0
no ip address
shutdown
duplex full
!
router ospf 100
network 10.22.212.0 0.0.0.255 area 100
network 100.126.198.0 0.0.0.255 area 100
network 172.21.1.0 0.0.0.255 area 100
neighbor 100.126.198.238
!
ip nat pool servers 172.21.1.6 172.21.1.253 netmask 255.255.255.0
ip nat inside source list 10 pool servers
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
access-list 10 permit 172.21.1.0 0.0.0.255
access-list 20 permit 10.22.212.0 0.0.0.255
Could the problem be with NAT?
07-15-2020 12:09 PM - edited 07-15-2020 12:18 PM
I would start TS with trace to see see where it stops (or how far it goes); And if you have A real PC (not virtual), check PC firewall.
also, see show ip route 100.110.102.1 t check if it's missing somewhere. why you have static route?
Regards, ML
**Please Rate All Helpful Responses **
07-21-2020 08:10 PM
07-22-2020 06:18 AM
Martin.
It lab is created in EVE.
07-16-2020 04:51 AM
Hello
Can you clarify where the device that hosts this Loopback interface is located?
If it’s on the inside of a natted network, then you won’t be able to reach it externally unless it has a valid inside global address relating to it.
Also note by default opsf loopback interfaces are advertised as host /32 unless you change the ospf interface mode of the loopback however this shouldn’t negate that interface from being advertised within ospf.
Int Loopback0
ip ospf network point-to-point
07-21-2020 08:08 PM
07-22-2020 06:02 AM
Hello
Can you clarify where the device that hosts this Loopback interface is located?
>It's EVE-NG Lab, The loopback behind R1. I posted of the running.
If it’s on the inside of a natted network, then you won’t be able to reach it externally unless it has a valid inside global address relating to it.
Also note by default opsf loopback interfaces are advertised as host /32 unless you change the ospf interface mode of the loopback however this shouldn’t negate that interface from being advertised within ospf.
Int Loopback0
ip ospf network point-to-point
Below is part of my laboratory.
The first objective:
The network 172.21.1.0/24 is able to reach the network 100.110.102.0 it behind the R1. And ping the Lo102 100.110.102.1 on R1.
TESTs
The PC Tracert for Lo102.
C:\Documents and Settings\user>tracert 100.110.102.1
1 2 ms 2 ms 2 ms 172.21.1.1
2 18 ms 17ms 16 ms 10.22.212.1 <<--R17-INTERFACE F0/0
3 * * * Request timed out.
When I remove the ip route 172.21.1.0 255.255.255.0 10.22.212.2. The packet with destination IP address 100.110.102.1 not arrive R17-INTERFACE F0/0.
C:\Documents and Settings\user>tracert 100.110.102.1
1 2 ms 2 ms 2 ms 172.21.1.1
2 * * * Request timed out.
The packet with destination interface Lo102 100.110.102.1
R17#ping 100.110.102.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.110.102.1, timeout is 2 seconds:
!!!!!
R1#ping 10.22.212.1 <<--R17 interface f0/0 inside
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.22.212.1, timeout is 2 seconds:
!!!!!
*********************************************
*****************R1**************************
*********************************************
I was announcing the 172.21.1.0 mask 255.255.255.0 network in BGP.
!I removed this configuration as requested.!
R1#
bgp 500 router
bgp log-neighbor-changes
bgp bestpath compare-routerid
network 1.1.1.1 mask 255.255.255.255
no network 172.21.1.0 mask 255.255.255.0
neighbor 192.168.12.2 remote-as 500
neighbor 192.168.13.3 remote-as 500
maximum-paths ibgp 2
R1#show run
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback102
ip address 100.110.102.1 255.255.255.0
!
interface Loopback10001
description Router-id OSPF100
ip address 10.10.10.101 255.255.255.255
!
interface FastEthernet0/0
description F0/1_R2
ip address 192.168.12.1 255.255.255.0
ip ospf 1 area 0
duplex full
!
interface FastEthernet1/0
description F0/0_R3
ip address 192.168.13.1 255.255.255.0
ip ospf 1 area 0
duplex full
!
interface FastEthernet2/0
description MPLS OI
ip address 100.126.198.238 255.255.255.252
ip ospf network point-to-point
duplex full
!
router ospf 1
!
router ospf 100
router-id 10.10.10.101
network 100.110.102.0 0.0.0.255 area 100
network 100.126.198.0 0.0.0.255 area 100
neighbor 100.126.198.237
!
router bgp 500
bgp log-neighbor-changes
bgp bestpath compare-routerid
network 1.1.1.1 mask 255.255.255.255
neighbor 192.168.12.2 remote-as 500
neighbor 192.168.13.3 remote-as 500
maximum-paths ibgp 2
******************************
************R17**************
The Router R17 receives OSPF information about 100.110.102.1/32.
R17#sh ip route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.22.212.0/24 is directly connected, FastEthernet0/0
L 10.22.212.1/32 is directly connected, FastEthernet0/0
100.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O 100.110.102.1/32
[110/2] via 100.126.198.238, 01:12:17, FastEthernet1/0
C 100.126.198.236/30 is directly connected, FastEthernet1/0
L 100.126.198.237/32 is directly connected, FastEthernet1/0
126.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 126.1.1.0/24 is directly connected, Loopback3
L 126.1.1.1/32 is directly connected, Loopback3
130.100.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 130.100.200.0/24 is directly connected, Loopback2
L 130.100.200.1/32 is directly connected, Loopback2
I have configured a NAT on the R17 for the network 172.21.1.0/24.
R17#sh ip nat translations
Pro Inside global Inside local Outside local Outside global
--- 172.21.1.6 172.21.1.10 --- ---
interface Loopback2
ip address 130.100.200.1 255.255.255.0
!
interface Loopback3
ip address 126.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.22.212.1 255.255.255.0
ip nat inside
duplex full
!
interface FastEthernet1/0
ip address 100.126.198.237 255.255.255.252
ip nat outside
ip ospf network point-to-point
duplex full
!
interface FastEthernet2/0
no ip address
shutdown
duplex full
!
router ospf 100
network 10.22.212.0 0.0.0.255 area 100
network 100.126.198.0 0.0.0.255 area 100
network 172.21.1.0 0.0.0.255 area 100
neighbor 100.126.198.238
!
ip nat pool servers 172.21.1.6 172.21.1.253 netmask 255.255.255.0
ip nat inside source list 10 pool servers
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
access-list 10 permit 172.21.1.0 0.0.0.255
access-list 20 permit 10.22.212.0 0.0.0.255
Could the problem be with NAT?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide