cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
309
Views
0
Helpful
6
Replies

NX-OS - Having trouble working out route redistribution

mbrown-revitycu
Level 1
Level 1

We have a pair of Nexus L3 switches performing OSPF routing to other locations in our environment. Some of the locations are using older ISRs for routing and a couple have Meraki devices handling it.

I am trying to set static routes on the Nexus stack to redistribute to the other locations in OSPF but it isn't working the way I am attempting it.

The OSPF config I have on the Nexus:

router ospf 10
router-id 10.10.100.236
default-information originate
redistribute static route-map RedistributeStaticAndInternalRoutes
log-adjacency-changes
area 0.0.0.0 authentication
passive-interface default

And the route-map config:

route-map RedistributeStaticAndInternalRoutes permit 10
match ip address prefix-list MerakiTrafficIPs Public_DNS_IPs InternalNetworks LocalNetworks

And lastly, the prefix lists:

ip prefix-list InternalNetworks description Allow internal network traffic
ip prefix-list InternalNetworks seq 10 permit 10.200.121.0/24
ip prefix-list InternalNetworks seq 20 permit 10.200.122.0/24
ip prefix-list InternalNetworks seq 30 permit 10.200.123.0/24
ip prefix-list InternalNetworks seq 40 permit 10.200.124.0/24
ip prefix-list InternalNetworks seq 50 permit 10.200.125.0/24
ip prefix-list InternalNetworks seq 60 permit 10.200.129.0/24
ip prefix-list InternalNetworks seq 70 permit 10.200.130.0/24
ip prefix-list LocalNetworks description Allow local network traffic
ip prefix-list LocalNetworks seq 10 permit 10.200.100.0/24
ip prefix-list LocalNetworks seq 20 permit 172.16.100.0/24
ip prefix-list MerakiTrafficIPs description Allow Meraki call home traffic
ip prefix-list MerakiTrafficIPs seq 10 permit 64.62.142.12/32
ip prefix-list MerakiTrafficIPs seq 20 permit 158.115.128.0/19
ip prefix-list MerakiTrafficIPs seq 30 permit 192.168.13.0/24
ip prefix-list MerakiTrafficIPs seq 40 permit 209.206.48.0/20
ip prefix-list MerakiTrafficIPs seq 50 permit 216.157.128.0/20
ip prefix-list Public_DNS_IPs description Allow public DNS traffic
ip prefix-list Public_DNS_IPs seq 10 permit 8.8.8.8/32
ip prefix-list Public_DNS_IPs seq 20 permit 1.1.1.1/32

My reading of the documentation indicates that this should redistribute the routes identified in the prefix lists into OSPF where the rest of the routers will pick it up. This just isn't happening though.

If I set a straight static route with an "ip route" command, those get picked up fine. That's what "default information originate" is doing if my understanding is correct?

What have I got wrong here?

Thanks!

 

 

6 Replies 6

Hello
the match statement in the route-map  doesn't match the prefix-list 

ip prefix-list InternalNetworks

match ip address prefix-list MerakiTrafficIPs Public_DNS_IPs InternalNetworks LocalNetworks


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

mbrown-revitycu
Level 1
Level 1

What I was trying to do is to match multiple prefix lists with that route map. That's what I thought I had understood to be the correct process.

Does it need to be something like this instead?

route-map RedistributeStaticAndInternalRoutes permit 10
match ip address prefix-list MerakiTrafficIPs

route-map RedistributeStaticAndInternalRoutes permit 20
match ip address prefix-list Public_DNS_IPs 

route-map RedistributeStaticAndInternalRoutes permit 30
match ip address prefix-list InternalNetworks

route-map RedistributeStaticAndInternalRoutes permit 40
match ip address prefix-list LocalNetworks

And so on for any other prefix lists I might want to add?

Thanks!

 

Hello
yes the ,match statment in the route-map needs to match the actual prefix-list


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

mbrown-revitycu
Level 1
Level 1

I still am not getting this to work for some reason.

I found some more documentation stating that to match multiple prefix lists within a single route map, you have to include "continue" statements.

This is where I currently stand:

route-map RedistributeStaticAndInternalRoutes permit 10
match ip address prefix-list InternalNetworks
match route-type internal
continue 20
route-map RedistributeStaticAndInternalRoutes permit 20
match ip address prefix-list Public_DNS_IPs
match route-type internal

ip prefix-list InternalNetworks description Allow internal network traffic
ip prefix-list InternalNetworks seq 10 permit 10.200.121.0/24
ip prefix-list InternalNetworks seq 20 permit 10.200.122.0/24
ip prefix-list InternalNetworks seq 30 permit 10.200.123.0/24
ip prefix-list InternalNetworks seq 40 permit 10.200.124.0/24
ip prefix-list InternalNetworks seq 50 permit 10.200.125.0/24
ip prefix-list InternalNetworks seq 60 permit 10.200.129.0/24
ip prefix-list InternalNetworks seq 70 permit 10.200.130.0/24
ip prefix-list Public_DNS_IPs description Allow public DNS traffic
ip prefix-list Public_DNS_IPs seq 10 permit 8.8.8.8/32
ip prefix-list Public_DNS_IPs seq 20 permit 1.1.1.1/32

route-map RedistributeStaticAndInternalRoutes, permit, sequence 10
Match clauses:
ip address prefix-lists: InternalNetworks
route-type: internal
Continue: sequence 20
Set clauses:
route-map RedistributeStaticAndInternalRoutes, permit, sequence 20
Match clauses:
ip address prefix-lists: Public_DNS_IPs
route-type: internal
Set clauses:

 

What I *think* should happen is that the addresses in the InternalNetworks and Public_DNS_IPs prefix lists should be advertised out into OSPF where the other neighbors should get the routes to those addresses.

This isn't happening at all. The routes are not being picked up by the other OSPF neighbors.

Something else is obviously wrong but I'm not seeing it.

 

Do you have routes to this prefixes in routing table (sh ip ro 10.200.121.0/24)?

Can you share ospf database?

mbrown-revitycu
Level 1
Level 1

It appears that we do have routes to the prefix in the routing table.

EDW-CORE-S-253# sh ip ospf data
OSPF Router with ID (10.10.100.236) (Process ID 10 VRF default)

Router Link States (Area 0.0.0.0)

Link ID ADV Router Age Seq# Checksum Link Count
10.10.100.236 10.10.100.236 1570 0x80003194 0xf712 8
10.100.100.254 10.100.100.254 512 0x80002daa 0x70be 6
10.253.253.4 10.253.253.4 721 0x800059ed 0xa58e 4
192.0.8.254 192.0.8.254 837 0x80004e13 0x63a4 1
192.0.12.254 192.0.12.254 239 0x8001baf0 0xf5e2 10
192.0.16.1 192.0.16.1 1201 0x800037c0 0xb8a2 1
192.68.20.1 192.68.20.1 320 0x80000a4c 0x99d1 1
192.68.120.254 192.68.120.254 854 0x80004e18 0x2a6e 1
192.68.123.2 192.68.123.2 1085 0x80003fa4 0xbb55 1
192.68.130.254 192.68.130.254 556 0x8000ab9b 0x02a7 1
192.168.0.254 192.168.0.254 905 0x8000718c 0x288e 10
192.168.12.1 192.168.12.1 970 0x800142f9 0x2f59 1

Network Link States (Area 0.0.0.0)

Link ID ADV Router Age Seq# Checksum
10.252.252.2 10.10.100.236 390 0x80002da5 0xcb21
10.253.253.4 10.253.253.4 721 0x80002950 0x73f4
172.16.1.2 192.0.12.254 123 0x80000e9b 0xd80e
172.16.99.254 192.0.12.254 904 0x80000298 0xd511

Summary Network Link States (Area 0.0.0.0)

Link ID ADV Router Age Seq# Checksum
192.168.12.0 192.168.12.1 970 0x800116f2 0xcc7a

Type-5 AS External Link States

Link ID ADV Router Age Seq# Checksum Tag
0.0.0.0 10.10.100.236 650 0x8000314d 0xc925 0
1.1.1.1 10.100.100.254 422 0x80000008 0x39a8 0
8.8.8.8 10.100.100.254 402 0x80002da5 0x33c7 0
10.10.2.65 192.168.0.254 673 0x8000716e 0x9510 0
10.100.163.66 192.168.0.254 673 0x80002fae 0xa307 0
10.100.163.74 192.168.0.254 673 0x80002fad 0x554e 0
10.100.163.90 192.168.0.254 673 0x80002fac 0xb6dd 0
10.100.163.98 192.168.0.254 673 0x80002fab 0x6825 0
10.202.1.0 192.168.0.254 673 0x8000716e 0x2403 0
10.202.5.0 192.168.0.254 673 0x8000716e 0xf72b 0
10.210.15.255 192.168.0.254 673 0x8000716e 0xdd42 0
10.200.121.0 192.68.120.254 854 0x80004dde 0xa0ef 0
10.200.122.0 192.0.16.1 1201 0x80003785 0x7b2e 0
10.200.123.0 192.68.123.2 1085 0x80003f53 0xa47d 0
10.200.124.0 192.0.8.254 837 0x80004de1 0xae90 0
10.200.125.0 192.68.20.1 320 0x80000a49 0x1cab 0
10.200.130.0 192.68.130.254 556 0x8000a6e3 0xe03e 0
10.200.145.0 192.168.0.254 673 0x8000716e 0xb4c7 0
10.254.254.0 10.253.253.4 721 0x80005168 0xaf1f 0
12.42.142.30 192.168.0.254 673 0x8000716e 0x4fca 0
64.62.142.12 10.100.100.254 402 0x80002da5 0xdd24 0
66.170.18.105 192.68.20.1 320 0x80000a49 0x7b50 0
104.18.28.175 192.168.0.254 673 0x800039df 0xc0bc 0
104.18.29.175 192.168.0.254 673 0x800039e0 0xb3c7 0
158.115.128.0 10.100.100.254 402 0x80002da5 0x0c9b 0
170.209.0.2 192.168.0.254 673 0x8000716e 0x9edf 0
170.209.0.3 192.168.0.254 673 0x8000716e 0x94e8 0
172.16.40.4 192.68.20.1 320 0x80000a49 0x440a 0
172.16.40.8 192.68.123.2 1085 0x80000ce8 0xfc43 0
172.16.40.12 192.0.16.1 1201 0x80003785 0x32f2 0
172.16.40.16 192.68.120.254 854 0x800005dc 0x0150 0
172.16.40.32 192.68.130.254 556 0x800004e4 0x0d23 0
172.16.40.40 192.0.8.254 837 0x800036ed 0x8f1c 0
172.16.130.0 192.68.130.254 556 0x8000a6e3 0x98b8 0
172.16.150.16 192.0.16.1 1201 0x80003785 0x3383 0
172.16.150.24 192.68.123.2 1085 0x80003f53 0x1711 0
172.16.150.40 192.68.130.254 556 0x80007a0e 0x30ed 0
172.16.150.48 192.68.120.254 854 0x80004dde 0x0c70 0
172.16.150.56 192.68.20.1 320 0x80000a49 0x634c 0
172.30.1.1 192.168.0.254 673 0x8000716e 0xef40 0
192.0.1.0 192.68.120.254 854 0x80004dde 0x41f5 0
192.0.2.0 192.68.20.1 320 0x80000a49 0xdd93 0
192.0.8.0 192.0.8.254 837 0x80004de1 0x23be 0
192.0.10.245 192.68.20.1 320 0x8000024f 0xf57f 0
192.0.14.0 192.68.123.2 1085 0x80003f53 0xcbf1 0
192.0.16.0 192.0.16.1 1201 0x80003785 0x81c0 0
192.68.20.0 192.68.20.1 320 0x80000a49 0xe337 0
192.68.120.254 192.68.120.254 854 0x80004ddc 0xf984 0
192.68.123.2 192.68.123.2 1085 0x80003f51 0xd437 0
192.68.130.254 192.68.130.254 556 0x8000a6e1 0x2fdc 0
192.168.1.0 192.68.130.254 556 0x8000a6e3 0xfc29 0
192.168.2.0 192.68.20.1 320 0x80000a49 0xf5d2 0
192.168.8.0 192.0.8.254 837 0x80004de1 0x3bfd 0
192.168.10.255 192.168.0.254 673 0x8000716e 0x1376 0
192.168.11.0 192.68.120.254 854 0x80004dde 0xea99 0
192.168.13.0 10.100.100.254 402 0x80002da5 0x6341 0
192.168.14.0 192.68.123.2 1085 0x80003f53 0xe331 0
192.168.16.0 192.0.16.1 1201 0x80003785 0x99ff 0
192.168.30.0 192.68.130.254 556 0x8000a6e3 0xbc4c 0
192.168.101.0 192.0.12.254 830 0x8000c22c 0x2cda 0
192.168.121.0 192.68.120.254 854 0x800032e4 0x71b9 0
192.168.122.0 192.0.16.1 1201 0x800032e4 0x577d 0
192.168.123.0 192.68.123.2 1085 0x800032e5 0x32ef 0
192.168.124.0 192.0.8.254 837 0x800032e5 0x8358 0
192.168.125.0 192.68.20.1 320 0x80000a49 0xa7a5 0
192.168.250.0 10.100.100.254 402 0x80002da5 0x2a8c 0
192.168.251.0 192.0.12.254 830 0x80001e38 0xa110 0
192.168.254.255 192.168.0.254 673 0x8000716e 0x8c08 0
199.186.96.255 192.168.0.254 673 0x80003317 0x921d 0
199.186.97.0 192.168.0.254 673 0x80003316 0x8926 0
199.186.98.255 192.168.0.254 673 0x80003315 0x802f 0
199.217.219.248 192.168.0.254 673 0x8000716e 0x810c 0
204.194.130.14 192.168.0.254 673 0x8000716e 0x8359 0
204.194.130.23 192.168.0.254 673 0x8000716e 0x29aa 0
209.206.48.0 10.100.100.254 402 0x80002da5 0xed6b 0
216.157.128.0 10.100.100.254 402 0x80002da5 0x6dc5 0
216.189.0.0 192.68.20.1 320 0x8000024f 0xd2cf 0
216.189.225.255 192.168.0.254 673 0x8000716e 0x6ff3 0

EDW-CORE-S-253# sh ip ro
IP Route Table for VRF "default"
'*' denotes best ucast next-hop
'**' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]
'%<string>' in via output denotes VRF <string>

0.0.0.0/0, ubest/mbest: 1/0
*via 10.254.254.1, [1/0], 12w3d, static
1.1.1.1/32, ubest/mbest: 1/0
*via 10.254.254.1, [1/0], 03:22:16, static
3.130.87.169/32, ubest/mbest: 1/0
*via 10.254.254.1, [1/0], 02:54:49, static
8.8.8.8/32, ubest/mbest: 1/0
*via 10.254.254.1, [1/0], 12w3d, static
10.10.2.65/32, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
10.100.163.66/32, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
10.100.163.74/32, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
10.100.163.90/32, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
10.100.163.98/32, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
10.202.1.0/24, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
10.202.5.0/24, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
10.210.0.0/20, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
10.200.100.0/24, ubest/mbest: 1/0
*via 10.253.253.4, Vlan253, [110/41], 12w4d, ospf-10, intra
10.200.120.0/24, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/41], 1w6d, ospf-10, intra
10.200.121.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101 <<<<<<<<<<<<<<<<<<<<
10.200.122.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
10.200.123.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
10.200.124.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
10.200.125.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
10.200.129.0/24, ubest/mbest: 1/0
*via 172.16.99.254, Eth1/45, [110/41], 1w6d, ospf-10, intra
10.200.130.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
10.200.145.0/24, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
10.252.252.0/29, ubest/mbest: 1/0, attached
*via 10.252.252.2, Vlan252, [0/0], 1y24w, direct
10.252.252.2/32, ubest/mbest: 1/0, attached
*via 10.252.252.2, Vlan252, [0/0], 1y24w, local
10.253.253.0/24, ubest/mbest: 1/0, attached
*via 10.253.253.2, Vlan253, [0/0], 1y24w, direct
10.253.253.1/32, ubest/mbest: 1/0, attached
*via 10.253.253.1, Vlan253, [0/0], 1y24w, hsrp
10.253.253.2/32, ubest/mbest: 1/0, attached
*via 10.253.253.2, Vlan253, [0/0], 1y24w, local
10.254.254.0/24, ubest/mbest: 1/0, attached
*via 10.254.254.3, Vlan254, [0/0], 1y24w, direct
10.254.254.2/32, ubest/mbest: 1/0, attached
*via 10.254.254.2, Vlan254, [0/0], 1y24w, hsrp
10.254.254.3/32, ubest/mbest: 1/0, attached
*via 10.254.254.3, Vlan254, [0/0], 1y24w, local
12.26.158.136/29, ubest/mbest: 1/0
*via 10.254.254.1, [1/0], 12w3d, static
12.42.142.30/32, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
64.62.142.12/32, ubest/mbest: 1/0
*via 10.254.254.1, [1/0], 12w3d, static
66.170.18.105/32, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
104.18.28.175/32, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
104.18.29.175/32, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
128.177.14.0/24, ubest/mbest: 1/0
*via 10.254.254.1, [1/0], 03:29:30, static
128.177.36.0/24, ubest/mbest: 1/0
*via 10.254.254.1, [1/0], 03:29:30, static
135.84.168.0/21, ubest/mbest: 1/0
*via 10.254.254.1, [1/0], 03:29:30, static
139.177.64.0/21, ubest/mbest: 1/0
*via 10.254.254.1, [1/0], 03:29:30, static
139.177.72.0/23, ubest/mbest: 1/0
*via 10.254.254.1, [1/0], 03:29:29, static
144.196.0.0/16, ubest/mbest: 1/0
*via 10.254.254.1, [1/0], 02:56:58, static
158.115.128.0/19, ubest/mbest: 1/0
*via 10.254.254.1, [1/0], 12w3d, static
170.72.0.0/16, ubest/mbest: 1/0
*via 10.254.254.1, [1/0], 5d20h, static
170.209.0.2/32, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
170.209.0.3/32, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
172.16.0.0/24, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/41], 1w6d, ospf-10, intra
172.16.1.0/30, ubest/mbest: 1/0
*via 172.16.99.254, Eth1/45, [110/41], 1w6d, ospf-10, intra
172.16.3.0/24, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/41], 1w6d, ospf-10, intra
172.16.4.0/24, ubest/mbest: 1/0
*via 172.16.99.254, Eth1/45, [110/41], 1w6d, ospf-10, intra
172.16.20.0/27, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/41], 1w6d, ospf-10, intra
172.16.20.32/27, ubest/mbest: 1/0, attached
*via 172.16.20.34, Vlan30, [0/0], 1y24w, direct
172.16.20.33/32, ubest/mbest: 1/0, attached
*via 172.16.20.33, Vlan30, [0/0], 1y24w, hsrp
172.16.20.34/32, ubest/mbest: 1/0, attached
*via 172.16.20.34, Vlan30, [0/0], 1y24w, local
172.16.21.0/24, ubest/mbest: 1/0
*via 172.16.99.254, Eth1/45, [110/41], 1w6d, ospf-10, intra
172.16.40.4/30, ubest/mbest: 1/0
*via 172.16.99.252, Eth1/45, [110/20], 1w6d, ospf-10, type-2
172.16.40.8/30, ubest/mbest: 1/0
*via 172.16.99.248, Eth1/45, [110/20], 1w6d, ospf-10, type-2
172.16.40.12/30, ubest/mbest: 1/0
*via 172.16.99.251, Eth1/45, [110/20], 1w6d, ospf-10, type-2
172.16.40.16/30, ubest/mbest: 1/0
*via 172.16.99.250, Eth1/45, [110/20], 1w6d, ospf-10, type-2
172.16.40.32/30, ubest/mbest: 1/0
*via 172.16.99.244, Eth1/45, [110/20], 1w6d, ospf-10, type-2
172.16.40.40/30, ubest/mbest: 1/0
*via 172.16.99.249, Eth1/45, [110/20], 1w6d, ospf-10, type-2
172.16.41.0/30, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/50], 1w6d, ospf-10, intra
172.16.41.4/30, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/50], 1w6d, ospf-10, intra
172.16.41.8/30, ubest/mbest: 1/0
*via 172.16.99.254, Eth1/45, [110/60], 1w6d, ospf-10, intra
172.16.41.12/30, ubest/mbest: 1/0
*via 172.16.99.254, Eth1/45, [110/70], 1w6d, ospf-10, intra
172.16.41.16/29, ubest/mbest: 1/0, attached
*via 172.16.41.18, Vlan999, [0/0], 45w1d, direct
172.16.41.17/32, ubest/mbest: 1/0, attached
*via 172.16.41.17, Vlan999, [0/0], 45w1d, hsrp
172.16.41.18/32, ubest/mbest: 1/0, attached
*via 172.16.41.18, Vlan999, [0/0], 45w1d, local
172.16.66.0/24, ubest/mbest: 1/0, attached
*via 172.16.66.2, Vlan66, [0/0], 1y4w, direct
172.16.66.1/32, ubest/mbest: 1/0, attached
*via 172.16.66.1, Vlan66, [0/0], 1y4w, hsrp
172.16.66.2/32, ubest/mbest: 1/0, attached
*via 172.16.66.2, Vlan66, [0/0], 1y4w, local
172.16.98.1/32, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 6w5d, bgp-65100, external, tag 65101
172.16.99.0/24, ubest/mbest: 1/0, attached
*via 172.16.99.236, Eth1/45, [0/0], 5w4d, direct
172.16.99.220/30, ubest/mbest: 1/0
*via 10.252.252.3, [1/0], 27w5d, static
172.16.99.236/32, ubest/mbest: 1/0, attached
*via 172.16.99.236, Eth1/45, [0/0], 5w4d, local
172.16.100.0/24, ubest/mbest: 1/0, attached
*via 172.16.100.2, Vlan35, [0/0], 1y24w, direct
172.16.100.1/32, ubest/mbest: 1/0, attached
*via 172.16.100.1, Vlan35, [0/0], 1y24w, hsrp
172.16.100.2/32, ubest/mbest: 1/0, attached
*via 172.16.100.2, Vlan35, [0/0], 1y24w, local
172.16.130.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
172.16.150.0/29, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/41], 1w6d, ospf-10, intra
172.16.150.8/29, ubest/mbest: 1/0
*via 172.16.99.254, Eth1/45, [110/41], 1w6d, ospf-10, intra
172.16.150.16/29, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
172.16.150.24/29, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
172.16.150.32/29, ubest/mbest: 1/0
*via 10.253.253.4, Vlan253, [110/41], 12w4d, ospf-10, intra
172.16.150.40/29, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
172.16.150.48/29, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
172.16.150.56/29, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
172.16.160.0/29, ubest/mbest: 1/0, attached
*via 172.16.160.2, Vlan160, [0/0], 1y0w, direct
172.16.160.1/32, ubest/mbest: 1/0, attached
*via 172.16.160.1, Vlan160, [0/0], 1y0w, hsrp
172.16.160.2/32, ubest/mbest: 1/0, attached
*via 172.16.160.2, Vlan160, [0/0], 1y0w, local
172.30.1.1/32, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
192.0.0.0/24, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/41], 1w6d, ospf-10, intra
192.0.1.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.0.2.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.0.8.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.0.10.245/32, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.0.12.0/24, ubest/mbest: 1/0
*via 172.16.99.254, Eth1/45, [110/41], 1w6d, ospf-10, intra
192.0.14.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.0.16.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.68.20.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.68.120.254/32, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.68.123.2/32, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.68.130.254/32, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.168.0.0/24, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/41], 1w6d, ospf-10, intra
192.168.1.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.168.2.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.168.8.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.168.10.0/24, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
192.168.11.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.168.12.0/24, ubest/mbest: 1/0
*via 172.16.99.254, Eth1/45, [110/41], 1w6d, ospf-10, intra
192.168.13.0/24, ubest/mbest: 1/0, attached
*via 192.168.13.3, Vlan13, [0/0], 25w6d, direct
192.168.13.2/32, ubest/mbest: 1/0, attached
*via 192.168.13.2, Vlan13, [0/0], 25w6d, hsrp
192.168.13.3/32, ubest/mbest: 1/0, attached
*via 192.168.13.3, Vlan13, [0/0], 25w6d, local
192.168.14.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.168.16.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.168.30.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.168.50.0/24, ubest/mbest: 1/0
*via 10.253.253.4, Vlan253, [110/41], 12w4d, ospf-10, intra
192.168.101.0/24, ubest/mbest: 1/0
*via 172.16.99.254, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
192.168.113.13/32, ubest/mbest: 1/0
*via 10.254.254.1, [1/0], 12w3d, static
192.168.121.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.168.122.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.168.123.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.168.124.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.168.125.0/24, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
192.168.250.0/24, ubest/mbest: 1/0
*via 10.254.254.1, [1/0], 12w3d, static
192.168.251.0/24, ubest/mbest: 1/0
*via 172.16.99.254, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
192.168.254.0/24, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
199.186.96.0/24, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
199.186.97.0/24, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
199.186.98.0/24, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
199.217.219.248/29, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
204.194.130.14/32, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
204.194.130.23/32, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2
209.206.48.0/20, ubest/mbest: 1/0
*via 10.254.254.1, [1/0], 12w3d, static
216.157.128.0/20, ubest/mbest: 1/0
*via 10.254.254.1, [1/0], 12w3d, static
216.189.0.0/22, ubest/mbest: 1/0
*via 172.16.41.20, [20/50], 1w6d, bgp-65100, external, tag 65101
216.189.224.0/23, ubest/mbest: 1/0
*via 172.16.99.253, Eth1/45, [110/10000], 1w6d, ospf-10, type-2