cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
341
Views
0
Helpful
0
Replies
mediaos718
Beginner

NXOSv Route Leak

IMG-5941.jpg

 

I am having 2 issues in this lab.

 

  • R1 and the NXOSv are running BGP
  • On the Nexus the eBGP is running inside the VRF “TEST”
  • R2 is running EIGRP with the NXOSv (Global table of the NXOSv)

 

Issue 1: I am unable to leak EIGRP routes in the BGP – I do not see the EIGRP routes in R1 (See config and routing table below)

Issue 2: I am able to see BGP routes in R2 but only after I add the following command in the NXOSv un the the VRF context “TEST” => import “vrf default map ACCEPT_ALL” – Although it works, this logically does not make sense. Why when I do an import of the default VRF under the context, I am able to export BGP route to R2 – [Is there something I can fix here?]

 

Please help

 

R1

interface Ethernet1/0.100

 encapsulation dot1Q 100

 ip address 10.0.0.1 255.255.255.0

 

interface Loopback0

 ip address 1.1.1.1 255.255.255.255

 

router bgp 1

 no synchronization

 bgp router-id 1.1.1.1

 bgp log-neighbor-changes

 network 1.1.1.1 mask 255.255.255.255

 network 10.0.0.0 mask 255.255.255.0

 neighbor 10.0.0.3 remote-as 2

 no auto-summary

 

R1# sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     1.0.0.0/32 is subnetted, 1 subnets

C       1.1.1.1 is directly connected, Loopback0

     3.0.0.0/32 is subnetted, 1 subnets

B       3.3.3.3 [20/0] via 10.0.0.3, 00:19:53

     10.0.0.0/24 is subnetted, 1 subnets

C       10.0.0.0 is directly connected, Ethernet1/0.100

 

 

+++++++++++++++++

 

R2

 

router eigrp 1

 network 2.0.0.0

 network 20.0.0.0

 no auto-summary

 

interface Ethernet1/0

 ip address 20.0.0.2 255.255.255.0

 duplex hal

 

interface Loopback0

 ip address 2.2.2.2 255.255.255.255

!

 

 

R2#    sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2

       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

       ia - IS-IS inter area, * - candidate default, U - per-user static route

       o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

     1.0.0.0/32 is subnetted, 1 subnets

D EX    1.1.1.1 [170/307200] via 20.0.0.3, 00:08:29, Ethernet1/0

     2.0.0.0/32 is subnetted, 1 subnets

C       2.2.2.2 is directly connected, Loopback0

     3.0.0.0/32 is subnetted, 1 subnets

D EX    3.3.3.3 [170/307200] via 20.0.0.3, 00:08:29, Ethernet1/0

     20.0.0.0/24 is subnetted, 1 subnets

C       20.0.0.0 is directly connected, Ethernet1/0

     10.0.0.0/24 is subnetted, 1 subnets

D EX    10.0.0.0 [170/307200] via 20.0.0.3, 00:08:29, Ethernet1/0

     30.0.0.0/32 is subnetted, 1 subnets

D       30.30.30.30 [90/409600] via 20.0.0.3, 00:24:44, Ethernet1/0

+++++++++++++++++++++++++++++++++

 

NXOSv

 

feature bgp

feature eigrp

feature interface-vlan

 

ip route 0.0.0.0/0 10.0.0.1 vrf TEST

vlan 1,100

vlan 100

  name TEST

 

route-map ACCEPT_ALL permit 10

vrf context TEST

  rd 1:1

  address-family ipv4 unicast

    route-target import 1:1

    route-target export 1:1

    import vrf default map ACCEPT_ALL

    export vrf default map ACCEPT_ALL

 

 

interface Vlan100

  no shutdown

  vrf member TEST

  ip address 10.0.0.3/24

 

interface Ethernet1/1

  switchport

  switchport mode trunk

  switchport trunk allowed vlan 100

  no shutdown

 

interface Ethernet1/2

  ip address 20.0.0.3/24

  ip router eigrp 1

  no shutdown

 

interface loopback1

  ip address 30.30.30.30/32

  ip router eigrp 1

 

interface loopback3

  vrf member TEST

  ip address 3.3.3.3/32

line console

line vty

router eigrp 1

  router-id 3.3.3.3

  redistribute bgp 2 route-map ACCEPT_ALL

  address-family ipv4 unicast

  vrf TEST

    address-family ipv4 unicast

      network 3.3.3.3/32

router bgp 2

  router-id 3.3.3.3

  address-family ipv4 unicast

  vrf TEST

    address-family ipv4 unicast

      network 3.3.3.3/32

      redistribute eigrp 1 route-map ACCEPT_ALL

    neighbor 10.0.0.1

      remote-as 1

      address-family ipv4 unicast

 

 

 

switch(config)# sh ip route vrf all

IP Route Table for VRF "default"

'*' denotes best ucast next-hop

'**' denotes best mcast next-hop

'[x/y]' denotes [preference/metric]

'%<string>' in via output denotes VRF <string>

 

0.0.0.0/0, ubest/mbest: 1/0

    *via 10.0.0.1%TEST, [1/0], 00:27:03, static

1.1.1.1/32, ubest/mbest: 1/0

    *via 10.0.0.1%TEST, [20/0], 00:11:15, bgp-2, external, tag 1

2.2.2.2/32, ubest/mbest: 1/0

    *via 20.0.0.2, Eth1/2, [90/130816], 00:27:30, eigrp-1, internal

3.3.3.3/32, ubest/mbest: 1/0, attached

    *via 3.3.3.3%TEST, Lo3, [20/0], 00:11:15, bgp-2, external, tag 2

10.0.0.0/24, ubest/mbest: 1/0

    *via 10.0.0.1%TEST, [20/0], 00:11:15, bgp-2, external, tag 1

20.0.0.0/24, ubest/mbest: 1/0, attached

    *via 20.0.0.3, Eth1/2, [0/0], 00:27:32, direct

20.0.0.3/32, ubest/mbest: 1/0, attached

    *via 20.0.0.3, Eth1/2, [0/0], 00:27:32, local

30.30.30.30/32, ubest/mbest: 2/0, attached

    *via 30.30.30.30, Lo1, [0/0], 00:27:36, local

    *via 30.30.30.30, Lo1, [0/0], 00:27:36, direct

 

IP Route Table for VRF "TEST"

'*' denotes best ucast next-hop

'**' denotes best mcast next-hop

'[x/y]' denotes [preference/metric]

'%<string>' in via output denotes VRF <string>

 

1.1.1.1/32, ubest/mbest: 1/0

    *via 10.0.0.1, [20/0], 00:24:00, bgp-2, external, tag 1

3.3.3.3/32, ubest/mbest: 2/0, attached

    *via 3.3.3.3, Lo3, [0/0], 00:27:34, local

    *via 3.3.3.3, Lo3, [0/0], 00:27:34, direct

10.0.0.0/24, ubest/mbest: 1/0, attached

    *via 10.0.0.3, Vlan100, [0/0], 00:27:03, direct

10.0.0.3/32, ubest/mbest: 1/0, attached

    *via 10.0.0.3, Vlan100, [0/0], 00:27:03, local

 

0 REPLIES 0