cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
178
Views
15
Helpful
4
Replies
Highlighted
Beginner

OSPF Routing Protocol - OSPF neighbors do not display

OSPF.png

Here are the configurations for each router

 

Router with Switch2 (Left):

en
config t
no ip domain-lookup
int fa0/0
ip add 172.16.1.17 255.255.255.240
no shutdown
exit
int s0/0
ip add 192.168.10.1 255.255.255.252
clock rate 64000
no shutdown
exit
int s0/1
ip add 192.168.10.5 255.255.255.252
no shutdown
exit
router ospf 1
network 172.16.1.16 0.0.0.15 area 0
network 192.168.10.0 0.0.0.3 area 0
network 192.168.10.4 0.0.0.3 area 0
end
copy run start

 

Router with Switch4 (Middle):

en
config t
no ip domain-lookup
int fa0/0
ip add 10.10.10.1 255.255.255.0
no shutdown
exit
int s0/0
ip add 192.168.10.2 255.255.255.252
clock rate 64000
no shutdown
exit
int s0/1
ip add 192.168.10.9 255.255.255.252
no shutdown
exit
router ospf 1
network 10.10.10.0 0.0.0.255 area 0
network 192.168.10.0 0.0.0.3 area 0
network 192.168.10.8 0.0.0.3 area 0
end
copy run start

 

Router with Switch3 (Right):

en
config t
no ip domain-lookup
int fa0/0
ip add 172.16.1.33 255.255.255.248
no shutdown
exit
int s0/0
ip add 192.168.10.6 255.255.255.252
clock rate 64000
no shutdown
exit
int s0/1
ip add 192.168.10.10 255.255.255.252
no shutdown
exit
router ospf 1
network 172.16.1.32 0.0.0.7 area 0
network 192.168.10.4 0.0.0.3 area 0
network 192.168.10.8 0.0.0.3 area 0
end
copy run start

 

When I do the show ip ospf neighbor on the Router with Switch4 (Middle), it doesn't show the connectivity:

ospf 2.jpg

Any idea? Thanks in advance.

3 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Collaborator

Re: OSPF Routing Protocol - OSPF neighbors do not display

Hi,

 

   1. First, test if you have IP connectivity over the Serial links, between the routers. Based on the diagram and attached config, it looks like the Serial interface are miss-configured and the routers re not sharing the same subnet. Like for example router 4 (middle) looks to have an IP of 192.168.10.9/30 facing left router, while router 2 (left) looks to have an IP of 192.168.10.1/30 facing the middle router, so they're not in the same subnet. So fix this first, ensure the interfaces are properly configured to match the physical connectivity. Test wit PING.

  2. Your OSPF config looks correct, so try first with "show ip ospf interface brief" to see if the interfaces are running OSPF. afterwards, "show ip ospf neighbor".

 

Regards,

Cristian Matei.

View solution in original post

Highlighted
VIP Mentor

Re: OSPF Routing Protocol - OSPF neighbors do not display

Hello,

 

post the zipped Packet Tracer project (.pkt) file here...

View solution in original post

Highlighted
VIP Mentor

Re: OSPF Routing Protocol - OSPF neighbors do not display

I don't see any attached file...?

View solution in original post

4 REPLIES 4
Highlighted
Collaborator

Re: OSPF Routing Protocol - OSPF neighbors do not display

Hi,

 

   1. First, test if you have IP connectivity over the Serial links, between the routers. Based on the diagram and attached config, it looks like the Serial interface are miss-configured and the routers re not sharing the same subnet. Like for example router 4 (middle) looks to have an IP of 192.168.10.9/30 facing left router, while router 2 (left) looks to have an IP of 192.168.10.1/30 facing the middle router, so they're not in the same subnet. So fix this first, ensure the interfaces are properly configured to match the physical connectivity. Test wit PING.

  2. Your OSPF config looks correct, so try first with "show ip ospf interface brief" to see if the interfaces are running OSPF. afterwards, "show ip ospf neighbor".

 

Regards,

Cristian Matei.

View solution in original post

Highlighted
VIP Mentor

Re: OSPF Routing Protocol - OSPF neighbors do not display

Hello,

 

post the zipped Packet Tracer project (.pkt) file here...

View solution in original post

Highlighted
VIP Mentor

Re: OSPF Routing Protocol - OSPF neighbors do not display

I don't see any attached file...?

View solution in original post

Highlighted
Beginner

Re: OSPF Routing Protocol - OSPF neighbors do not display

Oops, sorry for the long-delayed reply. 

 

http://www.mediafire.com/file/cz4sb2pfbquwcz4/OSPF_test.pkt/file