cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
385
Views
10
Helpful
7
Replies
rpozywak
Beginner

OSPF Stuck in INT C3560 Switches

Hi All,

     I am having a problem with OSPF neighbors stuck in the state of INIT.   I am currently running a point to multipoint network.  The core of the network has a Cisco 6509 installed and at each remote site either a cisco 3750x or a cisco C3560CG 8 Port switch is installed.

    

       The connection between all the sites are on a layer 2 connection via fiber and a additional link over microwave for backup.
I am having a problem with two of the sites that have the C3560CG switches installed.    On the links that have the microwave connection the interface is set with an IP address and configuration and OSPF comes right up on those ports.
 
       On the ports that have layer 2 fiber connection, those ports are set to trunk and a routed VLAN is being trunked over that port.     The ports do come up and OPSF does not go back the state of INIT.   I did a debug on the OSPF and I get the following report from debug:
Rcv hello from 10.200.201.242 area 200 10.200.202.1
Nov 12 17:00:02.815: OSPF-200 HELLO Vl700: No more immediate hello for nbr 10.200.201.242, which has been sent on this intf 2 times
Nov 12 17:00:02.815: OSPF-200 HELLO Vl700: End of hello processing

The other sites that have a different switch ie 3750X comes right up over the layer 2 trunk port without a problem.   
This is my configuration on the Cisco C3560CG:
 
VLAN Routed
interface Vlan700
description ROUTED VLAN OVER FIBER
ip address 10.200.202.7 255.255.255.224
ip pim passive
ip ospf network point-to-multipoint
ip ospf cost 10
ip ospf mtu-ignore
arp timeout 600
 
interface GigabitEthernet0/10
description LAYER2 FIBER HANDOFF
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 700
switchport mode trunk
!

I also checked my MTU's on all the switches and they are set the same see below:
System MTU size is 1535 bytes
System Jumbo MTU size is 9000 bytes
System Alternate MTU size is 1535 bytes
Routing MTU size is 1500 bytes

I am unsure what the problem is and why on that VLAN and switch OSPF will not form adjacencies with the other switches on the network. 
 
Any insight on this would be appreciated
 
7 REPLIES 7
Georg Pauwen
VIP Expert

Hello,

 

check if VTP pruning is enabled on the switch, and if so, disable it (no vtp pruning).

rpozywak
Beginner

On the 3560 Switch this is the VTP Output:

 

VTP Version capable : 1 to 3
VTP version running : 1
VTP Domain Name : LCAnet
VTP Pruning Mode : Disabled
VTP Traps Generation : Disabled
Device ID : c025.5c2f.bc00
Configuration last modified by 172.16.2.6 at 0-0-00 00:00:00

Feature VLAN:
--------------
VTP Operating Mode : Transparent
Maximum VLANs supported locally : 1005
Number of existing VLANs : 15
Configuration Revision : 0
MD5 digest : 0x63 0x0F 0x2C 0x37 0xD1 0xA8 0xD9 0xA3
0xE5 0x1D 0x70 0xF2 0x2B 0x84 0x3F 0x53

 

Core Switch 6509:

VTP Version : 3 (capable)
Configuration Revision : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs : 33
VTP Operating Mode : Transparent
VTP Domain Name : LCAnet
VTP Pruning Mode : Disabled (Operationally Disabled)
VTP V2 Mode : Disabled
VTP Traps Generation : Enabled
MD5 digest : 0x6C 0x8E 0xB3 0x14 0x7C 0x9C 0x65 0x32
Configuration last modified by 172.16.252.1 at 0-0-00 00:00:00
VTP version running : 1

 

Hello,

 

set the 6509 to VTP mode server and the 3560 to VTP mode client.

balaji.bandi
VIP Expert

Make sure both the side switches are VTP Transparent and VLAN available locally and SVI up and running. Do you have reachability between 20.200.201.242  to 200 10.200.202.1 on both the side

 

i saw the message was OSPF area 200 ? what is the other side area configured?

 

can you below the device not working

 

show version 

 

from both the side

show run interface vlan 700

show run | begin router ospf

show ip route

 



BB


*** Rate All Helpful Responses ***

I am not clear whether this is an implementation that has worked and then stopped working or if it is a new deployment which has not ever worked. If it has worked and stopped, were changes made? Has there been some event that might have impacted the network? In either case is there any possibility of MTU mismatch between neighbors?

HTH

Rick
Seroj Hacopian
Beginner

Hello and dead intervals must match

rpozywak
Beginner

Cisco 3560

License Level: ipbase
License Type: Permanent
Next reload license Level: ipbase

cisco WS-C3560CG-8PC-S (PowerPC) processor (revision A0) with 131072K bytes of memory.
Processor board ID FOC1604W1XA
Last reset from power-on
7 Virtual Ethernet interfaces
10 Gigabit Ethernet interfaces
The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address : A4:56:30:90:34:80
Motherboard assembly number : 73-13272-04
Power supply part number : 341-0407-01
Motherboard serial number : FOC16021V7V
Power supply serial number : LIT15430ZCD
Model revision number : A0
Motherboard revision number : A0
Model number : WS-C3560CG-8PC-S
System serial number : FOC1604W1XA
Top Assembly Part Number : 800-33676-01
Top Assembly Revision Number : A0
Version ID : V01
CLEI Code Number : CMMD900ARA
Hardware Board Revision Number : 0x00

 

router ospf 200
router-id 10.200.201.254
passive-interface default
no passive-interface Vlan700
no passive-interface GigabitEthernet0/8
network 10.200.201.252 0.0.0.3 area 200
network 10.200.202.0 0.0.0.31 area 200
network 172.16.150.0 0.0.0.255 area 200
network 172.16.155.0 0.0.0.255 area 200
network 172.16.156.0 0.0.0.255 area 200
maximum-paths 2

 

interface Vlan700
description FIBER
ip address 10.200.202.7 255.255.255.224
ip pim passive
ip ospf network point-to-multipoint
ip ospf cost 10
ip ospf mtu-ignore
arp timeout 600