cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2289
Views
0
Helpful
11
Replies

[PACKET TRACER 7.2.1]IP Route between 2 Trunked Interfaces on separate VLANS which have a /24 Cidr

GillverK
Level 1
Level 1

topology.PNG

 

So in the above topology I'm trying to make routers Router0(1) and Router2(1) successfully ping one another. I'm using trunked interfaces with the 10.10.10.0/24 network on VLAN 1 and the 10.10.20.0/24 network on VLAN2. I'm using trunking because I was under the impression that it would allow for cross communication between VLANs as long as "switchport trunk allowed vlan all" was used which I did.  I assume that  I may need to take further steps on Router1(1) so that it allows cross communications between VLANs or that I may have to change the Subnet Masks but I'm unsure. I tried using "IP route" as pictured above, not sure if I'm using the command correctly, but I'm not sure why the two routers won't ping. Do I need to set a new protocol?

1 Accepted Solution

Accepted Solutions

Hi,

Kindly make below changes as:

Router0:

Static route for the 10.10.20.0/24 is missing. so add route as:

 

ip route 10.10.20.0 255.255.255.0 10.10.10.2

 

Router1:

Wrong routes configured:

 

no ip route 10.10.10.0 255.255.255.0 10.10.20.0
no ip route 10.10.20.0 255.255.255.0 10.10.10.0

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution if this comment will help you!

View solution in original post

11 Replies 11

Deepak Kumar
VIP Alumni
VIP Alumni

Hi,

Could you share the Router1 and anyone another as Router 0 configuration? 

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution if this comment will help you!

Hello and thank you. My configs follow:

 

Router 0(1)

Router 0(1)

Building configuration...

Current configuration : 993 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO2911/K9 sn FTX1524V3FY-
!
!
!
spanning-tree mode pvst
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/3/0
 switchport mode trunk
!
interface FastEthernet0/3/1
 switchport mode access
 switchport nonegotiate
!
interface FastEthernet0/3/2
 switchport mode access
 switchport nonegotiate
!
interface FastEthernet0/3/3
 switchport mode access
 switchport nonegotiate
!
interface Vlan1
 ip address 10.10.10.1 255.255.255.0
!
ip classless
!
ip flow-export version 9
!
!

!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

 

SWITCH0(1)

Building configuration...

Current configuration : 1091 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

 

Router1(1)

ROUTER 1(1)


Building configuration...

Current configuration : 1147 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO2911/K9 sn FTX15240W87-
!
!
spanning-tree mode pvst
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/3/0
 switchport mode trunk
!
interface FastEthernet0/3/1
 switchport trunk native vlan 2
 switchport mode trunk
!
interface FastEthernet0/3/2
 switchport mode access
 switchport nonegotiate
!
interface FastEthernet0/3/3
 switchport mode access
 switchport nonegotiate
!
interface Vlan1
 ip address 10.10.10.2 255.255.255.0
!
interface Vlan2
 ip address 10.10.20.2 255.255.255.0
!
ip classless
ip route 10.10.10.0 255.255.255.0 10.10.20.0 
ip route 10.10.20.0 255.255.255.0 10.10.10.0 
!
ip flow-export version 9
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

 

SWITCH2(0)

Building configuration...

Current configuration : 1359 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport trunk native vlan 2
 switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
 switchport trunk native vlan 2
 switchport mode trunk
!
interface FastEthernet0/17
 switchport trunk native vlan 2
 switchport mode trunk
!
interface FastEthernet0/18
 switchport trunk native vlan 2
 switchport mode trunk
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 mac-address 0050.0fd0.425a
 no ip address
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

 

 

 

SWITCH3(0)

Building configuration...

Current configuration : 1359 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 switchport trunk native vlan 2
 switchport mode trunk
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
 switchport trunk native vlan 2
 switchport mode trunk
!
interface FastEthernet0/17
 switchport trunk native vlan 2
 switchport mode trunk
!
interface FastEthernet0/18
 switchport trunk native vlan 2
 switchport mode trunk
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 mac-address 0030.f2c2.b669
 no ip address
!
!
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
!
!
end

 

 

Router2(1)

ROUTER 2(1)


Building configuration...

Current configuration : 1114 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
no ip cef
no ipv6 cef
!
!
license udi pid CISCO2911/K9 sn FTX1524CQ4L-
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface FastEthernet0/3/0
 switchport mode access
 switchport nonegotiate
!
interface FastEthernet0/3/1
 switchport trunk native vlan 2
 switchport mode trunk
!
interface FastEthernet0/3/2
 switchport mode access
 switchport nonegotiate
!
interface FastEthernet0/3/3
 switchport mode access
 switchport nonegotiate
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 ip address 10.10.20.1 255.255.255.0
!
ip classless
ip route 10.10.10.0 255.255.255.0 10.10.20.2 
!
ip flow-export version 9
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end

 

pieterh
VIP
VIP

I did not replicate your setup in packet tracer,but...

1) what do you mean with "trunked/vlan-x"?

   did you create a subinterface with dot1q-tag in the vlan ?

2) is the switchport connected to the router2 "mode trunk" or mode access?

 

if router2 vlan2 is not connected to anything, it will be effectively "down", so unreachable


@pieterh wrote:

I did not replicate your setup in packet tracer,but...

1) what do you mean with "trunked/vlan-x"?

   did you create a subinterface with dot1q-tag in the vlan ?

2) is the switchport connected to the router2 "mode trunk" or mode access?

 

if router2 vlan2 is not connected to anything, it will be effectively "down", so unreachable


Thanks for the help. I'm very, very new at this.

1. I mean I set the switchport mode to "trunk", set up a particular vlan (either used the default or made vlan 2), then attached the interfaces to the vlans while specifying the vlans would accept all other VLANs

- Sorry, not sure what you mean by sub-interface. I did assign teh connected interfaces to the VLANs I desired and set the VLANs up with an IP address

 

2. The switchport to the routers and switches are all "Trunk"

Hi Gilver,

 

I only reply because I want  to explain my response,

 

1) your extra information like .pkt file and router configs are very helpful to understand your setup.

like in the diagram you show the command for an extra route in R0, but this does not show up in the config

 

2)  a router is a router and a switch is a switch,

     but..... you are using a router which internally has a switch module.

    you use this switch ports (Fax/x) to connect to the external switch not the routed ports (Gix/x)

=>> for this reason you do not need the subinterfaces I mentioned, so forget my post in solving the curent problem

 

3) for the rest I'm confident Deepak and Georg will lead you to the solution.

 

regards and happy learning


@pieterh wrote:

Hi Gilver,

 

I only reply because I want  to explain my response,

 

1) your extra information like .pkt file and router configs are very helpful to understand your setup.

like in the diagram you show the command for an extra route in R0, but this does not show up in the config

 

2)  a router is a router and a switch is a switch,

     but..... you are using a router which internally has a switch module.

    you use this switch ports (Fax/x) to connect to the external switch not the routed ports (Gix/x)

=>> for this reason you do not need the subinterfaces I mentioned, so forget my post in solving the curent problem

 

3) for the rest I'm confident Deepak and Georg will lead you to the solution.

 

regards and happy learning


Thanks a lot. I am confident I'm in good hands. 

Hello,

 

post the Packet Tracer project (.pkt) file, zip it first, otherwise the system won't let you upload it...


@Georg Pauwen wrote:

Hello,

 

post the Packet Tracer project (.pkt) file, zip it first, otherwise the system won't let you upload it...


Hi and thank you George. Alrighty, I'm uploading the ",pkt" file now.

 

Thanks again man.

 

- GK

Hi,

Kindly make below changes as:

Router0:

Static route for the 10.10.20.0/24 is missing. so add route as:

 

ip route 10.10.20.0 255.255.255.0 10.10.10.2

 

Router1:

Wrong routes configured:

 

no ip route 10.10.10.0 255.255.255.0 10.10.20.0
no ip route 10.10.20.0 255.255.255.0 10.10.10.0

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution if this comment will help you!


@Deepak Kumar wrote:

Hi,

Kindly make below changes as:

Router0:

Static route for the 10.10.20.0/24 is missing. so add route as:

 

ip route 10.10.20.0 255.255.255.0 10.10.10.2

 

Router1:

Wrong routes configured:

 

no ip route 10.10.10.0 255.255.255.0 10.10.20.0
no ip route 10.10.20.0 255.255.255.0 10.10.10.0


WOW! That's interesting. In the original screenshot I posted in the Top Left corner under "Command" I actually tried this, or thought I did. I really wonder why this is working...

 

Thank you very, very much Deepak!!

 

Spoiler

 topology.PNG 

 

Hi,
You're Welcome! I am happy that my suggestion has worked for you.
Regards,
Deepak Kumar,
Don't forget to vote and accept the solution if this comment will help you!
Review Cisco Networking for a $25 gift card