09-20-2024 07:16 AM
Hello,
I am doing a lab for class that's due at midnight tonight and I've been having trouble for the past couple of days. The assignment is to essentially create a topology with 4 different networks connected with 3 different routers. 3 of the networks have a switch, 5 PCs, and a server. I have been able to set it up to where my PCs can ping their own router, but they cannot ping another router or PC on another network. However, my routers can ping each other (at least on their connected interfaces). I tried to set up static ip routes, but I'm unsure if I did it correctly or not. I was given a network of 192.168.20.0/24 that I had to VLSM, and this is my topology table:
Device | Interface | IP Address | Subnet Mask | Default Gateway |
R1 | G0/0 | 192.168.20.1 | 255.255.255.192 |
|
R1 | S0/0/0 (DCE) | 192.168.20.145 | 255.255.255.252 |
|
R2 | S0/0/0 | 192.168.20.146 | 255.255.255.252 |
|
R2 | G0/0 | 192.168.20.65 | 255.255.255.224 |
|
R2 | S0/0/1 (DCE) | 192.168.20.149 | 255.255.255.252 |
|
R3 | S0/0/1 | 192.168.20.150 | 255.255.255.252 |
|
R3 | G0/0 | 192.168.20.97 | 255.255.255.224 |
|
R3 | G0/1 | 192.168.20.129 | 255.255.255.240 |
|
S1 (58-hosts) |
| 192.168.20.2 | 255.255.255.192 | 192.168.20.1 |
S1-PC1 | Fa0/1 | 192.168.20.3 | 255.255.255.192 | 192.168.20.1 |
S1-PC2 | Fa0/2 | 192.168.20.4 | 255.255.255.192 | 192.168.20.1 |
S1-PC3 | Fa0/3 | 192.168.20.5 | 255.255.255.192 | 192.168.20.1 |
S1-PC4 | Fa0/4 | 192.168.20.6 | 255.255.255.192 | 192.168.20.1 |
S1-PC5 | Fa0/5 | 192.168.20.7 | 255.255.255.192 | 192.168.20.1 |
S2 (29-hosts) |
| 192.168.20.66 | 255.255.255.224 | 192.168.20.65 |
S2-PC1 | Fa0/1 | 192.168.20.67 | 255.255.255.224 | 192.168.20.65 |
S2-PC2 | Fa0/2 | 192.168.20.68 | 255.255.255.224 | 192.168.20.65 |
S2-PC3 | Fa0/3 | 192.168.20.69 | 255.255.255.224 | 192.168.20.65 |
S2-PC4 | Fa0/4 | 192.168.20.70 | 255.255.255.224 | 192.168.20.65 |
S2-PC5 | Fa0/5 | 192.168.20.71 | 255.255.255.224 | 192.168.20.65 |
S3 (15-hosts) |
| 192.168.20.98 | 255.255.255.224 | 192.168.20.97 |
S3-PC1 | Fa0/1 | 192.168.20.99 | 255.255.255.224 | 192.168.20.97 |
S3-PC2 | Fa0/2 | 192.168.20.100 | 255.255.255.224 | 192.168.20.97 |
S3-PC3 | Fa0/3 | 192.168.20.101 | 255.255.255.224 | 192.168.20.97 |
S3-PC4 | Fa0/4 | 192.168.20.102 | 255.255.255.224 | 192.168.20.97 |
S3-PC5 | Fa0/5 | 192.168.20.103 | 255.255.255.224 | 192.168.20.97 |
S3a (7-hosts) |
| 192.168.20.130 | 255.255.255.240 | 192.168.20.129 |
Ubuntu Server (S1) | Fa0/20 | 192.168.20.8 | 255.255.255.192 | 192.168.20.1 |
Windows OS (S2) | Fa0/20 | 192.168.20.72 | 255.255.255.224 | 192.168.20.65 |
Kali-Linux (S3) | Fa0/20 | 192.168.20.104 | 255.255.255.224 | 192.168.20.97 |
I have primarily just been trying to get a PC on the R1 network to ping a PC on a R2 network, so I'm going to give the show commands for those two networks.
Here is sh run for Router1 (R1):
Router#sh run
Building configuration...
Current configuration : 839 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524O0HM-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 192.168.20.1 255.255.255.192
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 192.168.20.145 255.255.255.252
clock rate 2000000
!
interface Serial0/0/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.20.148 255.255.255.252 192.168.20.146
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
Show ip route for Router1 (R1):
Router#sh ip rout
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
192.168.20.0/24 is variably subnetted, 5 subnets, 3 masks
C 192.168.20.0/26 is directly connected, GigabitEthernet0/0
L 192.168.20.1/32 is directly connected, GigabitEthernet0/0
C 192.168.20.144/30 is directly connected, Serial0/0/0
L 192.168.20.145/32 is directly connected, Serial0/0/0
S 192.168.20.148/30 [1/0] via 192.168.20.146
Show run for Router2 (R2):
Router#sh run
Building configuration...
Current configuration : 836 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524K237-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 192.168.20.65 255.255.255.224
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 192.168.20.146 255.255.255.252
!
interface Serial0/0/1
ip address 192.168.20.149 255.255.255.252
clock rate 2000000
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip route 192.168.20.0 255.255.255.252 192.168.20.145
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
Show ip route for Router2 (R2):
Router#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
192.168.20.0/24 is variably subnetted, 7 subnets, 3 masks
S 192.168.20.0/30 [1/0] via 192.168.20.145
C 192.168.20.64/27 is directly connected, GigabitEthernet0/0
L 192.168.20.65/32 is directly connected, GigabitEthernet0/0
C 192.168.20.144/30 is directly connected, Serial0/0/0
L 192.168.20.146/32 is directly connected, Serial0/0/0
C 192.168.20.148/30 is directly connected, Serial0/0/1
L 192.168.20.149/32 is directly connected, Serial0/0/1
Show run for Switch1 (S1):
Switch#sh run
Building configuration...
Current configuration : 1140 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 192.168.20.2 255.255.255.192
shutdown
!
ip default-gateway 192.168.20.1
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
!
end
Show run for Switch2 (S2):
Switch#sh run
Building configuration...
Current configuration : 1142 bytes
!
version 15.0
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 192.168.20.66 255.255.255.224
shutdown
!
ip default-gateway 192.168.20.65
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
!
end
I have also attached the Packet Tracer file. Ignore the little network that is at the bottom of the topology that isn't connected to anything, that was just me trying to troubleshoot on a smaller scale. Please let me know if I need to show anymore show commands. Thank you so much, I appreciate any help!
Solved! Go to Solution.
09-20-2024 08:21 AM
Hello,
You need to configure a static route for every network that's not connected to that router.
I would recommend just implementing a routing protocol to make your life easier unless the assignment is specific to you creating static routes only.
router eigrp 1
network 0.0.0.0 255.255.255.255
Hope this helps.
-David
09-20-2024 08:21 AM
Hello,
You need to configure a static route for every network that's not connected to that router.
I would recommend just implementing a routing protocol to make your life easier unless the assignment is specific to you creating static routes only.
router eigrp 1
network 0.0.0.0 255.255.255.255
Hope this helps.
-David
09-20-2024 08:26 AM
Hey David,
That worked, thank you so much! If you don't mind me asking, how exactly does this routing protocol work? Like what does "router eigrp 1" do?
Thank you again!
09-20-2024 08:59 AM
Routing protocols exchange routes. Simple as that. Now the mechanism in which they exchange routes is a bit more involved and complicated but essentially it does what static routes do on a more dynamic scale. For instance:
Your static route has a statement that says this network is out this interface (or next hop IP). A routing protocol will send information about it known routes to its neighbors and they exchange routing information. I just picked EIGRP but you could have used OSPF or RIP for Packet Tracer. Everyone has their likes/dislikes of the routing protocols, and each have their pros/cons in certain network designs.
router eigrp 1 <- turns on the EIGRP process and assigns it to Autonomous System 1 - this can be any # but they must match between router peers to form a neighbor adjacency.
network 0.0.0.0 255.255.255.255 <- this command enables EIGRP packets to be sent out interfaces in this range and it also advertises its interface networks to its neighbors.
Specifically 0.0.0.0 255.255.255.255 means all networks/interfaces.
There are way better resources on routing protocols than what I can explain here. You can try some CCNA level YouTube videos to help you better understand routing protocols. These are very involved protocols that require several chapters (and even whole books) written about them
-David
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide