cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4031
Views
0
Helpful
7
Replies

PPPoE on 1812 configuration problems

Hi,

I am configuring an 1812 for PPPoE and have struck a snag...

I am guessing it is a problem with the IOS version but according to the capability matrix it should work.

The IOS is advanced IP Services 12.4-6.T5

Router(config)# vpdn enable

Router(config)# vpdn-group 1

Router(config-vpdn)#request-dialin

Router(config-vpdn-req-in)#protocol pppoe

% PPPoE config from vpdn-group is converted to pppoe-profile based config.

% Continue PPPoE configuration under 'bba-group pppoe global'

Router(config-vpdn-req-in)#

and from there I am stuck as I can't find any config examples on the net for if this event happens.  Do I just need to upgrade the IOS or is this something else I need to just deal with. 

Any help greatfully accepted...

2 ACCEPTED SOLUTIONS

Accepted Solutions

Hi,

A basic configuration can be something like this

interface FastEthernet x/x

pppoe enable group global

pppoe-client dial-pool-number 1

interface Dialer1

ip address negotiated

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp chap hostname xxxxxxx

ppp chap password xxxxxxx

ip route 0.0.0.0 0.0.0.0 Dialer1

dialer-list 1 protocol ip permit

Hope this helps

Marco

View solution in original post

7 REPLIES 7

Gerald Vogt
Participant
Participant

Do you want to establish an incoming PPPoE connection to your router or a outgoing connection from your router?

Hi and thanks for the reply.

I am trying to establish a connection from my router to my ISP.  the ISP has given me an ethernet port to connect to and the PPPoE login details.

paolo bevilacqua
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

You don't need the vpdn commands for pppoe client.

Only the pppoe-client command is necessary.

Hi Paolo,

all the example config I found show using the VPDN so I thought that's what I needed.

I am trying to connect from my router to the ISP.  They has supplied a Mystery blackbox in our office andwith an ethernet port and instructions for PPPoE an obtaining an IPCP static IP.

But I don't know how to configure the router to connect to it.

An example would be helpful all the other examples I have found have led me to this point.

Hi,

A basic configuration can be something like this

interface FastEthernet x/x

pppoe enable group global

pppoe-client dial-pool-number 1

interface Dialer1

ip address negotiated

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp chap hostname xxxxxxx

ppp chap password xxxxxxx

ip route 0.0.0.0 0.0.0.0 Dialer1

dialer-list 1 protocol ip permit

Hope this helps

Marco

Thank you very much to Didier and Marc for very helpful responses.  Didier's worked perfectly.  I I trying to learn more about VPDN and why all the cisco examples say to use it but will do that as I need.

Thanks again for the excellent responses.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: