cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
685
Views
14
Helpful
3
Replies

PPPoE on an 831

mvoss
Level 1
Level 1

I have a remote facility with a DSL modem that can only do bridge mode, meaning all authentication with the ISP has to be done on the device behind it. I have the PPPoE username/password from the ISP and I'm wondering if it's possible to set up an 831 to do the authentication.

1 Accepted Solution

Accepted Solutions

cristianlinca
Level 1
Level 1

Hello is this config working?

Yesterday I ran into an issue and my home router is broken so I have to configure my ISP connection on this old 831 CISCO Router. Did some searching online and got here.

Can you please tell if you managed to make it work?

In the command below, what is that 0 after password?

ppp pap sent-username username@isp.com password 0 password

shouldn't be only?

ppp pap sent-username "myISPusername" password "myISPpassword"

I will try tonight and let you know the results if I get no answer till then.

Cheers and thanks for the post, seems helpful

Cristian

View solution in original post

3 Replies 3

Hello,

this should be possible. Here is a sample configuration for the 831, replace the username and password with the ones you have from your ISP:

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname 831

!

logging queue-limit 100

!

ip subnet-zero

ip dhcp excluded-address 192.168.1.1

!

ip dhcp pool LOCALPOOL

import all

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1

!

ip audit notify log

ip audit po max-events 100

no ftp-server write-enable

!

interface Ethernet0

description Inside private interface

ip address 192.168.1.1 255.255.255.0

ip nat inside

hold-queue 100 out

!

interface Ethernet1

description Connection to DSL Modem ISP

no ip address

ip tcp adjust-mss 1452

load-interval 30

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp pap sent-username username@isp.com password 0 password

!

ip nat inside source list 1 interface Dialer1 overload

ip classless

ip http server

no ip http secure-server

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

ip route 0.0.0.0 0.0.0.0 Dialer1

dialer-list 1 protocol ip permit

!

line con 0

no modem enable

stopbits 1

line aux 0

stopbits 1

line vty 0 4

login

!

scheduler max-task-time 5000

!

end

HTH,

GP

cristianlinca
Level 1
Level 1

Hello is this config working?

Yesterday I ran into an issue and my home router is broken so I have to configure my ISP connection on this old 831 CISCO Router. Did some searching online and got here.

Can you please tell if you managed to make it work?

In the command below, what is that 0 after password?

ppp pap sent-username username@isp.com password 0 password

shouldn't be only?

ppp pap sent-username "myISPusername" password "myISPpassword"

I will try tonight and let you know the results if I get no answer till then.

Cheers and thanks for the post, seems helpful

Cristian

Hi,

the keyword 0 is inserted in the running config and it means that the following value is the unencrypted value.

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Review Cisco Networking for a $25 gift card