cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1350
Views
0
Helpful
4
Replies

PPPoE on C881-K9 failing

DON BROWN
Level 1
Level 1

I have IOS version 157-3.M7 on C881 Router

Trying to connect PPPoE to ISP

Relevant Config ...

 

vpdn enable
!
vpdn-group 1

!

interface FastEthernet4
description NBN Connection to Internet
no ip address
ip nbar protocol-discovery
ip nat outside
ip virtual-reassembly in
duplex full
speed 100
pppoe enable group global
pppoe-client dial-pool-number 1
!

interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp pap sent-username @redacted>@redacted.com.au password 0 <password>

 

ip nat inside source list 22 interface FastEthernet4 overload
ip route 0.0.0.0 0.0.0.0 FastEthernet4

!

dialer-list 1 protocol ip permit

 

I have the following debugs active

 

PPP:
PPP authentication debugging is on
PPP protocol negotiation debugging is on
PPPoE:
PPPoE protocol events debugging is on

 

The debug is showing;

036361: *Sep 21 22:00:44.365: Sending PADI: Interface = FastEthernet4
036362: *Sep 21 22:00:56.429: PPPoE 0: I PADI R:2247.3292.89ee L:ffff.ffff.ffff Fa4
036363: *Sep 21 22:01:01.433: PPPoE 0: I PADI R:2247.3292.89ee L:ffff.ffff.ffff Fa4
036364: *Sep 21 22:01:11.445: PPPoE 0: I PADI R:2247.3292.89ee L:ffff.ffff.ffff Fa4
036365: *Sep 21 22:01:16.621: padi timer expired

 

PPPoE Session is not established

sh pppoe sess
1 client session

Uniq ID PPPoE RemMAC Port VT VA State
SID LocMAC VA-st Type
N/A 0 0000.0000.0000 Fa4 Di1 N/A PADISNT
0000.0000.0000

 

So no ip address has been negotiated on the dialer interface.

 

I have been going in circles with this for hours - what am I missing please.

 

 

4 Replies 4

Hello,

 

you need to use Dialer 1 as the outgoing interface. Configure the settings below (Vlan 1 IP address is assumed since you did not post your full config, make sure access list 1 matches whatever IP address space you are using on Vlan 1):

 

vpdn enable
!
vpdn-group 1
!
interface FastEthernet4
description NBN Connection to Internet
no ip address
ip nat outside
ip virtual-reassembly in
duplex full
speed 100
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp pap sent-username @redacted>@redacted.com.au password 0 <password>
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
ip nat inside source list 1 Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit
!
access-list 1 permit 192.168.1.0 0.0.0.255

Thank you for your suggestions - I have applied the changes you suggested but still am not getting PPPoE session established.

 

Please find current config below.

 

vpdn enable
!
vpdn-group 1
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface FastEthernet4
description NBN Connection to Internet
no ip address
ip nbar protocol-discovery
ip nat outside
ip virtual-reassembly in
duplex full
speed 100
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Vlan1
description $ETH_LAN$
ip address 10.1.1.77 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp pap sent-username <redacted> password 0 <redacted>
!
ip nat inside source list 22 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
ip ssh version 2
!
dialer-list 1 protocol ip permit
access-list 22 permit 10.1.1.0 0.0.0.255
access-list 23 permit 10.1.1.0 0.0.0.255

Debug logs

 

040116: *Sep 22 06:52:31.615: padi timer expired
040117: *Sep 22 06:52:31.615: Sending PADI: Interface = FastEthernet4
040118: *Sep 22 06:52:53.607: PPPoE 0: I PADI R:2247.3292.89ee L:ffff.ffff.ffff Fa4
040119: *Sep 22 06:52:58.611: PPPoE 0: I PADI R:2247.3292.89ee L:ffff.ffff.ffff Fa4
040120: *Sep 22 06:53:03.871: padi timer expired
040121: *Sep 22 06:53:03.871: Sending PADI: Interface = FastEthernet4
040122: *Sep 22 06:53:08.619: PPPoE 0: I PADI R:2247.3292.89ee L:ffff.ffff.ffff Fa4
040123: *Sep 22 06:53:36.126: padi timer expired
040124: *Sep 22 06:53:36.126: Sending PADI: Interface = FastEthernet4

 

Still no IP address negotiated for D1

 

Interface IP-Address OK? Method Status Protocol
Dialer1 unassigned YES NVRAM up up
FastEthernet0 unassigned YES unset down down
FastEthernet1 unassigned YES unset down down
FastEthernet2 unassigned YES unset down down
FastEthernet3 unassigned YES unset up up
FastEthernet4 unassigned YES NVRAM up up
NVI0 unassigned YES unset up up
Virtual-Access1 unassigned YES unset up up
Vlan1 10.1.1.77 YES NVRAM up up

Hello,

 

I have looked around, it is possible that you need a subinterface. Make the changes marked in bold:

 

vpdn enable
!
vpdn-group 1
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface FastEthernet4
description NBN Connection to Internet
no ip address
duplex auto
speed auto
!
interface FastEthernet4.2
encapsulation dot1q 2
pppoe-client dial-pool-number 1

!

interface Vlan1
description $ETH_LAN$
ip address 10.1.1.77 255.255.255.0
ip nat inside
ip virtual-reassembly in
ip tcp adjust-mss 1452
!
interface Vlan2
description --- NBN Logical Interface ---
bandwidth 20000
bandwidth receive 50000
no ip address
ip mtu 1460
ip nat outside
ip virtual-reassembly in
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp pap sent-username <redacted> password 0 <redacted>
!
ip nat inside source list 22 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
ip ssh version 2
!
dialer-list 1 protocol ip permit
access-list 22 permit 10.1.1.0 0.0.0.255
access-list 23 permit 10.1.1.0 0.0.0.255

Thank you for your suggestion.

 

When I first looked at the suggestions I did not think it would work but there have been many times something I did not think would work actually did so I made the changes.

 

Situation is still the same

Debug shows

040905: *Sep 22 08:44:35.365: padi timer expired
040906: *Sep 22 08:44:35.365: Sending PADI: Interface = FastEthernet4.2
040907: *Sep 22 08:44:35.365: PPPoE VLAN CoS (pppoe_client_send_padi)=>FastEthernet4.2 :: cos=0x0
040908: *Sep 22 08:45:07.624: padi timer expired
040909: *Sep 22 08:45:07.624: Sending PADI: Interface = FastEthernet4.2
040910: *Sep 22 08:45:07.624: PPPoE VLAN CoS (pppoe_client_send_padi)=>FastEthernet4.2 :: cos=0x0
040911: *Sep 22 08:45:39.880: padi timer expired
040912: *Sep 22 08:45:39.880: Sending PADI: Interface = FastEthernet4.2
040913: *Sep 22 08:45:39.880: PPPoE VLAN CoS (pppoe_client_send_padi)=>FastEthernet4.2 :: cos=0x0
040914: *Sep 22 08:46:12.136: padi timer expired
040915: *Sep 22 08:46:12.136: Sending PADI: Interface = FastEthernet4.2
040916: *Sep 22 08:46:12.136: PPPoE VLAN CoS (pppoe_client_send_padi)=>FastEthernet4.2 :: cos=0x0
040917: *Sep 22 08:46:44.403: padi timer expired
040918: *Sep 22 08:46:44.403: Sending PADI: Interface = FastEthernet4.2
040919: *Sep 22 08:46:44.403: PPPoE VLAN CoS (pppoe_client_send_padi)=>FastEthernet4.2 :: cos=0x0
040920: *Sep 22 08:47:16.659: padi timer expired

 

Still no ip address being assigned to dialer interface

 

Please advise

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card