cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1199
Views
5
Helpful
2
Replies
Emperor2000
Beginner

Problem with 1911 ISRG2 and 3G ehwic.

hello iam working on setting up a 1911 router with a EHWIC-3G-HSPA+7.

I have searched different guides for how to set this up.

Config looks like this.

chat-script hspa "" "AT!SCACT=1,1" TIMEOUT 60 "OK"

!

interface Loopback1

ip address 10.10.10.1 255.255.255.255

!

interface Cellular0/0/0

ip address negotiated

ip nat outside

ip virtual-reassembly in

encapsulation slip

dialer in-band

dialer string hspa

dialer-group 1

async mode interactive

!

ip route 0.0.0.0 0.0.0.0 Cellular0/0/0

!

dialer-list 1 protocol ip permit

!

line 0/0/0

exec-timeout 0 0

script dialer direct-ip

modem InOut

no exec

!

Router#sh cellular 0/0/0 all

Hardware Information

====================

Modem Firmware Version = T1_0_3_2AP R361 CNSZ

Modem Firmware built = 04/15/11

Hardware Version = 1.0

International Mobile Subscriber Identity (IMSI) = 240029803040651

International Mobile Equipment Identity (IMEI) = 357115040235926

Integrated Circuit Card ID (ICCID) = 8946071207220086210

Mobile Subscriber International Subscriber

IDentity Number (MSISDN) =

Factory Serial Number (FSN) = CC3157202581007

Modem Status = Online

Current Modem Temperature = 28 deg C, State = Normal

PRI SKU ID = 9900198, SKU Rev. = 1.2

Profile Information

====================

Profile 1 = INACTIVE*

--------

PDP Type = IPv4

Access Point Name (APN) = bredband.tre.se

Authentication = PAP

Username: '', Password: xx

Profile 16 = INACTIVE

--------

PDP Type = IPv4

Access Point Name (APN) = bredband.tre.se

Authentication = None

Username: , Password:

* - Default profile

Network Information

===================

Current Service Status = Normal, Service Error = None

Current Service = Combined

Packet Service = HSDPA (Attached)

Packet Session Status = Inactive

Current Roaming Status = Home

Network Selection Mode = Automatic

Country = SWE, Network = SWE

Mobile Country Code (MCC) = 240

Mobile Network Code (MNC) = 4

Location Area Code (LAC) = 2362

Routing Area Code (RAC) = 1

Cell ID = 23182

Primary Scrambling Code = 182

PLMN Selection = Automatic

Registered PLMN =  , Abbreviated =

Service Provider = 3

Radio Information

=================

Radio power mode = ON

Current Band = WCDMA 2100, Channel Number = 10638

Current RSSI = -97 dBm

Band Selected = Auto

Number of nearby cells = 1

Cell 1

        Primary Scrambling Code = 0xB6

        RSCP = -96 dBm, ECIO = -3 dBm

Modem Security Information

==========================

Card Holder Verification (CHV1) = Disabled

SIM Status = OK

SIM User Operation Required = None

Number of CHV1 Retries remaining = 3

However im unable to connect with ping

Router# ping 4.4.2.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 4.4.2.2, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Router#

When checing debug logs i find this.

Oct 14 14:12:13.687: Ce0/0/0 DDR: place call

Oct 14 14:12:13.687: Ce0/0/0 DDR: Dialing cause ip (s=10.10.10.1, d=8.8.4.4)

Oct 14 14:12:13.687: Ce0/0/0 DDR: Attempting to dial hspa

Oct 14 14:12:13.687: CHAT0/0/0: Attempting async line dialer script

Oct 14 14:12:13.687: CHAT0/0/0: no matching chat script found for hspa

Oct 14 14:12:13.687: CHAT0/0/0: Dialing using Modem script: d0efault-d0ials0cript & System script: none

Oct 14 14:12:13.687: CHAT0/0/0: process started

Oct 14 14:12:13.687: CHAT0/0/0: Asserting DTR

Oct 14 14:12:13.687: CHAT0/0/0: Chat script d0efault-d0ials0cript started

Oct 14 14:12:13.687: CHAT0/0/0: Sending string: ATZ

Oct 14 14:12:13.687: CHAT0/0/0: Expecting string: OK

Oct 14 14:12:13.699: CHAT0/0/0: Completed match for expect: OK

Oct 14 14:12:13.699: CHAT0/0/0: Sending string: AT

Oct 14 14:12:13.699: CHAT0/0/0: Expecting string: OK

Oct 14 14:12:13.711: CHAT0/0/0: Completed match for expect: OK

Oct 14 14:12:13.715: CHAT0/0/0: Sending string: ATDT\T<hspa>

Oct 14 14:12:13.715: CHAT0/0/0: Expecting string: CONNECT

Oct 14 14:12:13.715: CHAT0/0/0: Found abort string ERROR expecting CONNECT

Oct 14 14:12:13.715: CHAT0/0/0: Chat script d0efault-d0ials0cript finished, status = Connection aborted

Oct 14 14:12:13.715: TTY0/0/0: Line reset by "Async dialer"

Oct 14 14:12:13.715: Ce0/0/0 DDR: disconnecting call

Oct 14 14:12:13.715: TTY0/0/0: Modem: (unknown)->HANGUP

Oct 14 14:12:13.715: TTY0/0/0: no timer type 0 to destroy

Oct 14 14:12:13.715: TTY0/0/0: no timer type 1 to destroy

Oct 14 14:12:13.715: TTY0/0/0: no timer type 3 to destroy

Oct 14 14:12:13.715: TTY0/0/0: no timer type 4 to destroy

Oct 14 14:12:13.715: TTY0/0/0: no timer type 10 to destroy

Oct 14 14:12:13.715: TTY0/0/0: no timer type 2 to destroy

Oct 14 14:12:13.911: TTY0/0/0: dropping DTR, hanging up

Oct 14 14:12:13.911: tty0/0/0: Modem: HANGUP->IDLE

Oct 14 14:12:15.911: TTY0/0/0: restoring DTR

It seems that the string ATDT\T<hspa> dosent work.

Would be great with some helt regarding where to start troubleshooting.

1 ACCEPTED SOLUTION

Accepted Solutions
paolo bevilacqua
Hall of Fame Master

You need to use a valid chat-script name in 'dialer script'.

View solution in original post

2 REPLIES 2
paolo bevilacqua
Hall of Fame Master

You need to use a valid chat-script name in 'dialer script'.

View solution in original post

Ahhhh yes staging at the config made me blind. Works now thanks. :)