cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1615
Views
5
Helpful
2
Replies

QoS for Voice Example

Filip Knezevic
Level 1
Level 1

Hello,

 

I need a simple QoS that will reserve bandwidth for VOIP over L2VPN link.

One member posted this:

class-map match-all voice

match ip rtp 16384 16383-----> matches RTP audio or

Match access group name voice

 

ip access-list extended voice

permit udp 10.10.10.0 0.0.0.255 any eq range 16384 32767

 

class-map match-all voice-wan

match ip dscp ef

 

policy-map ingress

class voip

set ip dscp ef

 

policy-map WAN

class voice-wan

priority percent 25 ---(depends upon the BW u want to assign)

class class-default

fair-queue

 

interface fa0/1

service-policy input ingress

 

interface s0/0

sevice-policy output WAN

 

I think it is what I need but I have one question. If the egress interface is 1G interface but shaped to 5M by the provider, will the priority percent 25 command take into account whole 1G link or it will simply take 25 percent of available bandwidth?

In other words, do I need to set bandwidth on that link or this will work like this?

 

Thanks in advance!

1 Accepted Solution

Accepted Solutions

Hello
It would be suggested to shape your wan link to the committed access rate of you ISP , setting the bandwidth directly on the physical interface wouldn't actually change the line rate it would only be used by routing protocol for path calculation.

Bellow is a possible example of shaping you wan link at 5mb whilst providing 15% of low latency queuing for your voice traffic

The acl matches on common uidp/tcp voice and signaling ports

access-list 100 permit udp any any range 16384 32767
access-list 100 permit tcp any any eq 1720

class-map VOIP_cm
match access-group 100

policy-map VOIP_pm_child
class VOIP_cm
priority percent 15
class class-default
fair queue

policy-map VOIP_pm_parent
class class-default
shape average 5120000 bc 80000
service-policy VOIP_pm_child

 

int x/x
description WAN link
service-policy output VOIP_pm_parent


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

View solution in original post

2 Replies 2

Hello
It would be suggested to shape your wan link to the committed access rate of you ISP , setting the bandwidth directly on the physical interface wouldn't actually change the line rate it would only be used by routing protocol for path calculation.

Bellow is a possible example of shaping you wan link at 5mb whilst providing 15% of low latency queuing for your voice traffic

The acl matches on common uidp/tcp voice and signaling ports

access-list 100 permit udp any any range 16384 32767
access-list 100 permit tcp any any eq 1720

class-map VOIP_cm
match access-group 100

policy-map VOIP_pm_child
class VOIP_cm
priority percent 15
class class-default
fair queue

policy-map VOIP_pm_parent
class class-default
shape average 5120000 bc 80000
service-policy VOIP_pm_child

 

int x/x
description WAN link
service-policy output VOIP_pm_parent


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Thank you, Paul.

In my case, it's a communication between two offices on a separate port (L2VPN). So in your example I wouldn't use my WAN interface, but my L2VPN interface?

Also, on top of L2VPN provided by ISP, GRE over IPSec is configured. Is that an issue for your example?

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: