cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
844
Views
0
Helpful
8
Replies

QoS Marking

cloudlogics
Level 1
Level 1

I have a basic QoS policy where I am trying to remark packets as they are coming in. It looks like my classification is working but remarking is not. This is my configuration

 

class-map match-any CM_REALTIME_WAN
match dscp ef
class-map match-any CM_BUSINESSCRITICAL_WAN
match dscp cs5
match dscp cs4
match dscp cs3
match dscp cs2
match dscp cs7
match dscp cs6
match dscp af43
match dscp af41
match dscp af42
match dscp af32
match dscp af33
match dscp af31
class-map match-any CM_BULK_WAN
match dscp cs1
match dscp af12
match dscp af13
match dscp af11
match dscp af23
match dscp af21
match dscp af22

policy-map PM_TEST
class CM_REALTIME_WAN
set ip precedence 5
class CM_BUSINESSCRITICAL_WAN
set ip precedence 3
class CM_BULK_WAN
set ip precedence 2
class class-default

R2#sh policy-map interface e0/0
..... output omitted .....
Class-map: CM_BUSINESSCRITICAL_WAN (match-any)
9 packets, 946 bytes
Match: dscp cs6 (48)
4 packets, 376 bytes
5 minute rate 0 bps
Match: dscp af43 (38)
5 packets, 570 bytes
5 minute rate 0 bps
QoS Set
ip precedence 3
Packets marked 0

8 Replies 8

Hello,

 

what device (e.g. 3850) is this configured on ?

It is c9500 but I am getting same issue on iol in eve-ng. Something very basic is missing i suppose. 

Joseph W. Doherty
Hall of Fame
Hall of Fame

I see "Packets marked 0", but you're sure packets are actually not being marked?

In a later reply, you also note, this is on a c9500.  I'm not current on those switches, but in the past, some Catalyst switches had interesting "quirks" compared to routers, as in device might not actually support marking in an egress policy, requiring such be done in the ingress policy (or possible the converse).

BTW, you do realize IP precedence is the first 3 bits of ToS byte, while DSCP is the first 6 bits?  I.e. setting, for example, CS2, AF21, AF22 and AF23 to IPPrec 3, should create CS3, AF31, AF32 and AF33, respectively.

BTW, you might "shorten" your matching, when, for example:

class-map match-any CM_BUSINESSCRITICAL_WAN
.
.
class-map match-any CM_BULK_WAN
.
.

Might (I think?) be replaced by:

class-map match-any CM_BUSINESSCRITICAL_WAN
match dscp cs2 cs5 cs6 cs7
match ip precedence 3 4
class-map match-any CM_BULK_WAN
match ip precedence 1 2

Thanks Joseph!

I have tried to apply the policy on both ingress and egress interfaces but still the same. I know packets are not being marked as I have a further upstream device where I ran the debug that still shows pre-policy markings.

I am using IP precedence as I am handing over traffic to MPLS so I have 1:1 relation though I understand setting DSCP can work as well.

Basically I am trying to classify LAN traffic to a 4 queue MPLS model. 

Okay, you've tried policy both ingress and egress interfaces, but those are connected to what and policy application was as ingress, egress or both, on those ingress and egress interfaces?

Ingress interface connects to a local sites (3560) while Egress connects to another C9500. On Ingress I applied the poilcy inbound (service policy input [Pol name]) and on Egress I applied the policy outbound (service-policy output [Pol Name]).

What I wanted to do was to apply Application QoS with a (4 queue) service provider profile through DNAC. Unfortunatly SP profile is only supported on the router platform only so I have applied Application QoS on 3560. As 3560 don't support outbound policy, I wanted to remark the traffic on the PE switch instead on the Ingress interface and then apply queing on PE-P interface based on those markings.  

On your 3560, QoS is enabled?  And if so, you either trust or use an ingress service policy?

sorry been busy with another project. Yes, I already have the ingress service policy but it is not working. Ingress policy is on c9500 interface connecting to 3560

 

3560CX (CE) --> c9500 (PE) --> c9500 (P)

 

class-map match-any CM_BULK
match dscp cs1
match dscp af12
match dscp af13
match dscp af11
match dscp af23
match dscp af21
match dscp af22
class-map match-any CM_REALTIME
match dscp ef
class-map match-any CM_BUSINESSCRITICAL
match dscp af43
match dscp af41
match dscp af42
match dscp af32
match dscp af33
match dscp af31
class-map match-any default

 

 

policy-map PL_QOS
class CM_REALTIME
set dscp ef
class CM_BUSINESSCRITICAL
set dscp af31
class CM_BULK
set dscp af21
class class-default

 

interface Ethernet0/0
no switchport
ip address 10.1.1.2 255.255.255.252
ip ospf 1 area 0
service-policy input PL_QOS

 

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card