cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5071
Views
22
Helpful
23
Replies

QoS on an ADSL link

nir.fisher
Level 1
Level 1

hi ,

I have question regarding bandwidth reservation on a cisco 837 router with an adsl link to the internet

I have 4 stations connected to the switchports on the router and I want to reserve bandwidth for 2 stations out of the 4

I created a class-map to identify the source mac-addresses of these stations and then created a policy-map to reserve
bandwidth

I applied the service policy under the ethernet 0 interface which is the logical interface connected to the switchports of the router

I am asking basically , if what I did has any effect or should I apply this policy elsewhere , suppose on the ATM interface or on the dialer Interface

Is there any best practice on how to implement this kind of a solution ( and where is it best to apply it ? on which interface ?)

thanks

23 Replies 23

o.k so let me understand , I am using QoS on the dialer interface to control bandwidth for the upload traffic as shown in the config below

is there any reason I should change the bandwidth on the interface ? I also added a "sh interface" output below

and about shaping , will it benefit me if I apply what you suggested before on the incoming traffic from the internet?

======

ip dhcp pool pool1
   import all
   network x.x.x.x 255.255.255.0
   default-router x.x.x.x
   dns-server x.x.x.x
   lease infinite
!
class-map match-all shob-stations1
match source-address mac aaaa.bbbb.cccc
match source-address mac aaaa.bbbb.cccc
class-map match-any station-traffic
match  dscp af41
!
!
policy-map mark-shob
class shob-stations1
  set dscp af41
policy-map QoS_upload
class station-traffic
!

interface Ethernet0
ip address x.x.x.x 255.255.255.0
ip nat inside
ip virtual-reassembly
service-policy input mark-shob
load-interval 30
no cdp enable
hold-queue 1000 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
pvc 8/48
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly
service-policy output QoS_upload
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp pap sent-username xxxxx
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
no ip http secure-server

ip nat inside source list 100 interface Dialer0 overload

access-list 100 permit ip any any
!
dialer-list 1 protocol ip permit

======

ip dhcp pool pool1
   import all
   network x.x.x.x 255.255.255.0
   default-router x.x.x.x
   dns-server x.x.x.x
   lease infinite
!
class-map match-all shob-stations1
match source-address mac aaaa.bbbb.cccc
match source-address mac aaaa.bbbb.cccc
class-map match-any station-traffic
match  dscp af41
!
!
policy-map mark-shob
class shob-stations1
  set dscp af41
policy-map QoS_upload
class station-traffic
!

interface Ethernet0
ip address x.x.x.x 255.255.255.0
ip nat inside
ip virtual-reassembly
service-policy input mark-shob
load-interval 30
no cdp enable
hold-queue 1000 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
pvc 8/48
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly
service-policy output QoS_upload
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp pap sent-username xxxxx
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
no ip http server
no ip http secure-server

ip nat inside source list 100 interface Dialer0 overload

access-list 100 permit ip any any
!
dialer-list 1 protocol ip permit

Router-837-cisco#sh interface dialer0
Dialer0 is up, line protocol is up (spoofing)
  Hardware is Unknown
  Internet address is x.x.x.x
  MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 9/255
  Encapsulation PPP, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 1 seconds on reset
  Interface is bound to Vi2
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 7w0d
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/0/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 42 kilobits/sec
  5 minute input rate 2000 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     40032294 packets input, 4213327940 bytes
     35539923 packets output, 672944349 bytes
Bound to:
Virtual-Access2 is up, line protocol is up
  Hardware is Virtual Access interface
  MTU 1500 bytes, BW 56 Kbit, DLY 100000 usec,
     reliability 255/255, txload 1/255, rxload 4/255
  Encapsulation PPP, LCP Open
  Open: IPCP
  PPPoATM vaccess, cloned from Dialer0
  Vaccess status 0x44
  Bound to ATM0 VCD: 1, VPI: 8, VCI: 48, loopback not set
  Keepalive set (10 sec)
  DTR is pulsed for 5 seconds on reset
  Interface is bound to Di0 (Encapsulation PPP)
  Last input 00:00:24, output never, output hang never
  Last clearing of "show interface" counters 7w0d
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 1000 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     40032659 packets input, 4213509236 bytes, 26 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     35540322 packets output, 672979372 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions

========

by the way do I need to change the  Queueing strategy ?

thanks for the efforts , really appriciate it.

Correct me if I'm wrong, but it appears that you mark certain traffic, and thats it.

Hi,

First your class-map:

class-map match-all shob-stations1
match source-address mac aaaa.bbbb.cccc
match source-address mac aaaa.bbbb.cccc

is wrong. You cannot have a packet witch comes frome two hosts at the same time. Your class-map must be match-any!!!

After that on policy-map QoS_upload you have not defined what bandwidth (for upload) you want to be guaranteed. If you want 256 kbit/s then you have to add:

policy-map QoS_upload
class station-traffic

  bandwidth 256

!!!There is no reason to change bandwidth of the interface!!! It will NOT help you to limit or to make qos for the traffic.

You can read more about the bandwidth command here http://articles.techrepublic.com.com/5100-10878_11-6093972.html

Now you have done with configuring upload QoS.  As I said before, you have not pretty much choices for the download traffic. As I understand you need prioritization for some hosts, so you cannot do anything about it.

you are right about the class-map , honest mistake...

but about the bandwidth configuration as I understand I have 2 choices , either configure the actual bandwidth like you suggested or the second way is

to reserve a bandwidth precent , like I have configured

class-map match-any shob-stations1
match source-address mac aaaa.bbbb.cccc
match source-address mac aaaa.bbbb.cccc
class-map match-any station-traffic
match  dscp af41
!
!
policy-map mark-shob
class shob-stations1
  set dscp af41
policy-map QoS_upload
class station-traffic

bandwidth percent 50
!

do you see any problem with that ?

I would put the policy on the pvc, not on the dialer.

but you'll need to tell the router the pvc is vbr-nrt for this to work.

what is the benefit of doing that?

my experience is that qos on the dialer basically doesn't work.

qos on the pvc does, but you need to tell the router it's a pvc with guaranteed bandwidth for it to be willing

to use qos on it. so something like:

vbr-nrt 448 448

in my case since my adsl is 448 outbound

then

service-policy out myqospolicy

(This is the way Cisco press books say to do it, by the way)

thanks everybody for greate tips

anybody has useful verification commands for this config ?

and do

tx-ring-limit 3

on the pvc if you haven't already

Review Cisco Networking for a $25 gift card