02-09-2006 08:56 AM - edited 03-03-2019 11:42 AM
hello everybody,
I have applied some commmand lines in my remote router to reserve a dedicated bandwidth to my voice services:
This is the information.
<IP PHONE>--(CAMPUS_ROUTER)---(WAN)---(REMOTE_ROUTER)F0/0--<IP PHONE>
MAX. WAN BW=1MB (between CAMPUS_R and REMOTE_R)
the Main service is IP Telephony.
I want a dynamic behaviour of Voice Bandwidth:
-minimun voice BW = 256K
-Maximun voice BW = 512K (this should have a variable behaviour, if there is no calls, I dont need to reserve those 512K)
-DATA IP range: 172.30.48.0 255.255.248.0
-VOICE IP range: 172.17.216.0 255.255.248.0
THIS IS MY router configuration:
ip access-list extended VOICE
permit ip 172.17.216.0 0.0.7.255 any
class-map match-all VOICE
match access-group name VOICE
policy-map WAN
class VOICE
priority 256
class class-default
fair-queue
policy-map MAX512
class class-default
shape average 512000
service-policy WAN
interface FastEthernet0/0
description TO_WAN
ip address 10.8.86.90 255.255.255.248
service-policy output MAX512
load-interval 30
speed 10
full-duplex
interface FastEthernet0/1
description TO_LAN
no ip address
no ip redirects
no ip proxy-arp
load-interval 30
speed 100
full-duplex
no cdp enable
!
interface FastEthernet0/1.1
description VLAN DATOS
encapsulation dot1Q 1 native
ip address 172.30.16.1 255.255.248.0
no ip redirects
no ip proxy-arp
!
interface FastEthernet0/1.2
description VLAN VOICE
encapsulation dot1Q 2
ip address 172.17.216.1 255.255.248.0
no ip redirects
no ip proxy-arp
FRIENDS, IS MY CONFIGURATION RIGTH?
hoping recomendation?
WALTER MUNGUIA MARTINEZ
SAN MARCOS UNIVERSITY
LIMA-PERU
02-09-2006 12:21 PM
Hi,
You indicated that you only wanted your voice traffic to be limited to a maximum of 512k, but that your WAN link was 1Mbps. With your current config, the maximum traffic you will get out of the WAN is 512k, inclusive of both voice and data.
You could do the following to get 1Mbps out of the WAN link while capping your voice traffic to 512k.
policy-map WAN
class VOICE
priority 256
police 512000 64000
class class-default
fair-queue
policy-map MAX1024
class class-default
shape average 1024000
service-policy WAN
interface FastEthernet0/0
description TO_WAN
ip address 10.8.86.90 255.255.255.248
service-policy output MAX1024
load-interval 30
speed 10
full-duplex
Hope that helps - pls rate the post if it does.
Paresh
02-09-2006 01:11 PM
your policy map WAN is only prioritizing 256k for voice. If you change the priority to 512, then the map will prioritize voice traffic up to 512k. But I am not sure how the MAX512 map works with the WAN service policy added. It would appear that you are limiting all traffic to a shaped 512k. So if you policy map read
policy-map WAN
class VOICE
priority 512
class class-default
shape average 512000
fair-queue
And then apply the WAN as a service policy going out your wan interface. Be aware you are only controling traffic in one direction with this settup! You need to do the same at both ends to control traffic in both directions
GENE
02-10-2006 12:17 PM
PARESH,
You indicated that the maximum traffic I will get out of the WAN is 512k (voice and data).
Does it mean that 1MB of BW is not real? I have to discuss this with my IP DATA Service Provider!
I am attaching a picture of the network and also the Main configuration of both Routers: CAMPUS_ROUTER and REMOTE_ROUTER.
could you tell me if I really have 1MB? I want to be sure about that.
Thanks.
****************************
GENE,
So changing the priority to 512 I will prioritize voice traffic up to 512k.
My IP DATA service provider told me that they made the BW upgrade sucefully in my link.
It is supposed that I have up to 1MB BW (voice and data)
and voice BW should have up to 512KB reserved. but at the same time it should have a dynamic bahaviour. (min voice BW = 256KB)
THANKS IN ADVANCE FRIENDS.
02-10-2006 03:05 PM
Howdy,
That is not quite what I meant. I have no doubts that you have a full 1Mbps connection from your provider. I was just stating that your configuration of the remote router would limit the bandwidth.
Now, looking at your original requirments:
-minimun voice BW = 256K
-Maximum voice BW = 512K (this should have a variable behaviour, if there is no calls, I dont need to reserve those 512K)
I can see that the configuration you have got will not satisfy this.
Here is how I would do it:
CAMPUS ROUTER:
policy-map WAN-CID
class VOICE-CID
priority 256
police 512000 32000
class class-default
fair-queue
!
REMOTE ROUTER:
policy-map WAN
class VOICE
priority 256
police 512000 32000
class class-default
fair-queue
!
policy-map MAX1024
class class-default
shape average 1000000
service-policy WAN
!
interface FastEthernet0/0
description TO_WAN
ip address 10.8.86.90 255.255.255.248
service-policy output MAX1024
load-interval 30
speed 10
full-duplex
!
If you change the policies tothe above, you get the following:
- max throughput of 1 Mbps
- min voice bandwidth of 128k
- max voice bandwidth of 256k
Pls do try it out and let us know how you go.
Do remember to rate posts.
Paresh
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide