cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1503
Views
0
Helpful
2
Replies

Resiliency with static mroutes

Hi Friends

I am trying to setup multicast over GRE tunnels between a pair of Hub routers to a spoke router. These are connected over an MPLS network that does not support multicast. The requirement is to have unicast work normally via MPLS and use CE to CE GRE tunnels only for multicast traffic. Multicast works fine when I create the GRE tunnel from the spoke to only one of the Hub routers and use a static default mroute pointing to Tunnel interface. But when I create a backup tunnel to a second Hub router, multicast is not working.

Since we can configure only one static mroute to 0.0.0.0 in Cisco IOS, I am using following workaround configuration on the Spoke router

!

interface Tunnel100

description To primary Hub router

ip address 100.64.0.213 255.255.255.252

ip pim sparse-mode

keepalive 2 3

tunnel source 100.64.0.211

tunnel destination 100.64.0.210

!

interface Tunnel200

description To secondary Hub router

ip address 100.64.0.230 255.255.255.252

ip pim sparse-mode

keepalive 2 3

tunnel source 100.64.0.225

tunnel destination 100.64.0.226

!

ip mroute 0.0.0.0 0.0.0.0 1.1.1.1

!

ip route 1.1.1.1 255.255.255.255 100.64.0.214 200

ip route 1.1.1.1 255.255.255.255 100.64.0.229 210

!

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 192.188.32.1 200 (192.188.32.1 is WAN IP towards MPLS cloud)

!

ip pim rp-address 100.64.0.209

However, when I do an RPF check for the Source or RP address, it fails.

#show ip rpf 100.64.0.209

failed, no route exists

RPF check only succeeds for the Tunnel IPs

#show ip rpf 100.64.0.214

RPF information for ? (100.64.0.214)

  RPF interface: Tunnel100

  RPF neighbor: ? (100.64.0.214) - directly connected

  RPF route/mask: 100.64.0.212/30

  RPF type: multicast (connected)

  Doing distance-preferred lookups across tables

  RPF topology: ipv4 multicast base

#

Need to troubleshoot why RPF is failing here.

This configuration is supposed to work as per

ftp://ftpeng.cisco.com/ipmulticast/config-notes/gre-tunnel.txt

Please advise

Thanks

Everyone's tags (3)
2 REPLIES 2
Highlighted
Beginner

Resiliency with static mroutes

hi

are you using mroute with tunnel interface as outgoing on other routers?

regards

shivlu jain

Resiliency with static mroutes

Yes Shivlu. But it does not matter since I am only looking to solve the RPF failure issue which is local to the spoke router. It is expected that  RPF check for RP address 100.64.0.209 should point to the Tunnel100 interface but it is failing instead. I also noticed some errors in the log messages of the spoke router when I do an RFP check

*Feb 13 14:27:15.296: %IPMCAST_RPF-4-RPF_LOOKUP_LOOP: RPF route lookup loop for 100.64.0.209

I can also see mpackets are coming in via Primary Hub router into the spoke but are getting dropped due to RPF check failure

*Feb 13 14:41:21.528: MFIBv4(0x0): Receive (100.64.0.218,239.192.4.130) from Tunnel100 (FS): hlen 5 prot 1 len 100 ttl 254 frag 0x0  

*Feb 13 14:41:21.528: MFIBv4(0x0): Pkt (100.64.0.218,239.192.4.130) from Tunnel100 (FS) Entry IC set, punting

*Feb 13 14:41:21.528: MFIBv4(0x0): Receive (100.64.0.218,239.192.4.130) from Tunnel100 (PS): hlen 5 prot 1 len 100 ttl 254 frag 0x0  

*Feb 13 14:41:21.528: MFIBv4(0x0): Pkt (100.64.0.218,239.192.4.130) from Tunnel100 (PS) Acceptance check failed - dropping

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards