cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
348
Views
0
Helpful
10
Replies

Route problem

Lost & Found
Explorer
Explorer

Hi,

From site a I can't ping Site B router 3(10.34.63.59) but I can ping R2 of site B switch and workstation.

Details:

from Site A R1

IP Route  10.0.0.0/8 is variably subnetted, 7 subnets, 4 masks
C       10.34.34.0/30 is directly connected, Tunnel3
C       10.34.16.0/20 is directly connected, FastEthernet0/1
O       10.34.112.0/24 [110/3] via 10.47.250.78, 01:25:16, Port-channel1
O       10.34.64.0/24 [110/2] via 10.47.250.78, 01:25:16, Port-channel1
O       10.34.80.0/24 [110/3] via 10.47.250.78, 01:25:16, Port-channel1
C       10.47.240.0/20 is directly connected, Port-channel1
C       10.34.255.1/32 is directly connected, Loopback0
S*   0.0.0.0/0 [1/0] via 10.47.250.78

Trace Route from R1

 1 10.47.250.78 8 msec 8 msec 4 msec
 2  *  *  *
 3  *  *  *
 4  *  *  *
 5  *  *  *

From Site B R2

Ip Route 10.0.0.0/8 is variably subnetted, 8 subnets, 4 masks
O       10.34.34.0/30 [110/1001] via 10.47.250.77, 00:23:47, Port-channel1
C       10.34.48.0/20 is directly connected, GigabitEthernet0/0
O       10.34.16.0/20 [110/2] via 10.47.250.77, 00:23:47, Port-channel1
O       10.34.112.0/24 [110/2] via 10.34.64.3, 00:23:47, GigabitEthernet0/1
C       10.34.64.0/24 is directly connected, GigabitEthernet0/1
O       10.34.80.0/24 [110/2] via 10.34.64.2, 00:23:47, GigabitEthernet0/1
C       10.47.240.0/20 is directly connected, Port-channel1
O       10.34.255.1/32 [110/2] via 10.47.250.77, 00:23:47, Port-channel1
S*   0.0.0.0/0 [1/0] via 10.34.63.59

How can I ping R3 of Site B from Site A.

Tried to add new OSPF network but it didnt work,

Please see the attached photo.

thanks

10 Replies 10

ipcruiser81
Beginner
Beginner

Hi,

R2 doesn't appear to have a route to R3.

Can you ping R3 from R2?

1) maybe you've misconfigured Gi0/1 on R2. Gi0/1 should be configured for 10.34.63.254/24?

2) make sure OSPF is advertising 10.34.63.0/24 network from R2.

Rgds

 

Yes from r1 i can ping r2 vise versa.

from site a

R1: added network 10.34.31.0 0.0.15.255 area 5

 

from site b

R2: added network 10.34.63.0 0.0.15.255 area 5

but upon check on ip route it still the same there no route

should I run the cmd clear ip ospf process?

 

Hi,

Ok R1 can ping R2 which is good, but can R2 ping R3?

Also the network statement network 10.34.63.0 0.0.15.255 area 5 is to advertise 10.34.48.0/28 network which appears to be incorrect according to the diagram provided.

Can you confirm the network address (with mask) between R2 and R3 for me please?

Rgds

yes r2 can ping r3.

also correct i will advertise 10.34.40.0/20 for site B and for site 10.34.16.0/20.

IP address of

R1: 10.34.31.253 255.255.240.0

R2: 10.34.63.254 255.255.240.0

Ok if R2 can ping R3, apply the following statement on R2 under the OSPF process.

network  10.34.48.0  0.0.15.255  area  5

then, clear ip ospf process on R2 (not necessary but am not sure of other changes you may have made on R2)

after that, try pinging R3 from R1 and see if it works.

If that doesnt work, paste the routing table of R1 and R2 again please.

let me know.

 

Hi,

Let me just verify. i added 10.34.63.0 /24 equivalent to 10.34.48.0 on R2.

so network  10.34.48.0  0.0.15.255  area  5 on r2 its still the same.

what if i add it to R3?

what do you think?

 

thanks

R2 ip address you have provided is: 10.34.63.254/20

So you should add the following network statement in ospf on R2:

'network 10.34.48.0 0.0.15.255 area 5' which will cover above R2 IP address.

If there is OSPF running between R2 and R3 then yes you will need to add the above network statement on R3 also. Otherwise it is not needed.

 

network  10.34.48.0  0.0.15.255  area  5
network  10.34.48.0  0.0.15.255  area  5

Hi,

Did this work out in the end?

Regards

correction on this response: network 10.34.63.0 0.0.15.255 area 5 is to advertise 10.34.48.0/20 network not /28 network. apologies.

Rolf Fischer
Engager
Engager

Perhaps R3 just doesn't know how to reach the source network of R1's ICMP requests.

Couple of things to check:

Has R2 an OSPF adjacency to R3 (I don't see OSPF routes with next-hop Gi0/0 in R2's routing-table)? Can you post the output of 'show ip ospf neighbor Gi0/0' from R2?

As far as I can see, Po1 (10.47.240.0/20) is the common subnet between R1 and R2.

Can you ping R3 from R2 with Po1's IP as source (R2# ping 10.34.63.59 source Po1)?

If so, try the same on R1 (R1# ping 10.34.63.59 source Po1).

 

HTH

Rolf

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers