09-16-2020 10:50 AM
i have to migrate functionality from one router to another.
want to reuse the complete config as-is, meaning copy the interface and hsrp config from old router to new router, on an existing interface.
end result will be an interface on new router, with two ip addresses. both primary and secondary ip addresses will be in the same subnet. is that ok?
09-16-2020 11:42 AM
It should be ok technically, but I have seen some issue on nexus devices, it can not ARP the second IP address. when i was doing vPC..
please provide relevant config to suggest better.
09-16-2020 12:11 PM
it will look something like this eventually, on one of the routers
interface GigabitEthernet0/0/1 ip address 10.10.10.4 255.255.255.0 ip address 10.10.10.10 255.255.255.0 secondary standby 50 ip 10.10.10.2 standby 50 preempt standby 100 ip 10.10.10.3 standby 100 preempt
09-16-2020 01:39 PM
Hello,
with that configuration, both HSRP groups will select the primary IP addresses as active and standby routers, not the secondaries. If you want both HSRP groups to function independently, you need the primary and secondary IP addresses to be in different subnets.
R1
interface GigabitEthernet0/0
ip address 10.10.10.10 255.255.255.0 secondary
ip address 10.10.10.4 255.255.255.0
standby 50 ip 10.10.10.2
standby 50 preempt
standby 100 ip 10.10.10.3
standby 100 preempt
R1#sh standby
GigabitEthernet0/0 - Group 50
State is Active
11 state changes, last state change 00:15:20
Virtual IP address is 10.10.10.2
Active virtual MAC address is 0000.0c07.ac32
Local virtual MAC address is 0000.0c07.ac32 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 1.584 secs
Preemption enabled
Active router is local
Standby router is 10.10.10.5, priority 100 (expires in 9.120 sec)
Priority 100 (default 100)
Group name is "hsrp-Gi0/0-50" (default)
GigabitEthernet0/0 - Group 100
State is Active
2 state changes, last state change 00:15:37
Virtual IP address is 10.10.10.3
Active virtual MAC address is 0000.0c07.ac64
Local virtual MAC address is 0000.0c07.ac64 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 1.040 secs
Preemption enabled
Active router is local
Standby router is 10.10.10.5, priority 100 (expires in 10.064 sec)
Priority 100 (default 100)
Group name is "hsrp-Gi0/0-100" (default)
R2
interface GigabitEthernet0/0
ip address 10.10.10.11 255.255.255.0 secondary
ip address 10.10.10.5 255.255.255.0
standby 50 ip 10.10.10.2
standby 100 ip 10.10.10.3
R2#sh standby
GigabitEthernet0/0 - Group 50
State is Standby
9 state changes, last state change 00:04:01
Virtual IP address is 10.10.10.2
Active virtual MAC address is 0000.0c07.ac32
Local virtual MAC address is 0000.0c07.ac32 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 2.304 secs
Preemption enabled
Active router is 10.10.10.4, priority 100 (expires in 10.896 sec)
Standby router is local
Priority 100 (default 100)
Group name is "hsrp-Gi0/0-50" (default)
GigabitEthernet0/0 - Group 100
State is Standby
4 state changes, last state change 00:03:59
Virtual IP address is 10.10.10.3
Active virtual MAC address is 0000.0c07.ac64
Local virtual MAC address is 0000.0c07.ac64 (v1 default)
Hello time 3 sec, hold time 10 sec
Next hello sent in 1.152 secs
Preemption enabled
Active router is 10.10.10.4, priority 100 (expires in 8.320 sec)
Standby router is local
Priority 100 (default 100)
Group name is "hsrp-Gi0/0-100" (default)
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide