cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
235
Views
25
Helpful
6
Replies
Highlighted
Beginner

Setting up OSPF Neighbours

Hi,

I'm trying to connect two routers using OSPF, but when issuing a 'sh ip ospf neighbor' the two are not showing as neighbours. Could someone offer some insight as to why this may be?

 

Here are the configurations for both routers:

R1:

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0/0

ip address 198.222.123.18 255.255.255.0

!

interface Serial0/0/1

no ip address

clock rate 2000000

shutdown

!

interface Vlan1

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

network 198.222.123.0 0.0.0.15 area 0

!

ip classless

ip route 0.0.0.0 0.0.0.0 Loopback0

!

 

R2:

interface Serial0/0/0

ip address 198.222.123.17 255.255.255.240

clock rate 128000

!

interface Serial0/0/1

no ip address

clock rate 2000000

shutdown

!

interface Vlan1

no ip address

shutdown

!

router ospf 1

log-adjacency-changes

network 198.222.123.0 0.0.0.15 area 0

network 10.1.1.0 0.0.0.3 area 0

!

ip classless

!

 

I'm pretty inexperienced with this, so I apologise if it's something super simple. 

Thank you in advance

-Stuart

 

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Participant

Re: Setting up OSPF Neighbours

first off, you're using addresses on a different subnet than is defined, and on R1, the mask on s0/0/0 is wrong. What I would suggest is:

R1

interface Serial0/0/0

ip address 198.222.123.18 255.255.255.240

!

router ospf 1

network 198.222.123.16 0.0.0.15 area 0

 

R2

router ospf 1

network 198.222.123.16 0.0.0.15 area 0

 

and see what happens. You can always run a debug right now and see what falls out.

6 REPLIES 6
VIP Advisor

Re: Setting up OSPF Neighbours

Hello

Do you have reach ability between the two rtrs looks?
interface Serial0/0/0
ip address 198.222.123.18 255.255.255.0

R1
int Serial0/0/0
ip address 198.222.123.18 255.255.255.0  <---incorrect mask


router ospf 1
no network 198.222.123.0 0.0.0.15 area 0
network 198.222.123.18 0.0.0.0 area 0


R2
int Serial0/0/0
ip address 198.222.123.17 255.255.255.240  <---incorrect mask
router ospf 1
no network 198.222.123.0 0.0.0.15 area 0
network 198.222.123.17 0.0.0.0 area 0

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Participant

Re: Setting up OSPF Neighbours

first off, you're using addresses on a different subnet than is defined, and on R1, the mask on s0/0/0 is wrong. What I would suggest is:

R1

interface Serial0/0/0

ip address 198.222.123.18 255.255.255.240

!

router ospf 1

network 198.222.123.16 0.0.0.15 area 0

 

R2

router ospf 1

network 198.222.123.16 0.0.0.15 area 0

 

and see what happens. You can always run a debug right now and see what falls out.

Participant

Re: Setting up OSPF Neighbours

remember that when it comes to IGPs, the hellos are sent out on any interface that falls within the defined network range. Since you have it defined as subnet zero, but your interfaces addressed on subnet.16, it won't send out any hellos at all.

Rising star

Re: Setting up OSPF Neighbours

interface Serial0/0/0

ip address 198.222.123.18 255.255.255.0

network 198.222.123.0 0.0.0.15 area 0

 

 

R2:

interface Serial0/0/0

ip address 198.222.123.17 255.255.255.240

clock rate 128000

 

They dont stay at the same network.   

 

Jaderson Pessoa
*** Rate All Helpful Responses ***
Advocate

Re: Setting up OSPF Neighbours

Hi @Stuart D ,

 

In R1 correct this:

 

R1(config)# interface Serial0/0/0

R1(config-if)# no ip add

R1(config-if)# ip address 198.222.123.18 255.255.255.240

 

Surely it was a typo error when entering the mask in that interface

 

Regards

Beginner

Re: Setting up OSPF Neighbours

Thanks everyone for your help! All sorted now, that had me pulling my hair out all afternoon! 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards