cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1837
Views
5
Helpful
4
Replies

SSH is not working in Ubuntu /Windows CMD prompt

Cisconew
Beginner
Beginner

Hi,

I am able to SSH my Router (Physical Device/1841) via Putty terminal.

But not able do it through Ubuntu terminal/Windows CMD prompt.

Please find below Show SSH output for reference.

 

Router-1841#sh ssh
Connection Version Mode Encryption Hmac State Username
0 2.0 IN aes256-cbc hmac-sha1 Session started jason
0 2.0 OUT aes256-cbc hmac-sha1 Session started jason
%No SSHv1 server connections running.

Also, please find below the ssh output from ubuntu terminal.

 

$ ssh username@192.168.1.100
Unable to negotiate with 192.168.1.100 port 22: no matching key exchange method found. Their offer: diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1

 

Any suggestion?

 

Thanks in advance.

1 Accepted Solution

Accepted Solutions

Hi,

 

I have added the below to the config file along with one you have given.

Ciphers aes256-cbc,aes128-ctr,aes192-ctr,aes256-ctr,aes128-cbc,3des-cbc

 

Now it is working. Thanks

View solution in original post

4 Replies 4

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

 

how did you configure the SSH client ? You need to include the DH sha1 in the configuration file of your client. Post the content of the client configuration file...

Hi,

Please find below the ubuntu ssh config file:

$ cat /etc/ssh/ssh_config

# This is the ssh client system-wide configuration file. See
# ssh_config(5) for more information. This file provides defaults for
# users, and the values can be changed in per-user configuration files
# or on the command line.

# Configuration data is parsed as follows:
# 1. command line options
# 2. user-specific file
# 3. system-wide file
# Any configuration value is only changed the first time it is set.
# Thus, host-specific definitions should be at the beginning of the
# configuration file, and defaults at the end.

# Site-wide defaults for some commonly used options. For a comprehensive
# list of available options, their meanings and defaults, please see the
# ssh_config(5) man page.

Include /etc/ssh/ssh_config.d/*.conf

Host *
# ForwardAgent no
# ForwardX11 no
# ForwardX11Trusted yes
# PasswordAuthentication yes
# HostbasedAuthentication no
# GSSAPIAuthentication no
# GSSAPIDelegateCredentials no
# GSSAPIKeyExchange no
# GSSAPITrustDNS no
# BatchMode no
# CheckHostIP yes
# AddressFamily any
# ConnectTimeout 0
# StrictHostKeyChecking ask
# IdentityFile ~/.ssh/id_rsa
# IdentityFile ~/.ssh/id_dsa
# IdentityFile ~/.ssh/id_ecdsa
# IdentityFile ~/.ssh/id_ed25519
# Port 22
# Ciphers aes128-ctr,aes192-ctr,aes256-ctr,aes128-cbc,3des-cbc
# MACs hmac-md5,hmac-sha1,umac-64@openssh.com
# EscapeChar ~
# Tunnel no
# TunnelDevice any:any
# PermitLocalCommand no
# VisualHostKey no
# ProxyCommand ssh -q -W %h:%p gateway.example.com
# RekeyLimit 1G 1h
SendEnv LANG LC_*
HashKnownHosts yes
GSSAPIAuthentication yes

Hello,

 

you need to add the line below to your SSH config file:

 

KexAlgorithms +diffie-hellman-group1-sha1

Hi,

 

I have added the below to the config file along with one you have given.

Ciphers aes256-cbc,aes128-ctr,aes192-ctr,aes256-ctr,aes128-cbc,3des-cbc

 

Now it is working. Thanks

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers